Bug 331011 - Add "Recent Files" feature, plus merge with "Recent URLs" tab on start page
Summary: Add "Recent Files" feature, plus merge with "Recent URLs" tab on start page
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 4.11.4
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2014-02-11 12:47 UTC by Kevin Funk
Modified: 2014-11-28 20:27 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Funk 2014-02-11 12:47:30 UTC
As discussed with Agateau on IRC:
- Add a "Recent Files" entry to the File menu (I think that's a pre-made KDE component?)
- Replace the "Recent URLs" tab by "Recent Files" instead

Reproducible: Always
Comment 1 Aurelien Gateau 2014-02-12 09:10:41 UTC
Git commit bec4e1bf3f19d7693815f9f8140f3cbf02ad15a8 by Aurélien Gâteau, on behalf of Kevin Funk.
Committed on 12/02/2014 at 09:09.
Pushed by gateau into branch 'master'.

Add "Recent Files" menu item

REVIEW: 115659

M  +15   -1    app/mainwindow.cpp
M  +1    -0    app/mainwindow.h

http://commits.kde.org/gwenview/bec4e1bf3f19d7693815f9f8140f3cbf02ad15a8
Comment 2 Kevin Funk 2014-02-12 10:12:56 UTC
Reopening because there's still something left:
- Replace the "Recent URLs" tab by "Recent Files" instead
Comment 3 Sahil Sareen 2014-03-16 09:56:24 UTC
I want to take this up but will need some help as this is my first time on kde. 
I think I can change the "Recent URLs" to "Recent Files" and make it work.

-Sahil
Comment 4 Kevin Funk 2014-03-16 13:00:57 UTC
@Sahil: Just check out the gwenview source code and get familiar with the code.

I think Aurelien and me agreed on replacing the second tab by a "Recent Files" widget. That means, it should just show the *same* contents as the "File -> Open Recent" menu item instead of just URLs.

Just have a look at the patch at https://projects.kde.org/projects/kde/kdegraphics/gwenview/repository/revisions/bec4e1bf3f19d7693815f9f8140f3cbf02ad15a8/diff/app/mainwindow.cpp to see where the recent file entries are coming from.
Comment 5 Sahil Sareen 2014-08-09 11:59:06 UTC
Im still on it.

-Sahil
Comment 6 Tomas Mecir 2014-11-28 20:27:16 UTC
Git commit daabe27bb0b981922b5ad96406b5896ed5aa07a6 by Tomas Mecir.
Committed on 10/11/2014 at 08:26.
Pushed by mecir into branch 'master'.

Replace the 'Recent URLs' tab with a 'Recent Files' one, which shows the same files as the recently opened menu item does.

Motivation as per 331011 in bugzilla.

M  +11   -10   app/gvcore.cpp
M  +2    -2    app/gvcore.h
M  +4    -3    app/mainwindow.cpp
M  +30   -48   app/startmainpage.cpp
M  +2    -14   app/startmainpage.ui
M  +1    -0    lib/CMakeLists.txt
A  +111  -0    lib/recentfilesmodel.cpp     [License: GPL]
A  +61   -0    lib/recentfilesmodel.h     [License: GPL]

http://commits.kde.org/gwenview/daabe27bb0b981922b5ad96406b5896ed5aa07a6