Bug 330943 - new lens not detected
Summary: new lens not detected
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Editor-LensCorrection (show other bugs)
Version: 3.5.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-09 07:56 UTC by Marc Cousin
Modified: 2016-07-01 09:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.12.0


Attachments
the lens xml file (1.50 KB, text/xml)
2014-02-09 07:58 UTC, Marc Cousin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Cousin 2014-02-09 07:56:52 UTC
Hi,

I've been working with the lensfun project to add the 18-55 Fuji X lens. I cannot get digikam to detect it (it works with the lensfun gimp plugin).

I tried:
- Putting the xml file (attached) into .local/share/lensfun
- Putting it in /usr/share/lensfun
- Importing the full database from the svn version of lensfun (/.configure --prefix=/usr;make install data)

None of these work. Selecting my camera or any of its family (XE1,Xpro1, XE2…) doesn't display the lens. I only get the 4 generic lenses.

Reproducible: Always

Steps to Reproduce:
1. Import the lens xml file
2. Try to correct (image editor, enhance, lens/autocorrection)
3. Select Fujifim, XE1, the lens isn't displayed
Comment 1 Marc Cousin 2014-02-09 07:58:05 UTC
Created attachment 85057 [details]
the lens xml file
Comment 2 Marc Cousin 2014-02-17 13:31:12 UTC
Is there something I can add to this bug report ?

Regards
Comment 3 Marc Cousin 2014-04-27 07:18:20 UTC
Hi,

Any news on this ? How could I help ? It's a bit of a pity to have to go to gimp only for this part.

To sum up, try it like this (no need to add another file):

In gimp, with the gimp-lensfun plugin, select a fuji X-E1 for instance. You'll get about 10 different compatible lenses (with the current database).

In digikam, select the fuji X-E1, you'll only get 4 «standard» lenses.
Comment 4 Michael Reed 2014-06-12 11:08:24 UTC
I wonder if this could be related to a problem that I have had with Digikam and my current camera body?

Basically, my current camera body specifies itself as "OLYMPUS IMAGING CORP." rather than "Olympus Imaging Corp." in the metadata. This seems to confuse the software. 

To remedy it, I opened /usr/share/lensfun/mil-olympus.xml in a text editor (as root) and changed the <maker> field to upper case. Things seem to be working properly now. Note that it would crash while doing the lens correction if I had two entries that were identical other than the case of the <maker> field.

This gives an exact match for the E-PL5 body with its kit zoom. With the Olympus body and a Panasonic lens, it guesses wrong but the right lens is now available on the drop down.

I've had some other crashes with Digikam and files from this body, and I'll play around to see if this solves them.

Kubuntu: 14.04
Digikam: 4:4.0.0-0ubuntu1ppa0~trusty
liblensfun0: 0.2.8-1
Comment 5 caulier.gilles 2014-06-12 11:17:25 UTC
lens database loading is performed by Lensfun, not digiKam.

So this typo problem in XML must be relevant to lensfun data parser... Right ?

Gilles Caulier
Comment 6 Marc Cousin 2014-06-12 11:48:07 UTC
As said before, it works perfectly with gimp. Which also uses the lensfun data parser, doesn't it ?
Comment 7 caulier.gilles 2015-05-17 08:11:57 UTC
Marc,

Problem still reproducible using last digiKam 4.10.0 ?

Gilles Caulier
Comment 8 Marc Cousin 2015-06-20 08:18:56 UTC
Yes, it works now. Sorry for the delay.