Bug 330924 - Rating is lost after tagging and rating
Summary: Rating is lost after tagging and rating
Status: RESOLVED DUPLICATE of bug 259228
Alias: None
Product: digikam
Classification: Unclassified
Component: Tags-Rating (show other bugs)
Version: 4.0.0
Platform: Ubuntu Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-08 17:26 UTC by Sander van der Heijden
Modified: 2022-01-22 22:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sander van der Heijden 2014-02-08 17:26:51 UTC
When moving to the next image, after tagging and rating an image, the rating is lost. (Probably on automatically saving the tags on deselecting the image)

Reproducible: Always

Steps to Reproduce:
1. Select an image
2. Add one or more tags to the image
3. Add (or update) a rating to the image
4. Deselect the image
Actual Results:  
Tags are added to the image, but the added (or updated) rating is lost.

Expected Results:  
Both tags and rating should be added (or updated) to the image

Workarounds:
- Change order: First add rating and then tags
- Add tags, apply changes and then add rating
Comment 1 caulier.gilles 2014-06-16 12:30:47 UTC
This problem still exist using digiKam 4.0.0 release ?

Gilles Caulier
Comment 2 Sander van der Heijden 2014-06-20 19:25:39 UTC
(In reply to comment #1)
> This problem still exist using digiKam 4.0.0 release ?
> 
> Gilles Caulier

Yes, it still exists. I guess that upon saving the tags to the database/xmp file the rating is somehow ignored/lost?

Sander van der Heijden
Comment 3 caulier.gilles 2014-09-02 10:07:39 UTC

*** This bug has been marked as a duplicate of bug 259228 ***