Bug 330923 - Custom toolbar settings not loaded on start
Summary: Custom toolbar settings not loaded on start
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Usability-Ergonomy (show other bugs)
Version: 3.4.0
Platform: Ubuntu Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-08 17:13 UTC by Sander van der Heijden
Modified: 2017-08-10 12:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.1.0


Attachments
toolbar with custom actions (27.72 KB, image/png)
2014-02-08 18:17 UTC, Sander van der Heijden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sander van der Heijden 2014-02-08 17:13:28 UTC
When additional items are added to the toolbar, they are not shown after a restart of digiKam, although they are still correctly listed in the configure toolbar dialog window.

Reproducible: Always

Steps to Reproduce:
1. Choose configure toolbars (from settings menu or rightclick on toolbar)
2. Add additional items to the toolbar
3. Click apply 
4. The additional items appear in the toolbar
5. Restart digiKam
Actual Results:  
The additional items are not shown in the toolbar

Expected Results:  
The additional items should shown in the toolbar
Comment 1 caulier.gilles 2014-02-08 17:15:08 UTC
Toolbar from Image Editor or AlbumGUI ?

It's not reproducible here...

What do you host in your customized toolbar ? Any kipi-plugins actions ?
Comment 2 Sander van der Heijden 2014-02-08 18:17:55 UTC
Created attachment 85049 [details]
toolbar with custom actions
Comment 3 Sander van der Heijden 2014-02-08 18:19:06 UTC
(In reply to comment #1)
> Toolbar from Image Editor or AlbumGUI ?
> 
> It's not reproducible here...
> 
> What do you host in your customized toolbar ? Any kipi-plugins actions ?

Toolbar from AlbumGUI.
I've added actions for rating, flagging and color labels...
Comment 4 Sander van der Heijden 2014-02-08 18:20:32 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > Toolbar from Image Editor or AlbumGUI ?
> > 
> > It's not reproducible here...
> > 
> > What do you host in your customized toolbar ? Any kipi-plugins actions ?
> 
> Toolbar from AlbumGUI.
> I've added actions for rating, flagging and color labels...

See also the attachment.
Comment 5 Sander van der Heijden 2014-06-20 19:42:48 UTC
Seems to be fixed in 4.0.0...