Bug 330196 - Pressing semi-colon or dot crashes kate
Summary: Pressing semi-colon or dot crashes kate
Status: RESOLVED DUPLICATE of bug 328271
Alias: None
Product: kate
Classification: Unclassified
Component: application (show other bugs)
Version: 3.12.0
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-20 11:57 UTC by ajar108
Modified: 2014-01-20 13:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ajar108 2014-01-20 11:57:22 UTC
Application: kate (3.12.0)
KDE Platform Version: 4.12.0
Qt Version: 4.8.2
Operating System: Linux 3.2.0-58-generic x86_64
Distribution: Ubuntu 12.04.4 LTS

-- Information about the crash:
Whenever I open an already saved file and edit it, the moment I click the "." button or the ";" button kate crashes. The crash can be reproduced every time. I am submitting the backtrace I could generate on my machine. Please help.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1ccb2d3780 (LWP 7315))]

Thread 4 (Thread 0x7f1cb7a7a700 (LWP 7317)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f1cb82d2022 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f1cb82d2059 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f1cc81ffe9a in start_thread (arg=0x7f1cb7a7a700) at pthread_create.c:308
#4  0x00007f1ccac253fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f1c34505700 (LWP 7318)):
#0  0x00007f1ccac17ffd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f1cc7d6d8df in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1cc7d32b64 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1cc7d32f96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1cc7d33124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f1cc8af5926 in QEventDispatcherGlib::processEvents (this=0x7f1c2c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f1cc8ac4e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f1cc8ac50b7 in QEventLoop::exec (this=0x7f1c34504dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f1cc89c4077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f1cc8aa4b6f in QInotifyFileSystemWatcherEngine::run (this=0x2a3ffa0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f1cc89c709b in QThreadPrivate::start (arg=0x2a3ffa0) at thread/qthread_unix.cpp:307
#11 0x00007f1cc81ffe9a in start_thread (arg=0x7f1c34505700) at pthread_create.c:308
#12 0x00007f1ccac253fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f1c31745700 (LWP 7326)):
#0  0x00007f1ccac19a43 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1cc7d32ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1cc7d33124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1cc8af5926 in QEventDispatcherGlib::processEvents (this=0x7f1c240008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f1cc8ac4e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1cc8ac50b7 in QEventLoop::exec (this=0x7f1c31744dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f1cc89c4077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f1cc8aa4b6f in QInotifyFileSystemWatcherEngine::run (this=0x2ba5d10) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f1cc89c709b in QThreadPrivate::start (arg=0x2ba5d10) at thread/qthread_unix.cpp:307
#9  0x00007f1cc81ffe9a in start_thread (arg=0x7f1c31745700) at pthread_create.c:308
#10 0x00007f1ccac253fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1ccb2d3780 (LWP 7315)):
[KCrash Handler]
#6  0x00007f1cb893f301 in contextNum (n=<optimized out>, this=<optimized out>) at ../../part/syntax/katehighlight.h:267
#7  KateDocument::defStyleNum (this=<optimized out>, line=<optimized out>, column=<optimized out>) at ../../part/document/katedocument.cpp:5466
#8  0x00007f1cb8954d49 in KateScriptDocument::isString (this=<optimized out>, line=<optimized out>, column=<optimized out>) at ../../part/script/katescriptdocument.cpp:83
#9  0x00007f1cb88c61a5 in KateScriptDocument::qt_static_metacall (_o=0x2e495a0, _id=<optimized out>, _a=0x7fff8e27cf20, _c=<optimized out>) at moc_katescriptdocument.cpp:408
#10 0x00007f1cb88c722b in KateScriptDocument::qt_metacall (this=0x2e495a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8e27cf20) at moc_katescriptdocument.cpp:468
#11 0x00007f1cb833ed71 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#12 0x00007f1cb8340e0b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#13 0x00007f1cb834101a in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007f1cb824a770 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#15 0x00007f1cb82214e6 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#16 0x00007f1c371e7afb in ?? ()
#17 0x0000000000000000 in ?? ()

Reproducible: Always

Steps to Reproduce:
Whenever I open an already saved file and edit it.
click the "." button or the ";" button kate crashes. 
The crash can be reproduced every time.
Comment 1 Jekyll Wu 2014-01-20 13:20:37 UTC

*** This bug has been marked as a duplicate of bug 328271 ***