Bug 330187 - Kontact crash after restore from sleep
Summary: Kontact crash after restore from sleep
Status: RESOLVED DUPLICATE of bug 328680
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.11.5
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-20 07:33 UTC by hynek
Modified: 2014-01-20 10:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hynek 2014-01-20 07:33:19 UTC
Application: kontact (4.11.5)
KDE Platform Version: 4.11.5
Qt Version: 4.8.5
Operating System: Linux 3.12.7-200.fc19.x86_64 x86_64
Distribution: "Fedora release 19 (Schrödinger’s Cat)"

-- Information about the crash:
- What I was doing when the application crashed:
I have restored computer from sleep mode. The crash happened before I could do anything else. I could as well have happened right before the computer went into sleep, I am not certain about the timing.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
185	62:	movl	(%rsp), %edi
[Current thread is 1 (Thread 0x7f87778c88c0 (LWP 3622))]

Thread 5 (Thread 0x7f876a149700 (LWP 3640)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x0000003cf5acde2d in WTF::TCMalloc_PageHeap::scavengerThread (this=<optimized out>) at /usr/src/debug/webkit-qtwebkit-23/Source/WTF/wtf/FastMalloc.cpp:2571
#2  0x0000003cf5acde69 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at /usr/src/debug/webkit-qtwebkit-23/Source/WTF/wtf/FastMalloc.cpp:1767
#3  0x00000035c5e07c53 in start_thread (arg=0x7f876a149700) at pthread_create.c:308
#4  0x00000035c56f5dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f8729635700 (LWP 3642)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x0000003cf580e5bd in JSC::BlockAllocator::blockFreeingThreadMain (this=0x7f87698b3398) at /usr/src/debug/webkit-qtwebkit-23/Source/JavaScriptCore/heap/BlockAllocator.cpp:128
#2  0x0000003cf5afd686 in WTF::wtfThreadEntryPoint (param=0x267a0e0) at /usr/src/debug/webkit-qtwebkit-23/Source/WTF/wtf/ThreadingPthreads.cpp:196
#3  0x00000035c5e07c53 in start_thread (arg=0x7f8729635700) at pthread_create.c:308
#4  0x00000035c56f5dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f8713bbe700 (LWP 3706)):
#0  0x00000035c5e0e0bd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00000035c8e864f0 in g_wakeup_acknowledge () from /lib64/libglib-2.0.so.0
#2  0x00000035c8e47c0c in g_main_context_check () from /lib64/libglib-2.0.so.0
#3  0x00000035c8e4807b in g_main_context_iterate.isra.22 () from /lib64/libglib-2.0.so.0
#4  0x00000035c8e481ec in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#5  0x00000035cf7a7166 in QEventDispatcherGlib::processEvents (this=0x7f870c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00000035cf778ecf in QEventLoop::processEvents (this=this@entry=0x7f8713bbdd20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00000035cf7791c5 in QEventLoop::exec (this=this@entry=0x7f8713bbdd20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00000035cf67866f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#9  0x00000035cf67ad0f in QThreadPrivate::start (arg=0x2790830) at thread/qthread_unix.cpp:338
#10 0x00000035c5e07c53 in start_thread (arg=0x7f8713bbe700) at pthread_create.c:308
#11 0x00000035c56f5dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f870bfff700 (LWP 3731)):
[KCrash Handler]
#6  tcpses_is_read_ready (ses=0x7f870001bdb0, to=to@entry=0x7f870000b6f0) at Dksestcp.c:1024
#7  0x00007f8720759c05 in service_read (ses=ses@entry=0x7f870000b650, buffer=0x7f870000bd80 "\220\254\002", req_bytes=req_bytes@entry=32768, need_all=need_all@entry=0) at Dkses2.c:372
#8  0x00007f8720759e1a in session_buffered_read (ses=0x7f870000b650, buffer=buffer@entry=0x7f870bffe74f "", req_bytes=req_bytes@entry=1) at Dkses2.c:515
#9  0x00007f8720759eb3 in session_buffered_read_char (ses=ses@entry=0x7f870000b650) at Dkses2.c:582
#10 0x00007f8720757ee0 in scan_session_boxing (session=session@entry=0x7f870000b650) at Dkmarshal.c:769
#11 0x00007f8720758109 in read_object (session=session@entry=0x7f870000b650) at Dkmarshal.c:296
#12 0x00007f8720762680 in read_service_request_1t (ses=0x7f870000b650) at Dkernel.c:2277
#13 0x00007f87207632e8 in PrpcFutureNextResult1T (future=0x7f870001eb70) at Dkernel.c:4252
#14 PrpcFutureNextResult (future=0x7f870001eb70) at Dkernel.c:4084
#15 0x00007f872072f5ad in stmt_process_result (stmt=stmt@entry=0x7f870002bf80, needs_evl=needs_evl@entry=1) at ../../libsrc/Wi/CLIuti.c:719
#16 0x00007f872073394b in virtodbc__SQLFetch (hstmt=hstmt@entry=0x7f870002bf80, preserve_rowset_at_end=preserve_rowset_at_end@entry=1) at ../../libsrc/Wi/CLIsql1.c:1637
#17 0x00007f87207444ee in sql_ext_fetch_fwd (hstmt=hstmt@entry=0x7f870002bf80, pcrow=pcrow@entry=0x0, rgfRowStatus=rgfRowStatus@entry=0x0) at ../../libsrc/Wi/CLIcr.c:225
#18 0x00007f8720744689 in virtodbc__SQLExtendedFetch (hstmt=0x7f870002bf80, fFetchType=<optimized out>, irow=0, pcrow=0x0, rgfRowStatus=0x0, bookmark_offset=0) at ../../libsrc/Wi/CLIcr.c:378
#19 0x00007f872129f539 in SQLFetch_Internal (hstmt=hstmt@entry=0x7f870002aca0) at fetch.c:161
#20 0x00007f872129f7b2 in SQLFetch (hstmt=0x7f870002aca0) at fetch.c:230
#21 0x00007f87214f8c27 in Soprano::ODBC::QueryResult::fetchRow (this=0x7f8700024810) at /usr/src/debug/soprano-2.9.4/backends/virtuoso/odbcqueryresult.cpp:96
#22 0x00007f87214f19fc in Soprano::Virtuoso::QueryResultIteratorBackend::next (this=0x7f870001c3d0) at /usr/src/debug/soprano-2.9.4/backends/virtuoso/virtuosoqueryresultiteratorbackend.cpp:141
#23 0x0000003cf1e54fa0 in Soprano::Iterator<Soprano::BindingSet>::next (this=0x7f870bffeb30) at /usr/include/soprano/iterator.h:239
#24 0x0000003cf1e4f427 in Nepomuk2::ResourceData::load (this=this@entry=0x7f870001e770) at /usr/src/debug/nepomuk-core-4.11.5/libnepomukcore/resource/resourcedata.cpp:370
#25 0x0000003cf1e50409 in Nepomuk2::ResourceData::property (this=0x7f870001e770, uri=...) at /usr/src/debug/nepomuk-core-4.11.5/libnepomukcore/resource/resourcedata.cpp:242
#26 0x0000003cf1e5b6a9 in Nepomuk2::Resource::property (this=this@entry=0x7f870bffec90, uri=...) at /usr/src/debug/nepomuk-core-4.11.5/libnepomukcore/resource/resource.cpp:268
#27 0x0000003cfca1b585 in MessageCore::NepomukResourceRetrieverRunnable::run (this=0x3910b40) at /usr/src/debug/kdepim-4.11.5/messagecore/nepomukutil/asyncnepomukresourceretriever.cpp:50
#28 0x00000035cf66e83e in QThreadPoolThread::run (this=0x3910b70) at concurrent/qthreadpool.cpp:107
#29 0x00000035cf67ad0f in QThreadPrivate::start (arg=0x3910b70) at thread/qthread_unix.cpp:338
#30 0x00000035c5e07c53 in start_thread (arg=0x7f870bfff700) at pthread_create.c:308
#31 0x00000035c56f5dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f87778c88c0 (LWP 3622)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00000035cf67b1e6 in wait (time=18446744073709551615, this=0x3911310) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x39112e0, mutex=mutex@entry=0x39112b8, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000035cf66e252 in QThreadPoolPrivate::waitForDone (this=0x3911230, msecs=msecs@entry=-1) at concurrent/qthreadpool.cpp:298
#4  0x00000035cf66f5f5 in QThreadPool::~QThreadPool (this=0x390f0a8, __in_chrg=<optimized out>) at concurrent/qthreadpool.cpp:440
#5  0x0000003cfca1a359 in ~AsyncNepomukResourceRetrieverPrivate (this=<optimized out>, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.11.5/messagecore/nepomukutil/asyncnepomukresourceretriever.cpp:61
#6  MessageCore::AsyncNepomukResourceRetriever::~AsyncNepomukResourceRetriever (this=0x390e5e0, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.11.5/messagecore/nepomukutil/asyncnepomukresourceretriever.cpp:131
#7  0x0000003d00c3ef1a in ~CallbackNepomukResourceRetriever (this=0x390e5e0, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.11.5/messagelist/core/callbacknepomukresourceretriever.h:32
#8  MessageList::CallbackNepomukResourceRetriever::~CallbackNepomukResourceRetriever (this=0x390e5e0, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.11.5/messagelist/core/callbacknepomukresourceretriever.h:32
#9  0x00000035c5639279 in __run_exit_handlers (status=1, listp=0x35c59ba6e8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#10 0x00000035c56392c5 in __GI_exit (status=<optimized out>) at exit.c:99
#11 0x00000035d342ecb8 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:772
#12 0x0000003cee23e910 in KApplication::xioErrhandler (this=0x7fff3a65f190, dpy=0x24ea7b0) at /usr/src/debug/kdelibs-4.11.5/kdeui/kernel/kapplication.cpp:419
#13 0x00000035c7a43cce in _XIOError (dpy=dpy@entry=0x24ea7b0) at XlibInt.c:1498
#14 0x00000035c7a4169d in _XEventsQueued (dpy=dpy@entry=0x24ea7b0, mode=mode@entry=2) at xcb_io.c:366
#15 0x00000035c7a3378b in XEventsQueued (dpy=0x24ea7b0, mode=2) at Pending.c:43
#16 0x00000035d3464a7c in x11EventSourceCheck (s=0x24e35a0) at kernel/qguieventdispatcher_glib.cpp:85
#17 0x00000035c8e47b61 in g_main_context_check () from /lib64/libglib-2.0.so.0
#18 0x00000035c8e4807b in g_main_context_iterate.isra.22 () from /lib64/libglib-2.0.so.0
#19 0x00000035c8e481ec in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#20 0x00000035cf7a7166 in QEventDispatcherGlib::processEvents (this=0x24a1ee0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#21 0x00000035d3465016 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#22 0x00000035cf778ecf in QEventLoop::processEvents (this=this@entry=0x7fff3a65f090, flags=...) at kernel/qeventloop.cpp:149
#23 0x00000035cf7791c5 in QEventLoop::exec (this=this@entry=0x7fff3a65f090, flags=...) at kernel/qeventloop.cpp:204
#24 0x00000035cf77e45b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#25 0x00000035d33c6cec in QApplication::exec () at kernel/qapplication.cpp:3823
#26 0x0000000000403760 in main (argc=3, argv=0x7fff3a65f2d8) at /usr/src/debug/kdepim-4.11.5/kontact/src/main.cpp:219

The reporter indicates this bug may be a duplicate of or related to bug 328680.

Possible duplicates by query: bug 328680.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-20 10:21:14 UTC

*** This bug has been marked as a duplicate of bug 328680 ***