Bug 330176 - kate crashed when typing the character '/' in a text (ASCII) file
Summary: kate crashed when typing the character '/' in a text (ASCII) file
Status: RESOLVED DUPLICATE of bug 328271
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: 3.11.4
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-19 23:39 UTC by Cezar Tigaret
Modified: 2014-01-20 02:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.55 KB, text/plain)
2014-01-19 23:58 UTC, Cezar Tigaret
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cezar Tigaret 2014-01-19 23:39:06 UTC
Application: kate (3.11.4)
KDE Platform Version: 4.11.4
Qt Version: 4.8.5
Operating System: Linux 3.11.6-4-desktop x86_64
Distribution: "openSUSE 13.1 (Bottle) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
simply editing a newly created text file

- Custom settings of the application:
kate started in anonymous session; syntax highlighting: none

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb40b86e780 (LWP 1686))]

Thread 5 (Thread 0x7fb3e85a9700 (LWP 1687)):
#0  0x00007fb408ed3b3d in poll () from /lib64/libc.so.6
#1  0x00007fb405de7604 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fb405de770c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fb40a536d76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007fb40a508d0f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007fb40a509005 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007fb40a407fef in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007fb40a4ea513 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007fb40a40a68f in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007fb40a1730db in start_thread () from /lib64/libpthread.so.0
#10 0x00007fb408edc90d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fb3e7da8700 (LWP 1689)):
#0  0x00007fb405e26ffd in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fb405e27289 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fb405de6cb9 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fb405de7523 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fb405de770c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fb40a536d76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007fb40a508d0f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#7  0x00007fb40a509005 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#8  0x00007fb40a407fef in QThread::exec() () from /usr/lib64/libQtCore.so.4
#9  0x00007fb40a4ea513 in ?? () from /usr/lib64/libQtCore.so.4
#10 0x00007fb40a40a68f in ?? () from /usr/lib64/libQtCore.so.4
#11 0x00007fb40a1730db in start_thread () from /lib64/libpthread.so.0
#12 0x00007fb408edc90d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fb3e75a7700 (LWP 1690)):
#0  0x00007fb40a1770af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fb3fc2f98cb in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fb3fc5f7f00 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fb3fc2f9909 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fb40a1730db in start_thread () from /lib64/libpthread.so.0
#4  0x00007fb408edc90d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fb3e577f700 (LWP 1691)):
#0  0x00007fb40a1770af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fb40a40ab66 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007fb3ec46757d in ?? () from /usr/lib64/kde4/ktexteditor_klf.so
#3  0x00007fb40a40a68f in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007fb40a1730db in start_thread () from /lib64/libpthread.so.0
#5  0x00007fb408edc90d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fb40b86e780 (LWP 1686)):
[KCrash Handler]
#5  0x00007fb3ed00ab10 in contextNum (n=<optimized out>, this=<optimized out>) at /usr/src/debug/kate-4.11.4/part/syntax/katehighlight.h:267
#6  KateDocument::defStyleNum (this=0x1580190, line=<optimized out>, column=<optimized out>) at /usr/src/debug/kate-4.11.4/part/document/katedocument.cpp:5376
#7  0x00007fb3ed032389 in KateScriptDocument::defStyleNum (this=<optimized out>, line=<optimized out>, column=<optimized out>) at /usr/src/debug/kate-4.11.4/part/script/katescriptdocument.cpp:51
#8  0x00007fb3ed032409 in KateScriptDocument::isString (this=<optimized out>, line=<optimized out>, column=<optimized out>) at /usr/src/debug/kate-4.11.4/part/script/katescriptdocument.cpp:83
#9  0x00007fb3ecfb04cd in KateScriptDocument::qt_static_metacall (_o=0x2d37c90, _id=176617760, _id@entry=90, _a=0x7fff9d7e0d60, _c=<optimized out>) at /usr/src/debug/kate-4.11.4/build/part/moc_katescriptdocument.cpp:405
#10 0x00007fb3ecfb1543 in qt_static_metacall (_a=0x7fff9d7e0d60, _id=90, _c=QMetaObject::InvokeMetaMethod, _o=0x2d37c90) at /usr/src/debug/kate-4.11.4/build/part/moc_katescriptdocument.cpp:466
#11 KateScriptDocument::qt_metacall (this=0x2d37c90, _c=QMetaObject::InvokeMetaMethod, _id=90, _a=0x7fff9d7e0d60) at /usr/src/debug/kate-4.11.4/build/part/moc_katescriptdocument.cpp:467
#12 0x00007fb3fc36551d in QScript::callQtMethod (exec=exec@entry=0x7fb3573ff1b0, callType=callType@entry=QMetaMethod::Method, thisQObject=thisQObject@entry=0x2d37c90, scriptArgs=..., meta=meta@entry=0x7fb3ed3b6ce0 <KateScriptDocument::staticMetaObject>, initialIndex=95, maybeOverloaded=true) at bridge/qscriptqobject.cpp:960
#13 0x00007fb3fc3666c9 in QScript::QtFunction::execute (this=this@entry=0x7fb3e4306540, exec=0x7fb3573ff1b0, thisValue=..., thisValue@entry=..., scriptArgs=...) at bridge/qscriptqobject.cpp:1015
#14 0x00007fb3fc366959 in QScript::QtFunction::call (exec=0x7fb3573ff1b0, callee=0x7fb3e4306540, thisValue=..., args=...) at bridge/qscriptqobject.cpp:1030
#15 0x00007fb3fc26bdc8 in QTJSC::NativeFuncWrapper::operator() (this=this@entry=0x7fff9d7e0f80, exec=0x7fb3573ff1b0, jsobj=jsobj@entry=0x7fb3e4306540, thisValue=..., argList=...) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/CallData.cpp:46
#16 0x00007fb3fc249d50 in QTJSC::cti_op_call_NotJSFunction (args=0x7fff9d7e0fd0) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:1780
#17 0x00007fb3580891a9 in ?? ()
#18 0x0000000000000000 in ?? ()

Possible duplicates by query: bug 328885, bug 328271.

Reported using DrKonqi
Comment 1 Cezar Tigaret 2014-01-19 23:58:02 UTC
Created attachment 84734 [details]
New crash information added by DrKonqi

kwrite (4.11.4) on KDE Platform 4.11.4 using Qt 4.8.5

- What I was doing when the application crashed:
just typing in a newly created text file
- Custom settings of the application: 
files are set to be saved as UTF-8 encoding (the default on my distro)

-- Backtrace (Reduced):
#5  0x00007fb3ed265b10 in contextNum (n=<optimized out>, this=<optimized out>) at /usr/src/debug/kate-4.11.4/part/syntax/katehighlight.h:267
#6  KateDocument::defStyleNum (this=0x1578b20, line=<optimized out>, column=<optimized out>) at /usr/src/debug/kate-4.11.4/part/document/katedocument.cpp:5376
#7  0x00007fb3ed28d389 in KateScriptDocument::defStyleNum (this=<optimized out>, line=<optimized out>, column=<optimized out>) at /usr/src/debug/kate-4.11.4/part/script/katescriptdocument.cpp:51
#8  0x00007fb3ed28d409 in KateScriptDocument::isString (this=<optimized out>, line=<optimized out>, column=<optimized out>) at /usr/src/debug/kate-4.11.4/part/script/katescriptdocument.cpp:83
#9  0x00007fb3ed20b4cd in KateScriptDocument::qt_static_metacall (_o=0x13c9330, _id=176617760, _id@entry=90, _a=0x7fff9d7e0ea0, _c=<optimized out>) at /usr/src/debug/kate-4.11.4/build/part/moc_katescriptdocument.cpp:405
Comment 2 Jekyll Wu 2014-01-20 02:07:02 UTC

*** This bug has been marked as a duplicate of bug 328271 ***