Bug 330121 - kmail save as over sftp or webdav does not work
Summary: kmail save as over sftp or webdav does not work
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-18 13:33 UTC by bernward-bielawski
Modified: 2017-01-07 22:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bernward-bielawski 2014-01-18 13:33:59 UTC
after new installation of ubuntu 12.04 and installation of Kmail 8.8.5 the feature " save as to network folder f.e SFTP or webdavs does not work.

it does not show an error and doesn't write the file.

before I had ubuntu 10.04 with kmail 1.13.5 the feature save as over sftp worked without any problems

who can help


Reproducible: Always

Steps to Reproduce:
1.makeing a network folder over dolphin and sftp
2.in kmail taken a mail an save as
3. destination the target in menue ... network ec....
4. ok no error comment
5. no result no file saved but works on lokal destinations
Comment 1 Laurent Montel 2014-01-18 15:04:45 UTC
I don't understand
What do you want to save ? an email ? an attachment ? etc.
Comment 2 bernward-bielawski 2014-01-18 15:58:24 UTC
The attachment can be saved but not the mail



Am Samstag, 18. Januar 2014, 15:04:45 schrieben Sie:
> https://bugs.kde.org/show_bug.cgi?id=330121
> 
> Laurent Montel <montel@kde.org> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
> CC|                            |montel@kde.org
> 
> --- Comment #1 from Laurent Montel <montel@kde.org> ---
> I don't understand
> What do you want to save ? an email ? an attachment ? etc.
Comment 3 Laurent Montel 2014-01-19 11:39:31 UTC
I will investigate it.
Comment 4 Laurent Montel 2014-01-20 07:32:05 UTC
Git commit 830f32ff5a7e78e58dc9bedceca476b7eff39f2a by Montel Laurent.
Committed on 20/01/2014 at 07:31.
Pushed by mlaurent into branch 'KDE/4.12'.

Inform when we want to save file to network

M  +40   -28   messageviewer/utils/util.cpp

http://commits.kde.org/kdepim/830f32ff5a7e78e58dc9bedceca476b7eff39f2a
Comment 5 Laurent Montel 2014-01-20 07:32:44 UTC
We can't fix it because we need to break API in kdepimlibs
But now we inform when we try to save in network.
Comment 6 Denis Kurz 2016-09-24 18:09:51 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 7 Denis Kurz 2017-01-07 22:29:35 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.