Bug 330078 - Akonadi crash when trying to authorize Google account
Summary: Akonadi crash when trying to authorize Google account
Status: RESOLVED DUPLICATE of bug 326594
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Google Resource (show other bugs)
Version: 4.11
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-17 14:37 UTC by Michael Rydén
Modified: 2014-01-17 21:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Rydén 2014-01-17 14:37:24 UTC
Application: akonadi_googlecalendar_resource (4.11)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
When trying to add new Google account the webpage shows up. After I loged in and accepted the request it tried to authorize the tokens, and then it crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Google kalendrar och uppgifter (miry2510@gmail.com) av typ Google kalendrar och uppgifter (akonadi_googlecalendar_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe953f397c0 (LWP 7513))]

Thread 5 (Thread 0x7fe93729f700 (LWP 7572)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fe9498871cd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fe949887209 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fe94d581f6e in start_thread (arg=0x7fe93729f700) at pthread_create.c:311
#4  0x00007fe9501bc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7fe8f6994700 (LWP 7573)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:238
#1  0x00007fe9498b7056 in WTF::ThreadCondition::timedWait(WTF::Mutex&, double) () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fe9495c7b4a in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fe9498b6a76 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#4  0x00007fe94d581f6e in start_thread (arg=0x7fe8f6994700) at pthread_create.c:311
#5  0x00007fe9501bc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7fe8f5b9b700 (LWP 7574)):
#0  0x00007fe9501aff7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe94cea46a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe94cea47ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe953058a76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007fe95302a5ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fe95302a8e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fe952f2988f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fe952f2bf2f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fe94d581f6e in start_thread (arg=0x7fe8f5b9b700) at pthread_create.c:311
#9  0x00007fe9501bc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fe8effff700 (LWP 7575)):
#0  0x00007fe94cee40ea in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fe94cee43c9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe94cea45b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe94cea47ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe953058a76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fe95302a5ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fe95302a8e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fe952f2988f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fe95300bd13 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fe952f2bf2f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007fe94d581f6e in start_thread (arg=0x7fe8effff700) at pthread_create.c:311
#11 0x00007fe9501bc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fe953f397c0 (LWP 7513)):
[KCrash Handler]
#5  0x00007fe950d19854 in typeinfo name for KIconLoader () from /usr/lib/libkdeui.so.5
#6  0x00007fe9510915a7 in KGAPI2::AuthWidget::Private::emitError(KGAPI2::Error, QString const&) () from /usr/lib/x86_64-linux-gnu/libkgapi2.so.2
#7  0x00007fe951092582 in KGAPI2::AuthWidget::Private::accountInfoReceived(KGAPI2::Job*) () from /usr/lib/x86_64-linux-gnu/libkgapi2.so.2
#8  0x00007fe95303fa58 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fe9510225ff in KGAPI2::Job::finished(KGAPI2::Job*) () from /usr/lib/x86_64-linux-gnu/libkgapi2.so.2
#10 0x00007fe953043dce in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007fe9523c8dfc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#12 0x00007fe9523cf470 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#13 0x00007fe950bc5a6a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#14 0x00007fe95302b8bd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#15 0x00007fe95302ee1f in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#16 0x00007fe953059073 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#17 0x00007fe94cea43b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007fe94cea4708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fe94cea47ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fe953058a55 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#21 0x00007fe95246a9d6 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#22 0x00007fe95302a5ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#23 0x00007fe95302a8e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#24 0x00007fe95286f38c in QDialog::exec() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#25 0x000000000040f6a7 in _start ()

Reported using DrKonqi
Comment 1 Michael Rydén 2014-01-17 14:49:02 UTC
Think this bug came from that akonadi-kde-resource-googledata wasn't installed by default in my system. After I installed akonadi-kde-resource-googledata, the authorization worked.
Comment 2 Jekyll Wu 2014-01-17 21:17:22 UTC

*** This bug has been marked as a duplicate of bug 326594 ***