Bug 330062 - Import from MTP or PTP based cameras is very slow
Summary: Import from MTP or PTP based cameras is very slow
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Gphoto2 (show other bugs)
Version: 3.5.0
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-17 10:17 UTC by Philippe ROUBACH
Modified: 2017-08-15 22:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2014-01-17 10:17:17 UTC
cpu : AMD Athlon 64 dual core 5000+ , 8 GB
opensuse 13.1 x86_64 , digikam 3.5
samsung SII P , android 4.2.2

ptp,mtp protocol

- gwenview
import
it's a matter of a few second <- very handy

- list of photos and videos

photos and videos from my camera are at the top <- very handy

 -digikam
import
it's a matter of minute , not handy at all
50 % cpu power
digikam completely freezed (not crashed)
 
photos and videos from my camera are at the bottom <- not handy

slider response is very slow <- not handy

digikam is oriented to camera then why scanning all internal and sd card storage ?

here the list of all folders digikam presents :

store_00010001
data
com.android.email
com.google.android.apps.maps
com.google.android.talk
com.sec.android.gallery.3d
cache
samsung
audio
osmand
voice
voice
voice
voice
voice
voice

store_00020002
store_00020002
DCIM

it would be enough to scan only these folders for a camera oriented app :

internal storage/ DCIM/
sd card storage/DCIM

why listing music , icon ? it's not relevant for camera oriented app . no ?

i know that for some smartphones (nokia 5800) videos are not stored in DCIM

perhaps a solution is an option to scan :
all the storages 
or
only the folders internal storage/ DCIM/ , sd card storage/DCIM/
or
the user fills a list of what folders he wants

a fast solution can be
all the storages 
or
only the folders internal storage/ DCIM/ , sd card storage/DCIM/

thanks
 

Reproducible: Always
Comment 1 caulier.gilles 2014-01-17 10:18:35 UTC
Huge improvements have been done in import tool with-beta release few days ago. Please take a look

Gilles Caulier
Comment 2 Philippe ROUBACH 2014-04-25 09:22:51 UTC
digikam 4.0.0 beta 4
kde 4.12.4

pb still there .

i discover this with kde 4.12.4 :
in dolphin we access to the smartphone via "mtp:<name of the smartphone>"

mtp displays 2 devices : "card" and "phone"

mtp lets the user running very fast across the 2 trees

there is 2 difficulties :
-  the user must know where are the photos and videos taken with smartphone camera . in case of android he must know photos and videos are in "DCIM" folder in the "phone" or in "card" if user chooses in "photo" app to store them in "card" .
- there is no preview .

i think it is an interesting alternative way to procede if the 2 difficulties are solved
Comment 3 Philippe ROUBACH 2014-06-07 13:00:53 UTC
opensuse x86_64 13.1
kde 4.13.1
digikam 4.0.0

no progress for mtp and ptp it is very slow

my solution today (no more cable) :
android 4.2.2 + primitiveftpd (ftp server to share internal and external storage)

my smartphone and my pc connected with wifi to the same network 

the sole pb with this solution is that "import from a remote computer" is less feature rich that "import from a camera"
Comment 4 caulier.gilles 2014-09-01 08:07:16 UTC
Philippe,

This file still valid using last digiKam 4.2.0 ?

Gilles Caulier
Comment 5 caulier.gilles 2015-05-12 13:36:05 UTC
Philippe,

This file still valid using last digiKam 4.9.0 ?

Gilles Caulier
Comment 6 caulier.gilles 2015-06-29 17:45:58 UTC
New digiKam 4.11.0 is available with official PKG installer for OSX.

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?

Gilles Caulier
Comment 7 caulier.gilles 2015-08-20 06:54:17 UTC
digiKam 4.12.0 is out :

https://www.digikam.org/node/741

We need a fresh feedback using this release please...
Thanks in advance.

Gilles Caulier
Comment 8 caulier.gilles 2016-07-15 16:17:57 UTC
Philippe,
digiKam 5.0.0 is released.
Problem  still valid with this release ?
Gilles Caulier
Comment 9 caulier.gilles 2016-11-21 16:04:25 UTC
We need feedback with last digiKam AppImage Linux Bundle:

https://drive.google.com/open?id=0BzeiVr-byqt5Y0tIRWVWelRJenM

Gilles Caulier
Comment 10 caulier.gilles 2016-11-26 10:34:30 UTC
This problem still reproducible using digiKam AppImage bundle 5.4.0 pre release
?

It available at this url :

https://drive.google.com/drive/folders/0BzeiVr-byqt5Y0tIRWVWelRJenM

Gilles Caulier
Comment 11 Philippe ROUBACH 2016-11-26 11:49:26 UTC
with 5.4

it is no more slow but it remains a problem:

why listing all folders instead of the one whom digikam is aware : DCIM/camera or better the tree DCIM because under DCIM many different folders are created by camera apps as "100ANDRO", "Camera", "OpenCamera" etc.
Comment 12 caulier.gilles 2016-11-26 12:55:50 UTC
because DCIM is the standard root dir. Sub directories can be different for some device.

Starting to scan from DCIM will work on all cases.

Of course a future work to customize this patch for each camera set in digiKam can be a solution. See bug #168253.

This is another point to talk in #168253

Gilles Caulier
Comment 13 Philippe ROUBACH 2016-11-26 13:37:36 UTC
i didn't well explain about MTP

1. digikam display many many folders apart Camera folder. read again description of the report

i know it's not digikam but the MTP protocol.

only Camera folder is useful for digikam.

it would be better if digikam filters result of MTP and retains only Camera

Camera is drowned among many folders.

2. digikam(?) displays "Camera" folder

it would be better to display "DCIM"
because "Camera" is a not a standard folder to store photos by camera apps

there is no standard folder in android to store photos by camera apps

with android
some app store by default photos in DCIM/100ANDRO/
some app store by default photos in DCIM/Camera/
some app store by default photos in DCIM/OpenCamera/
etc.