Bug 330022 - File manager crashed while trying to rename a file
Summary: File manager crashed while trying to rename a file
Status: RESOLVED DUPLICATE of bug 325359
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.11.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-16 11:27 UTC by Ali Alawami
Modified: 2014-01-17 08:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ali Alawami 2014-01-16 11:27:27 UTC
Application: konqueror (4.11.3)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

I clicked F2 to rename a file, then used the keyboard shortcut to paste the new file name.

-- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fccaf1a07c0 (LWP 26669))]

Thread 3 (Thread 0x7fcc99e92700 (LWP 26672)):
#0  0x00007fccaea006bd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fcca797e670 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcca793f1cc in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcca793f63b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcca793fb0a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fcca18eab66 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#6  0x00007fcca79640f5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fcca7e17f6e in start_thread (arg=0x7fcc99e92700) at pthread_create.c:311
#8  0x00007fccaea0e9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fcc98dc8700 (LWP 26673)):
#0  0x00007fcca797f0e7 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fcca797f3c9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcca793ed40 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcca793f5c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcca793f7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fcca793f7f9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fcca79640f5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fcca7e17f6e in start_thread (arg=0x7fcc98dc8700) at pthread_create.c:311
#8  0x00007fccaea0e9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fccaf1a07c0 (LWP 26669)):
[KCrash Handler]
#5  0x00007fcc859814fe in KFileItemModel::lessThan(KFileItemModel::ItemData const*, KFileItemModel::ItemData const*) const () from /usr/lib/libdolphinprivate.so.4
#6  0x00007fcc85985b52 in KFileItemModel::emitItemsChangedAndTriggerResorting(QList<KItemRange> const&, QSet<QByteArray> const&) () from /usr/lib/libdolphinprivate.so.4
#7  0x00007fcc8598629a in KFileItemModel::setData(int, QHash<QByteArray, QVariant> const&) () from /usr/lib/libdolphinprivate.so.4
#8  0x00007fcc859cb30c in DolphinView::slotRoleEditingFinished(int, QByteArray const&, QVariant const&) () from /usr/lib/libdolphinprivate.so.4
#9  0x00007fcc859d00f3 in ?? () from /usr/lib/libdolphinprivate.so.4
#10 0x00007fccab63fa58 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007fcc859a17eb in KItemListView::roleEditingFinished(int, QByteArray const&, QVariant const&) () from /usr/lib/libdolphinprivate.so.4
#12 0x00007fcc859a181a in KItemListView::slotRoleEditingFinished(int, QByteArray const&, QVariant const&) () from /usr/lib/libdolphinprivate.so.4
#13 0x00007fccab63fa58 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#14 0x00007fcc859ad06b in KItemListWidget::roleEditingFinished(int, QByteArray const&, QVariant const&) () from /usr/lib/libdolphinprivate.so.4
#15 0x00007fcc859b03ee in KStandardItemListWidget::slotRoleEditingFinished(QByteArray const&, QVariant const&) () from /usr/lib/libdolphinprivate.so.4
#16 0x00007fccab63fa58 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#17 0x00007fcc859bc617 in KItemListRoleEditor::roleEditingFinished(QByteArray const&, QVariant const&) () from /usr/lib/libdolphinprivate.so.4
#18 0x00007fcc859bc67f in KItemListRoleEditor::emitRoleEditingFinished() () from /usr/lib/libdolphinprivate.so.4
#19 0x00007fcc859bc855 in KItemListRoleEditor::keyPressEvent(QKeyEvent*) () from /usr/lib/libdolphinprivate.so.4
#20 0x00007fccac06c1ea in QWidget::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#21 0x00007fccac40d5be in QFrame::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#22 0x00007fccac48977b in QAbstractScrollArea::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#23 0x00007fccac4761ba in QTextEdit::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#24 0x00007fccac01cdfc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#25 0x00007fccac0246c1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#26 0x00007fccacd26a6a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#27 0x00007fccab62b8bd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#28 0x00007fccac0bbe19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#29 0x00007fccac0bc1b9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#30 0x00007fccac096207 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#31 0x00007fccac0be922 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#32 0x00007fcca793f3b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007fcca793f708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007fcca793f7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007fccab658a55 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#36 0x00007fccac0be9d6 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#37 0x00007fccab62a5ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#38 0x00007fccab62a8e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#39 0x00007fccab62fe5b in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#40 0x00007fccaed8e126 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_konqueror.so
#41 0x00007fccae935de5 in __libc_start_main (main=0x4006d0, argc=3, ubp_av=0x7fff654ad968, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff654ad958) at libc-start.c:260
#42 0x00000000004006fe in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2014-01-16 21:31:58 UTC
I guess this is bug 325359 (should be fixed in 4.12)
Comment 2 Frank Reininghaus 2014-01-17 08:33:20 UTC
Yes, you are probably right.

If the problem is still reproducible after upgrading to 4.12.1 or later, please let us know. Thanks!

*** This bug has been marked as a duplicate of bug 325359 ***