Bug 329923 - KMix crashes while shutting down the system
Summary: KMix crashes while shutting down the system
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: kmix
Classification: Applications
Component: general (show other bugs)
Version: 4.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-13 19:35 UTC by Jacobtey
Modified: 2014-01-16 15:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.26 KB, text/plain)
2014-01-16 15:44 UTC, Sadako Sasaki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacobtey 2014-01-13 19:35:39 UTC
Application: kmix (4.4)
KDE Platform Version: 4.12.0
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed: Not at all, just system shut down. Sometimes it crashes also plasma-desktop.

-- Backtrace:
Application: KMix (kmix), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f922ea187c0 (LWP 1636))]

Thread 3 (Thread 0x7f920d201700 (LWP 1646)):
#0  0x00007fff71194a2f in clock_gettime ()
#1  0x00007f922e2f196d in clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f922b017757 in do_gettime (frac=0x7f920d200b00, sec=0x7f920d200af8) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f922b0f0fe5 in updateCurrentTime (this=0x7f9208002860) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0x7f9208002860, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0x00007f922b0ef82c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f920d200bb4) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f922b0ef8d5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f922371cd4d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f922371d5c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f922371d7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f922b0efa76 in QEventDispatcherGlib::processEvents (this=0x7f92080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f922b0c15ef in QEventLoop::processEvents (this=this@entry=0x7f920d200d70, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f922b0c18e5 in QEventLoop::exec (this=this@entry=0x7f920d200d70, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f922afc088f in QThread::exec (this=this@entry=0x122e4e0) at thread/qthread.cpp:542
#15 0x00007f922b0a2d13 in QInotifyFileSystemWatcherEngine::run (this=0x122e4e0) at io/qfilesystemwatcher_inotify.cpp:265
#16 0x00007f922afc2f2f in QThreadPrivate::start (arg=0x122e4e0) at thread/qthread_unix.cpp:338
#17 0x00007f922429bf6e in start_thread (arg=0x7f920d201700) at pthread_create.c:311
#18 0x00007f922e2dc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f9207fff700 (LWP 1682)):
#0  0x00007f922e85fac4 in __tls_get_addr (ti=0x7f922b426a50) at dl-tls.c:777
#1  0x00007f922afc1c44 in get_thread_data () at thread/qthread_unix.cpp:182
#2  QThreadData::current () at thread/qthread_unix.cpp:208
#3  0x00007f922b0ef981 in postEventSourcePrepare (s=0x7f92000012d0, timeout=0x7f9207ffebb4) at kernel/qeventdispatcher_glib.cpp:256
#4  0x00007f922371cd4d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f922371d5c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f922371d7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f922b0efa76 in QEventDispatcherGlib::processEvents (this=0x7f92000008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#8  0x00007f922b0c15ef in QEventLoop::processEvents (this=this@entry=0x7f9207ffed70, flags=...) at kernel/qeventloop.cpp:149
#9  0x00007f922b0c18e5 in QEventLoop::exec (this=this@entry=0x7f9207ffed70, flags=...) at kernel/qeventloop.cpp:204
#10 0x00007f922afc088f in QThread::exec (this=this@entry=0x11750d0) at thread/qthread.cpp:542
#11 0x00007f922b0a2d13 in QInotifyFileSystemWatcherEngine::run (this=0x11750d0) at io/qfilesystemwatcher_inotify.cpp:265
#12 0x00007f922afc2f2f in QThreadPrivate::start (arg=0x11750d0) at thread/qthread_unix.cpp:338
#13 0x00007f922429bf6e in start_thread (arg=0x7f9207fff700) at pthread_create.c:311
#14 0x00007f922e2dc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f922ea187c0 (LWP 1636)):
[KCrash Handler]
#6  0x00007f922bf20f79 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1460310, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f922bf20ff9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1460310, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f922bf3934c in QWidgetBackingStore::~QWidgetBackingStore (this=0x1460640, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f922bd71e09 in QWidgetBackingStoreTracker::destroy (this=0x1460590) at kernel/qwidget.cpp:221
#10 0x00007f922bd71fa9 in QWidgetPrivate::deleteExtra (this=this@entry=0x11f1020) at kernel/qwidget.cpp:1835
#11 0x00007f922bd721bd in QWidgetPrivate::~QWidgetPrivate (this=0x11f1020, __in_chrg=<optimized out>) at kernel/qwidget.cpp:361
#12 0x00007f922bd72449 in QWidgetPrivate::~QWidgetPrivate (this=0x11f1020, __in_chrg=<optimized out>) at kernel/qwidget.cpp:366
#13 0x00007f922b0db8e5 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x12415a8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x12415a0, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0x00007f922bd7abcc in QWidget::~QWidget (this=0x12415a0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1556
#17 0x00007f922bd7ae49 in QWidget::~QWidget (this=0x12415a0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1705
#18 0x00007f922c2c9f75 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f922c816180 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1950
#19 0x00007f922e21e071 in __run_exit_handlers (status=0, listp=0x7f922e5a36a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#20 0x00007f922e21e0f5 in __GI_exit (status=<optimized out>) at exit.c:99
#21 0x00007f922e203dec in __libc_start_main (main=0x4006d0, argc=3, ubp_av=0x7fff7103cd68, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7103cd58) at libc-start.c:294
#22 0x00000000004006fe in _start ()

Possible duplicates by query: bug 327798, bug 320766.

Reported using DrKonqi
Comment 1 Christoph Feck 2014-01-14 01:47:04 UTC

*** This bug has been marked as a duplicate of bug 261539 ***
Comment 2 Sadako Sasaki 2014-01-16 15:44:42 UTC
Created attachment 84669 [details]
New crash information added by DrKonqi

kmix (4.4) on KDE Platform 4.12.0 using Qt 4.8.4

- What I was doing when the application crashed:
I tried to shotdown the System and then the kmix application killed himself

-- Backtrace (Reduced):
#7  0xb63df282 in QRasterWindowSurface::~QRasterWindowSurface (this=0x8ed2d78, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#8  0xb63df30c in QRasterWindowSurface::~QRasterWindowSurface (this=0x8ed2d78, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#9  0xb63fa154 in QWidgetBackingStore::~QWidgetBackingStore (this=<optimized out>, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#10 0xb6208683 in QWidgetBackingStoreTracker::destroy (this=0x90bd8e8) at kernel/qwidget.cpp:221
#11 0xb6208838 in QWidgetPrivate::deleteExtra (this=this@entry=0x8e9b850) at kernel/qwidget.cpp:1835