Bug 329848 - Akonadi resource crashes
Summary: Akonadi resource crashes
Status: RESOLVED DUPLICATE of bug 326242
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.11
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-11 13:19 UTC by Geert Janssens
Modified: 2014-01-12 00:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geert Janssens 2014-01-11 13:19:12 UTC
Application: akonadi_imap_resource (4.11)
KDE Platform Version: 4.11.5
Qt Version: 4.8.5
Operating System: Linux 3.12.6-300.fc20.i686+PAE i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
I simply opened kontact on a Fedora system. This  worked fine about a week and a half ago. I have been away for that time, so yesterday was the first time this pc was started again. Since then I get this crash report when starting kontact.

- Additional comments:
There have been no system changes that I'm aware of between the last time it worked  a wee and a half ago and the time it starts crashing.

Whenever I close the crash report assistent, the same crash report assistant pops up again. I assume akonadi detects the resource has crashed and automatically restarts it, repeating the cycle.

All similar reports the crash assistant found do point at the same bug report. I don't know enough about the internals of akonadi to estimate if this is a duplicate or not. Especially since the bug was closed in kde 4.8 and I'm running kde 4.11.5. So to be on the safe side I decided to create a separate bug report.

The crash can be reproduced every time.

-- Backtrace:
Application: Goudsmid info van type  (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb63537c0 (LWP 11968))]

Thread 2 (Thread 0xb4ee0b40 (LWP 12026)):
#0  0xb77dc424 in __kernel_vsyscall ()
#1  0x49ac4dd2 in __GI___clock_gettime (clock_id=1, tp=0xb4edffb4) at ../sysdeps/unix/clock_gettime.c:115
#2  0x4aa9d5dd in do_gettime (frac=0xb4edffa8, sec=0xb4edffa0) at tools/qelapsedtimer_unix.cpp:127
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:144
#4  0x4ab8d013 in updateCurrentTime (this=0xb4502074) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0xb4502074, tm=...) at kernel/qeventdispatcher_unix.cpp:460
#6  0x4ab8b42b in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb4ee00a8) at kernel/qeventdispatcher_glib.cpp:136
#7  0x4ab8b4dd in timerSourcePrepare (source=0xb4502040, timeout=timeout@entry=0xb4ee00a8) at kernel/qeventdispatcher_glib.cpp:169
#8  0x49e9edbf in g_main_context_prepare (context=<optimized out>, context@entry=0xb45004e0, priority=priority@entry=0xb4ee0104) at gmain.c:3340
#9  0x49e9f787 in g_main_context_iterate (context=context@entry=0xb45004e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3693
#10 0x49e9f9e9 in g_main_context_iteration (context=0xb45004e0, may_block=1) at gmain.c:3774
#11 0x4ab8b62f in QEventDispatcherGlib::processEvents (this=0xb4500468, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#12 0x4ab583b0 in QEventLoop::processEvents (this=this@entry=0xb4ee0214, flags=...) at kernel/qeventloop.cpp:149
#13 0x4ab58741 in QEventLoop::exec (this=this@entry=0xb4ee0214, flags=...) at kernel/qeventloop.cpp:204
#14 0x4aa3bd55 in QThread::exec (this=this@entry=0x9d7ada0) at thread/qthread.cpp:536
#15 0x4aa3bebc in QThread::run (this=0x9d7ada0) at thread/qthread.cpp:603
#16 0x4aa3e81b in QThreadPrivate::start (arg=0x9d7ada0) at thread/qthread_unix.cpp:338
#17 0x49b8cd8a in start_thread (arg=0xb4ee0b40) at pthread_create.c:309
#18 0x49ab69be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:129

Thread 1 (Thread 0xb63537c0 (LWP 11968)):
[KCrash Handler]
#7  0x0808b1f6 in MoveItemsTask::recordNewUid (this=this@entry=0x9dfaca8) at /usr/src/debug/kdepim-runtime-4.11.5/resources/imap/moveitemstask.cpp:289
#8  0x0808b863 in MoveItemsTask::onSearchDone (this=0x9dfaca8, job=0x9d0ecf0) at /usr/src/debug/kdepim-runtime-4.11.5/resources/imap/moveitemstask.cpp:241
#9  0x4ab6f735 in QMetaObject::activate (sender=sender@entry=0x9d0ecf0, m=m@entry=0xb6b5a40c <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0xbfd94ed4) at kernel/qobject.cpp:3547
#10 0xb69a90da in KJob::result (this=this@entry=0x9d0ecf0, _t1=_t1@entry=0x9d0ecf0) at /usr/src/debug/kdelibs-4.11.5/i686-redhat-linux-gnu/kdecore/kjob.moc:207
#11 0xb69a9143 in KJob::emitResult (this=0x9d0ecf0) at /usr/src/debug/kdelibs-4.11.5/kdecore/jobs/kjob.cpp:318
#12 0xb74f78d9 in KIMAP::Job::handleErrorReplies (this=this@entry=0x9d0ecf0, response=...) at /usr/src/debug/kdepimlibs-4.11.5/kimap/job.cpp:84
#13 0xb751e7f7 in KIMAP::SearchJob::handleResponse (this=0x9d0ecf0, response=...) at /usr/src/debug/kdepimlibs-4.11.5/kimap/searchjob.cpp:161
#14 0xb75119cd in KIMAP::SessionPrivate::responseReceived (this=0x9d7bd40, response=...) at /usr/src/debug/kdepimlibs-4.11.5/kimap/session.cpp:285
#15 0xb75144fb in KIMAP::SessionPrivate::qt_static_metacall (_o=0x12d, _id=0, _a=0xb4502c60, _c=<optimized out>) at /usr/src/debug/kdepimlibs-4.11.5/i686-redhat-linux-gnu/kimap/moc_session_p.cpp:76
#16 0x4ab6bcdb in QMetaCallEvent::placeMetaCall (this=0xb4502c80, object=0x9d7bd40) at kernel/qobject.cpp:524
#17 0x4ab7401b in QObject::event (this=0x9d7bd40, e=0xb4502c80) at kernel/qobject.cpp:1194
#18 0x4b43a084 in QApplicationPrivate::notify_helper (this=0x9beb4c0, receiver=0x9d7bd40, e=0xb4502c80) at kernel/qapplication.cpp:4562
#19 0x4b440fdc in QApplication::notify (this=0xbfd957f0, receiver=0x9d7bd40, e=e@entry=0xb4502c80) at kernel/qapplication.cpp:4348
#20 0xb6d5ab10 in KApplication::notify (this=0xbfd957f0, receiver=0x9d7bd40, event=0xb4502c80) at /usr/src/debug/kdelibs-4.11.5/kdeui/kernel/kapplication.cpp:311
#21 0x4ab59a76 in QCoreApplication::notifyInternal (this=0xbfd957f0, receiver=receiver@entry=0x9d7bd40, event=event@entry=0xb4502c80) at kernel/qcoreapplication.cpp:949
#22 0x4ab5ceea in sendEvent (event=0xb4502c80, receiver=0x9d7bd40) at kernel/qcoreapplication.h:231
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x9bc2f00) at kernel/qcoreapplication.cpp:1573
#24 0x4ab5d3ed in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1466
#25 0x4ab8be7f in sendPostedEvents () at kernel/qcoreapplication.h:236
#26 postEventSourceDispatch (s=s@entry=0x9be6128) at kernel/qeventdispatcher_glib.cpp:280
#27 0x49e9f556 in g_main_dispatch (context=0x9bf03b0) at gmain.c:3066
#28 g_main_context_dispatch (context=context@entry=0x9bf03b0) at gmain.c:3642
#29 0x49e9f920 in g_main_context_iterate (context=context@entry=0x9bf03b0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3713
#30 0x49e9f9e9 in g_main_context_iteration (context=0x9bf03b0, may_block=1) at gmain.c:3774
#31 0x4ab8b610 in QEventDispatcherGlib::processEvents (this=this@entry=0x9bc4b90, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#32 0x4b4f07ac in QGuiEventDispatcherGlib::processEvents (this=0x9bc4b90, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#33 0x4ab583b0 in QEventLoop::processEvents (this=this@entry=0xbfd95754, flags=...) at kernel/qeventloop.cpp:149
#34 0x4ab58741 in QEventLoop::exec (this=this@entry=0xbfd95754, flags=...) at kernel/qeventloop.cpp:204
#35 0x4ab5e3fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#36 0x4b438395 in QApplication::exec () at kernel/qapplication.cpp:3823
#37 0xb76a1725 in Akonadi::ResourceBase::init (r=r@entry=0x9d40708) at /usr/src/debug/kdepimlibs-4.11.5/akonadi/resourcebase.cpp:548
#38 0x08061b9a in Akonadi::ResourceBase::init<ImapResource> (argc=argc@entry=3, argv=argv@entry=0xbfd958d4) at /usr/include/kde4/akonadi/resourcebase.h:192
#39 0x080595fc in main (argc=3, argv=0xbfd958d4) at /usr/src/debug/kdepim-runtime-4.11.5/resources/imap/imapresource.cpp:755

The reporter indicates this bug may be a duplicate of or related to bug 328601.

Possible duplicates by query: bug 329628, bug 329202, bug 329162, bug 328043, bug 326242.

Reported using DrKonqi
Comment 1 Geert Janssens 2014-01-11 13:32:25 UTC
While the crash assistant is active, the Akonadi configuration window shows the following for the "Goudsmid info" resource:
Items verplaatsen uit 'INBOX' naar 'Geert' (0%)

This roughly translates as
Moving items from 'INBOX' to 'Geert' (0%)

'Geert' is a shared imap folder which is visible for several users on the mail system. It can be used successfully by the same user on another system. That system is currently still on kde 4.11.4 while the bug is reported from a system running 4.11.5. That last part may lead to wrong conclusions though. When the bug first appeared, the problematic system was still running kde 4.11.4. I did update to 4.11.5 hoping that would fix the issue, but it doesn't.
Comment 2 Geert Janssens 2014-01-11 13:33:53 UTC
Final remark: removing the akonadi imap resource and recreating it fixed the problem. I'm leaving the bug report open though because I should not have ended up in that situation and hopefully the backtrace reveals the cause of the issue.
Comment 3 Jekyll Wu 2014-01-12 00:19:10 UTC

*** This bug has been marked as a duplicate of bug 326242 ***