Bug 329759 - Kmail planté en envoyant un mail
Summary: Kmail planté en envoyant un mail
Status: RESOLVED DUPLICATE of bug 300253
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.11.3
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-09 11:23 UTC by nicolas.religieux
Modified: 2014-01-09 11:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nicolas.religieux 2014-01-09 11:23:17 UTC
Application: kmail (4.11.3)
KDE Platform Version: 4.11.3 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:
I was clicking on the send button to transfer a mail.
Many other apps were opened like Firefox, Amarok, jitsi, JDownloader.
And only Kmail Krashed

-- Backtrace:
Application: KMail (kmail), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f60ce95a800 (LWP 2469))]

Thread 5 (Thread 0x7f60a2651700 (LWP 2637)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f60c062b1cd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f60c062b209 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f60c9596f6e in start_thread (arg=0x7f60a2651700) at pthread_create.c:311
#4  0x00007f60cbcd09cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f60616df700 (LWP 2638)):
#0  0x00007f60cbcc3f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f60c3df26a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f60c3df27ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f60cd311a76 in QEventDispatcherGlib::processEvents (this=0x7f605c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f60cd2e35ef in QEventLoop::processEvents (this=this@entry=0x7f60616ded30, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f60cd2e38e5 in QEventLoop::exec (this=this@entry=0x7f60616ded30, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f60cd1e288f in QThread::exec (this=this@entry=0xdc8a40) at thread/qthread.cpp:542
#7  0x00007f60cd2c4d13 in QInotifyFileSystemWatcherEngine::run (this=0xdc8a40) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f60cd1e4f2f in QThreadPrivate::start (arg=0xdc8a40) at thread/qthread_unix.cpp:338
#9  0x00007f60c9596f6e in start_thread (arg=0x7f60616df700) at pthread_create.c:311
#10 0x00007f60cbcd09cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f605bfff700 (LWP 2639)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f60c036bbbd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f60c065aa76 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f60c9596f6e in start_thread (arg=0x7f605bfff700) at pthread_create.c:311
#4  0x00007f60cbcd09cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f605affd700 (LWP 2686)):
#0  0x00007f60c3e320ea in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f60c3e32399 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f60c3df2659 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f60c3df27ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f60cd311a76 in QEventDispatcherGlib::processEvents (this=0x7f60500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f60cd2e35ef in QEventLoop::processEvents (this=this@entry=0x7f605affcd70, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f60cd2e38e5 in QEventLoop::exec (this=this@entry=0x7f605affcd70, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f60cd1e288f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#8  0x00007f60cd1e4f2f in QThreadPrivate::start (arg=0xd76f60) at thread/qthread_unix.cpp:338
#9  0x00007f60c9596f6e in start_thread (arg=0x7f605affd700) at pthread_create.c:311
#10 0x00007f60cbcd09cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f60ce95a800 (LWP 2469)):
[KCrash Handler]
#6  0x00007f60cbc0cf77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f60cbc105e8 in __GI_abort () at abort.c:90
#8  0x00007f60cbc4a4fb in __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x7f60cbd5e240 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:199
#9  0x00007f60cbc56996 in malloc_printerr (ptr=0x446d070, str=0x7f60cbd5e3e0 "free(): invalid next size (fast)", action=3) at malloc.c:4923
#10 _int_free (av=<optimized out>, p=0x446d060, have_lock=0) at malloc.c:3779
#11 0x00007f60cc8d55a5 in QTextLayout::~QTextLayout (this=<optimized out>, __in_chrg=<optimized out>) at text/qtextlayout.cpp:366
#12 0x00007f60cc8fa593 in free (this=0x7cdeaf8, this=0x7cdeaf8) at text/qtextdocument_p.h:109
#13 ~QFragmentMap (this=0x58721e8, __in_chrg=<optimized out>) at ../../include/QtGui/private/../../../src/gui/text/qfragmentmap_p.h:807
#14 QTextDocumentPrivate::~QTextDocumentPrivate (this=0x58720d0, __in_chrg=<optimized out>) at text/qtextdocument_p.cpp:290
#15 0x00007f60cc8faa09 in QTextDocumentPrivate::~QTextDocumentPrivate (this=0x58720d0, __in_chrg=<optimized out>) at text/qtextdocument_p.cpp:298
#16 0x00007f60cd2fd8e5 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#17 ~QScopedPointer (this=0x58720b8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#18 QObject::~QObject (this=0x58720b0, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#19 0x00007f60cc8e9f49 in QTextDocument::~QTextDocument (this=0x58720b0, __in_chrg=<optimized out>) at text/qtextdocument.cpp:362
#20 0x00007f60cd2fb308 in QObjectPrivate::deleteChildren (this=this@entry=0x5871f40) at kernel/qobject.cpp:1907
#21 0x00007f60cd2fd8af in QObject::~QObject (this=0x6a15d30, __in_chrg=<optimized out>) at kernel/qobject.cpp:926
#22 0x00007f60ccadc4f3 in ~QTextEditControl (this=0x6a15d30, __in_chrg=<optimized out>) at widgets/qtextedit.cpp:82
#23 QTextEditControl::~QTextEditControl (this=0x6a15d30, __in_chrg=<optimized out>) at widgets/qtextedit.cpp:82
#24 0x00007f60cd2fb308 in QObjectPrivate::deleteChildren (this=this@entry=0x6ca2ed0) at kernel/qobject.cpp:1907
#25 0x00007f60cc6cdb37 in QWidget::~QWidget (this=0x8e55fe0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1681
#26 0x00007f60cd78a229 in ~KMComposerEditor (this=0x8e55fe0, __in_chrg=<optimized out>) at ../../kmail/editor/kmcomposereditor.cpp:60
#27 KMComposerEditor::~KMComposerEditor (this=0x8e55fe0, __in_chrg=<optimized out>) at ../../kmail/editor/kmcomposereditor.cpp:62
#28 0x00007f60cd2fb308 in QObjectPrivate::deleteChildren (this=this@entry=0x7325e50) at kernel/qobject.cpp:1907
#29 0x00007f60cc6cdb37 in QWidget::~QWidget (this=0x2442d70, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1681
#30 0x00007f60cc6cde49 in QWidget::~QWidget (this=0x2442d70, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1705
#31 0x00007f60cd2fb308 in QObjectPrivate::deleteChildren (this=this@entry=0xa6ff9e0) at kernel/qobject.cpp:1907
#32 0x00007f60cc6cdb37 in QWidget::~QWidget (this=0x3d991c0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1681
#33 0x00007f60ccac4d09 in QSplitter::~QSplitter (this=0x3d991c0, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1056
#34 0x00007f60cd2fb308 in QObjectPrivate::deleteChildren (this=this@entry=0x3d98f60) at kernel/qobject.cpp:1907
#35 0x00007f60cc6cdb37 in QWidget::~QWidget (this=0x46f09e0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1681
#36 0x00007f60ccac4d09 in QSplitter::~QSplitter (this=0x46f09e0, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1056
#37 0x00007f60cd2fb308 in QObjectPrivate::deleteChildren (this=this@entry=0x8e567b0) at kernel/qobject.cpp:1907
#38 0x00007f60cc6cdb37 in QWidget::~QWidget (this=0x53aa780, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1681
#39 0x00007f60ccac4d09 in QSplitter::~QSplitter (this=0x53aa780, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1056
#40 0x00007f60cd2fb308 in QObjectPrivate::deleteChildren (this=this@entry=0xa8ea550) at kernel/qobject.cpp:1907
#41 0x00007f60cc6cdb37 in QWidget::~QWidget (this=0x98ad640, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1681
#42 0x00007f60cc6cde49 in QWidget::~QWidget (this=0x98ad640, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1705
#43 0x00007f60cd2fb308 in QObjectPrivate::deleteChildren (this=this@entry=0x34220b0) at kernel/qobject.cpp:1907
#44 0x00007f60cc6cdb37 in QWidget::~QWidget (this=0x5868df0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1681
#45 0x00007f60ce42dfa5 in KMainWindow::~KMainWindow (this=0x5868df0, __in_chrg=<optimized out>) at ../../kdeui/widgets/kmainwindow.cpp:467
#46 0x00007f60cd7a8b87 in ~Composer (__vtt_parm=0x7f60cda763a8 <VTT for KMComposeWin+8>, this=0x5868df0, __in_chrg=<optimized out>) at ../../kmail/editor/composer.h:37
#47 KMComposeWin::~KMComposeWin (this=this@entry=0x5868df0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../kmail/editor/kmcomposewin.cpp:497
#48 0x00007f60cd7a8e29 in KMComposeWin::~KMComposeWin (this=0x5868df0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../kmail/editor/kmcomposewin.cpp:517
#49 0x00007f60cd2fce08 in QObject::event (this=this@entry=0x5868df0, e=e@entry=0x8a118f0) at kernel/qobject.cpp:1175
#50 0x00007f60cc6d136b in QWidget::event (this=this@entry=0x5868df0, event=event@entry=0x8a118f0) at kernel/qwidget.cpp:8845
#51 0x00007f60cca8adb3 in QMainWindow::event (this=this@entry=0x5868df0, event=event@entry=0x8a118f0) at widgets/qmainwindow.cpp:1478
#52 0x00007f60ce42efa1 in KMainWindow::event (this=this@entry=0x5868df0, ev=ev@entry=0x8a118f0) at ../../kdeui/widgets/kmainwindow.cpp:1084
#53 0x00007f60ce466a49 in KXmlGuiWindow::event (this=0x5868df0, ev=0x8a118f0) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#54 0x00007f60cc681dfc in QApplicationPrivate::notify_helper (this=this@entry=0x722a80, receiver=receiver@entry=0x5868df0, e=e@entry=0x8a118f0) at kernel/qapplication.cpp:4567
#55 0x00007f60cc688470 in QApplication::notify (this=this@entry=0x7fff7bd43fa0, receiver=receiver@entry=0x5868df0, e=e@entry=0x8a118f0) at kernel/qapplication.cpp:4353
#56 0x00007f60ce37aa6a in KApplication::notify (this=0x7fff7bd43fa0, receiver=0x5868df0, event=0x8a118f0) at ../../kdeui/kernel/kapplication.cpp:311
#57 0x00007f60cd2e48bd in QCoreApplication::notifyInternal (this=0x7fff7bd43fa0, receiver=receiver@entry=0x5868df0, event=event@entry=0x8a118f0) at kernel/qcoreapplication.cpp:946
#58 0x00007f60cd2e7e1f in sendEvent (event=0x8a118f0, receiver=0x5868df0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#59 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x632220) at kernel/qcoreapplication.cpp:1570
#60 0x00007f60cd2e82c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#61 0x00007f60cd312073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#62 postEventSourceDispatch (s=0x71a620) at kernel/qeventdispatcher_glib.cpp:279
#63 0x00007f60c3df23b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#64 0x00007f60c3df2708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#65 0x00007f60c3df27ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#66 0x00007f60cd311a55 in QEventDispatcherGlib::processEvents (this=0x633b00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#67 0x00007f60cc7239d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#68 0x00007f60cd2e35ef in QEventLoop::processEvents (this=this@entry=0x7fff7bd43bf0, flags=...) at kernel/qeventloop.cpp:149
#69 0x00007f60cd2e38e5 in QEventLoop::exec (this=this@entry=0x7fff7bd43bf0, flags=...) at kernel/qeventloop.cpp:204
#70 0x00007f60cd2e8e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#71 0x00007f60cc68034c in QApplication::exec () at kernel/qapplication.cpp:3828
#72 0x0000000000402d1a in main (argc=<optimized out>, argv=<optimized out>) at ../../kmail/main.cpp:146

The reporter indicates this bug may be a duplicate of or related to bug 327531.

Possible duplicates by query: bug 328917, bug 327905, bug 327724, bug 327531, bug 326211.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-09 11:48:47 UTC

*** This bug has been marked as a duplicate of bug 300235 ***
Comment 2 Jekyll Wu 2014-01-09 11:56:31 UTC

*** This bug has been marked as a duplicate of bug 300253 ***