Bug 329730 - reminder does not pop up at login if digital clock widget runs
Summary: reminder does not pop up at login if digital clock widget runs
Status: RESOLVED UNMAINTAINED
Alias: None
Product: korgac
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-08 18:56 UTC by Franky
Modified: 2017-01-07 23:40 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Franky 2014-01-08 18:56:43 UTC
At Login normally a reminderwindow pops up to show birthdays. This feature fails for me a long time (in Ubuntu packages too) and i asked a lot in different forums and on IRC. Until today, it seems, that i have bin the only one who runs in this failure. Anyway: Since yesterday i looked forward to find a solution for me.

After some experiments i found following:
1. If the digital clock widget is active at login, the reminderwindow doesn't pop up. If i remove the digital clock and logout/login the reminderwindow pops up.

2. If the digital clock widget is active (at login or activate it afterwards) and i restart akonadi with "akonadictl restart" the reminderwindow pops up.

What i expect is, that the reminderwindow pops up every time if i login.

It would be very nice, to get some hints about that (my?) bug. Because of this failure i forgot allready some birthdays :-(
Comment 1 David Jarvie 2014-01-08 22:02:36 UTC
Can you please give full details of which digital clock widget you are using, so that the bug can be tested with the same widget installed. Please bear in mind that I don't have an Archlinux installation.
Comment 2 Franky 2014-01-08 23:02:09 UTC
Thanks for reponse :-)

Its the default digital clock widget, wich is in the panel. On click it shows the calendar events including birthdays.

But its not sure, if this widget causes the problem. As i restart the hole System, without the clock widget, the reminderwindow does not popup. Maybe because kontact starts with the login? I will watch the behavior...

But if i restart akonadi, the reminder popup will allways appear. Regardless of a running kontact or digital clock widget. Confusing...
Comment 3 David Jarvie 2014-01-09 14:08:20 UTC
KDE 4.12
Comment 4 Franky 2014-01-09 18:37:34 UTC
(In reply to comment #3)
> KDE 4.12

In case of a question: Yes, its kde 4.12. But the missing reminder popup follows me for years...

Today i boot the system twice and everytime the reminder window pops up at login (without the digital clock in panel). Things that happens:
 1. Kontact/kmail starts up and i see that akonadi ins't running
 2. akonadi starts 
 3. Reminderwindow pops up

The reminder daemon is configured as "Enable reminders" and "Start reminder daemon at login"

Additional info: If i add the digital clock and configure it to NOT show events, the reminderwindow pops up at login. 

It seems to me, that only the trigger to display the reminder window is'nt fired if akonadi runs befor the daemon runs. I think this, because in case of a akonadi restart, the reminder always pops up. Only guessed...
Comment 5 David Jarvie 2014-01-10 14:09:52 UTC
Are you using KAlarm or KOrganizer/Kontact to set up the reminders?
Comment 6 Franky 2014-01-10 17:00:29 UTC
I am using KOrganizer/Kontact.
Comment 7 Franky 2014-01-11 11:32:25 UTC
This failure drives me crazy...

When booting today, no reminder popup appears. Also when i logout/login. The only thing i did yesterday was to set the session from
"Restore previous session" 
to
"Restore manually saved session"

A "akonadictl restart" in konsole: The reminder popup appears.

So i changed the setting to "Restore previous session" again and logout/login. No change, no reminderpopup.

I noticed that kontact/kmail starts very fast. So i decided to close kontact and logout/login... tadaaa: The reminder popup appears. Then i start kontact/kmail and logout login.... tadaaa: The reminder popup appears at login (before kontact/kmail starts).

The behavior with the digital clock is allways the same: If the clock is set to show events, the reminder popoup will never show, regardless of a running kontact/kmail.

As a dirty workaround, i wrote a script and run it at autostart:

#!/bin/bash 
sleep 5
akonadictl restart

With this script the reminderpopup appears regardless of showing events in the digital clock or in case of starting kontact/kmail at login or of "Restore manually saved session". But this script has a uggly sideeffect: The folderview in kmail is collapsed, so i must expand it to get the view of previous expanded kmailfolders.

If i am the only one who have the failure of a "Reminder do not popup at login" this dirty script will at least make me not forgot some birthdays...
Comment 8 Denis Kurz 2016-09-24 21:04:47 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of korgac (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 9 Franky 2016-09-25 14:31:13 UTC
The reminder didn't work at all, regardless of which clock i am using. I am using KMail 5.3.0 and kf 5.25 (arch-linux). Maybe i do not really understand how the reminder works, or for which circumstances it would be useful, or it doesn't fit my needs.

So this bug couldn't be confirmed by me anymore. Feel free to mark it as invalid.

Thanks for all replies anyway :-)
Comment 10 Denis Kurz 2016-09-25 18:27:55 UTC
(In reply to Franky from comment #9)
> Maybe i do not really understand
> how the reminder works, or for which circumstances it would be useful, or it
> doesn't fit my needs.

Nevermind, you are not the only one who's confused/frustrated by reminders not popping up as expected. There's definitely something off.
Comment 11 Franky 2016-09-25 19:12:43 UTC
Forgotten: My solution with the script provided in comment 7 also doesn't work anymore.
Comment 12 Denis Kurz 2017-01-07 23:40:43 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.