Bug 329599 - kmixd service hang kde a fw seconds during login
Summary: kmixd service hang kde a fw seconds during login
Status: RESOLVED DUPLICATE of bug 317926
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-04 15:51 UTC by Søren Holm
Modified: 2014-04-12 15:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.13


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Søren Holm 2014-01-04 15:51:12 UTC
KDE hangs a few seconds during startup. It does that every time.

Accourding to [1] it is because of some sound issue. Disabling kmixd system service solved it for me.

[1]  http://krisko210.blogspot.dk/2012/02/kde-freezes-for-few-seconds-after-login.html



Reproducible: Always

Steps to Reproduce:
1. Logout 
2. Login again a notice the pause in the startup.
Actual Results:  
The system stalls for a few seconds.

Expected Results:  
The system should continue without stalling.

Accouding to [1] it could be related to specifics in the sound hardware. So not everyone migt experience it. For the record I amd running KDE on a Lenovo T430S
Comment 1 Christian Esken 2014-01-05 19:43:43 UTC
Fixed for KDE 4.13
Comment 2 Søren Holm 2014-01-05 21:41:51 UTC
Do you have a commit link ?
Comment 3 Søren Holm 2014-03-23 20:21:54 UTC
It still hangs in 4.12.95
Comment 4 Søren Holm 2014-03-23 21:20:08 UTC
Basically deleting /etc/xdg/autostart/pulseaudio.desktop removes the problem.

http://linuxadvantage.blogspot.dk/2013/01/kde-rather-slow-to-start-pulseaudio.html
Comment 5 Christian Esken 2014-04-04 13:58:41 UTC
About the commit link. I was pretty sure it was the DBUS/MPRIS2 issue, which took several commits. Here is the link to the last commit and the ticket:
http://quickgit.kde.org/?p=kmix.git&a=commit&h=b3b8844690216b3af547775f549c192927022657
https://bugs.kde.org/show_bug.cgi?id=317926
Comment 6 Søren Holm 2014-04-12 15:04:04 UTC

*** This bug has been marked as a duplicate of bug 317926 ***