Bug 329523 - Login does not come up because kdm_greet crashes
Summary: Login does not come up because kdm_greet crashes
Status: RESOLVED DUPLICATE of bug 105631
Alias: None
Product: kdm
Classification: Miscellaneous
Component: general (show other bugs)
Version: 4.11.4
Platform: openSUSE Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: kdm bugs tracker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-02 10:42 UTC by sverre.moe
Modified: 2014-03-31 14:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sverre.moe 2014-01-02 10:42:36 UTC
I am unable to log in to KDE because kdm_greet crashes with the following message:
The theme can not be used with the authentication method <<Generic>>.

I have to uninstall KDM and use XDM instead in order to log into KDE.



Reproducible: Always

Steps to Reproduce:
1. Restart
2. 
3.
Actual Results:  
KDM comes up with a crash message.

Expected Results:  
Expected to get the login window/box

Application:  (kdm_greet), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7265677780 (LWP 887))]

Thread 2 (Thread 0x7f7258a64700 (LWP 889)):
#0  0x00007f726230e293 in select () from /lib64/libc.so.6
#1  0x00007f7263e64742 in ?? () from /usr/lib64/libQtCore.so.4
#2  0x00007f7263d8b0cc in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007f7263af4e0f in start_thread () from /lib64/libpthread.so.0
#4  0x00007f726231544d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f7265677780 (LWP 887)):
[KCrash Handler]
#4  0x00007f7253dfc651 in ?? () from /usr/lib64/kde4/kgreet_generic.so
#5  0x00007f7253dfcb5c in ?? () from /usr/lib64/kde4/kgreet_generic.so
#6  0x0000000000422aec in ?? ()
#7  0x00007f7263e9c29f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#8  0x00007f7263ee752e in QSocketNotifier::activated(int) () from /usr/lib64/libQtCore.so.4
#9  0x00007f7263ea3cfb in QSocketNotifier::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#10 0x00007f726301486c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#11 0x00007f7263018ceb in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#12 0x00007f7263e86d8e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#13 0x00007f7263eb4ac8 in ?? () from /usr/lib64/libQtCore.so.4
#14 0x00007f725f9e57d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#15 0x00007f725f9e5b08 in ?? () from /usr/lib64/libglib-2.0.so.0
#16 0x00007f725f9e5bc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#17 0x00007f7263eb52c6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#18 0x00007f72630b4c1e in ?? () from /usr/lib64/libQtGui.so.4
#19 0x00007f7263e8ab9f in QCoreApplication::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#20 0x000000000041e4d3 in ?? ()
#21 0x00000000004199f7 in ?? ()
#22 0x00007f726224da15 in __libc_start_main () from /lib64/libc.so.6
#23 0x0000000000419f05 in _start ()
Comment 1 sverre.moe 2014-01-02 10:46:33 UTC
I would like to add that this was still an issue after I upgraded KDE from 4.11.4 to 4.12.0

KDM in 4.12 is still on its 4.11.x version.
Comment 2 sverre.moe 2014-01-02 12:19:52 UTC
I added the following to the /usr/share/kde4/config/kdm/kdmrc
PluginsLogin=classic
PluginsShutdown=classic

The single line error message went away, but I still got the crash message with the same output.
Comment 3 Christoph Feck 2014-01-04 14:59:04 UTC
> KDM in 4.12 is still on its 4.11.x version.

This is expected, because the KDE Workspaces are frozen at KDE 4.11 version. Only the KDE Applications are updated to 4.12 versions.

I suggest to also report this issue to the bug tracker of your distribution.
Comment 4 sverre.moe 2014-01-10 08:50:24 UTC
I uninstalled the fprint library, and then I removed the following from from /etc/pam.d/common-auth
auth sufficient pam_fp.so

Then KDM was working fine again. Seems it did not like fingerprint as authentication method.
Comment 5 Oswald Buddenhagen 2014-03-31 14:11:52 UTC

*** This bug has been marked as a duplicate of bug 105631 ***