Bug 329442 - Sub-TODOs not printed anymore
Summary: Sub-TODOs not printed anymore
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Unclassified
Component: printing (show other bugs)
Version: 4.11.3
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-30 21:54 UTC by Przemysław Węgrzyn
Modified: 2014-01-04 19:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.12.1


Attachments
Patch fixing the problem for me (653 bytes, patch)
2013-12-30 22:13 UTC, Przemysław Węgrzyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Przemysław Węgrzyn 2013-12-30 21:54:07 UTC
KOrganizer's TODOs are no longer printed with sub-todos. It acts as if there were no sub-todos, only top level todos are printed. This affects the preview, too. 

I've done some investigation myself, the problem was introduced with this very commit (I'm going to attach my patch fixing the problem in a second):

commit 6fd9d0ef4f2d92c3300c112831f98d19721e0ae4
Author: Sergio Martins <iamsergio@gmail.com>
Date:   Fri Aug 3 18:16:39 2012 +0100

    Port away from CalendarSupport::Calendar and CalendarAdaptor.


Reproducible: Always

Steps to Reproduce:
1. Open KOrganizer (or Kontact)
2. Add a TODO item with one or more sub-todos.
3. Open print preview.
Actual Results:  
No sub-todos are visible.

Expected Results:  
Sub-todos should be printed under TODOs, in a tree form.
Comment 1 Przemysław Węgrzyn 2013-12-30 22:13:11 UTC
Created attachment 84356 [details]
Patch fixing the problem for me
Comment 2 Allen Winter 2014-01-04 16:40:17 UTC
yep.
I tested the patch and it works.  will commit shortly.
Comment 3 Allen Winter 2014-01-04 19:43:55 UTC
Git commit fc8ad0283679cca9d5c0d638f7287302ebaa9590 by Allen Winter.
Committed on 04/01/2014 at 19:42.
Pushed by winterz into branch 'KDE/4.12'.

fix printing sub to-dos
thanks for the patch Przemysław!
FIXED-IN: 4.12.1

M  +1    -1    korganizer/printing/calprintpluginbase.cpp

http://commits.kde.org/kdepim/fc8ad0283679cca9d5c0d638f7287302ebaa9590