Bug 329384 - Crash upon typing semicolon in new unsaved include file
Summary: Crash upon typing semicolon in new unsaved include file
Status: RESOLVED DUPLICATE of bug 328271
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 4.6.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-12-29 21:27 UTC by martin.girard
Modified: 2013-12-30 03:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description martin.girard 2013-12-29 21:27:16 UTC
Application: kdevelop (4.6.0)
KDE Platform Version: 4.11.3
Qt Version: 4.8.5
Operating System: Linux 3.11.6-4-desktop x86_64
Distribution: "openSUSE 13.1 (Bottle) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I created a new include file and attempted to add a function declaration prior to saving for the first time; it crashed systematically upon typing the trailing semicolon. Saving the header file first successfully works around the issue.

The crash can be reproduced every time.

-- Backtrace:
Application: KDevelop (kdevelop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f078b025880 (LWP 24372))]

Thread 11 (Thread 0x7f076e79a700 (LWP 24373)):
#0  0x00007f07874bd0af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0783f408cb in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f078423ef00 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f0783f40909 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f07874b90db in start_thread () from /lib64/libpthread.so.0
#4  0x00007f07877b690d in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7f06eac09700 (LWP 24374)):
#0  0x00007f07874bd458 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0788ac6b44 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f0784bdc8c2 in ?? () from /usr/lib64/libkdevplatformlanguage.so.7
#3  0x00007f0788ac668f in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f07874b90db in start_thread () from /lib64/libpthread.so.0
#5  0x00007f07877b690d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f06dd259700 (LWP 24375)):
#0  0x00007f07874bb3e9 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f0781778291 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f07817384f5 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f078173870c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f0788bf2d76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f0788bc4d0f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f0788bc5005 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#7  0x00007f0788ac3fef in QThread::exec() () from /usr/lib64/libQtCore.so.4
#8  0x00007f0788ac668f in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f07874b90db in start_thread () from /lib64/libpthread.so.0
#10 0x00007f07877b690d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f06d7fff700 (LWP 24376)):
#0  0x00007f0781777ff0 in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f07817782b9 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f0781738516 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f078173870c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f0788bf2d76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f0788bc4d0f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f0788bc5005 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#7  0x00007f0788ac3fef in QThread::exec() () from /usr/lib64/libQtCore.so.4
#8  0x00007f0788ac668f in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f07874b90db in start_thread () from /lib64/libpthread.so.0
#10 0x00007f07877b690d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f06ce98d700 (LWP 24382)):
#0  0x00007f07874bb32c in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f0781778291 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f07817385b9 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f078173870c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f0788bf2d76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f0788bc4d0f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f0788bc5005 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#7  0x00007f0788ac3fef in QThread::exec() () from /usr/lib64/libQtCore.so.4
#8  0x00007f0788ba6513 in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f0788ac668f in ?? () from /usr/lib64/libQtCore.so.4
#10 0x00007f07874b90db in start_thread () from /lib64/libpthread.so.0
#11 0x00007f07877b690d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f06ce18c700 (LWP 24386)):
#0  0x00007f07874bd0af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0788ac6b66 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f077e7c679c in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f077e7c9233 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f077e7c7f4f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f0788ac668f in ?? () from /usr/lib64/libQtCore.so.4
#6  0x00007f07874b90db in start_thread () from /lib64/libpthread.so.0
#7  0x00007f07877b690d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f06cd98b700 (LWP 24387)):
#0  0x00007f07874bf8dc in __lll_timedlock_wait () from /lib64/libpthread.so.0
#1  0x00007f07874bc4be in _L_timedlock_365 () from /lib64/libpthread.so.0
#2  0x00007f07874bbdf3 in pthread_mutex_timedlock () from /lib64/libpthread.so.0
#3  0x00007f078a7896a6 in ?? () from /usr/lib64/libkdevplatforminterfaces.so.7
#4  0x00007f078a789c7a in KDevelop::ForegroundLock::relock() () from /usr/lib64/libkdevplatforminterfaces.so.7
#5  0x00007f0784bb0da3 in KDevelop::ParseJob::readContents() () from /usr/lib64/libkdevplatformlanguage.so.7
#6  0x00007f06dda37aba in ?? () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#7  0x00007f06dda3a798 in ?? () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#8  0x00007f077e7c85e2 in ?? () from /usr/lib64/libthreadweaver.so.4
#9  0x00007f077e7c879e in ThreadWeaver::Job::execute(ThreadWeaver::Thread*) () from /usr/lib64/libthreadweaver.so.4
#10 0x00007f077e7ca23b in ?? () from /usr/lib64/libthreadweaver.so.4
#11 0x00007f077e7c7feb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#12 0x00007f0788ac668f in ?? () from /usr/lib64/libQtCore.so.4
#13 0x00007f07874b90db in start_thread () from /lib64/libpthread.so.0
#14 0x00007f07877b690d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f06cd18a700 (LWP 24390)):
#0  0x00007f07874bd0af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f077da6bf76 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f077da6bfa9 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f07874b90db in start_thread () from /lib64/libpthread.so.0
#4  0x00007f07877b690d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f06cc989700 (LWP 24391)):
#0  0x00007f07874bd0af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f077d7de2cd in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f077da93ad6 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f07874b90db in start_thread () from /lib64/libpthread.so.0
#4  0x00007f07877b690d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f067bbfd700 (LWP 24408)):
#0  0x00007f0781737cb4 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f0781738523 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f078173870c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f0788bf2d76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f0788bc4d0f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f0788bc5005 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f0788ac3fef in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f0788ac668f in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f07874b90db in start_thread () from /lib64/libpthread.so.0
#9  0x00007f07877b690d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f078b025880 (LWP 24372)):
[KCrash Handler]
#5  0x00007f06e14e4b10 in contextNum (n=<optimized out>, this=<optimized out>) at /usr/src/debug/kate-4.11.3/part/syntax/katehighlight.h:267
#6  KateDocument::defStyleNum (this=0x88b3c40, line=<optimized out>, column=<optimized out>) at /usr/src/debug/kate-4.11.3/part/document/katedocument.cpp:5376
#7  0x00007f06e150c389 in KateScriptDocument::defStyleNum (this=<optimized out>, line=<optimized out>, column=<optimized out>) at /usr/src/debug/kate-4.11.3/part/script/katescriptdocument.cpp:51
#8  0x00007f06e150c409 in KateScriptDocument::isString (this=<optimized out>, line=<optimized out>, column=<optimized out>) at /usr/src/debug/kate-4.11.3/part/script/katescriptdocument.cpp:83
#9  0x00007f06e148a439 in KateScriptDocument::qt_static_metacall (_o=0xed2efc0, _id=6425504, _id@entry=91, _a=0x7fff3d5b8d40, _c=<optimized out>) at /usr/src/debug/kate-4.11.3/build/part/moc_katescriptdocument.cpp:407
#10 0x00007f06e148b4d3 in qt_static_metacall (_a=0x7fff3d5b8d40, _id=91, _c=QMetaObject::InvokeMetaMethod, _o=0xed2efc0) at /usr/src/debug/kate-4.11.3/build/part/moc_katescriptdocument.cpp:466
#11 KateScriptDocument::qt_metacall (this=0xed2efc0, _c=QMetaObject::InvokeMetaMethod, _id=91, _a=0x7fff3d5b8d40) at /usr/src/debug/kate-4.11.3/build/part/moc_katescriptdocument.cpp:467
#12 0x00007f0783fac51d in QScript::callQtMethod (exec=exec@entry=0x7f067a36f240, callType=callType@entry=QMetaMethod::Method, thisQObject=thisQObject@entry=0xed2efc0, scriptArgs=..., meta=meta@entry=0x7f06e1890ea0 <KateScriptDocument::staticMetaObject>, initialIndex=95, maybeOverloaded=true) at bridge/qscriptqobject.cpp:960
#13 0x00007f0783fad6c9 in QScript::QtFunction::execute (this=this@entry=0x7f06eb486740, exec=0x7f067a36f240, thisValue=..., thisValue@entry=..., scriptArgs=...) at bridge/qscriptqobject.cpp:1015
#14 0x00007f0783fad959 in QScript::QtFunction::call (exec=0x7f067a36f240, callee=0x7f06eb486740, thisValue=..., args=...) at bridge/qscriptqobject.cpp:1030
#15 0x00007f0783eb2dc8 in QTJSC::NativeFuncWrapper::operator() (this=this@entry=0x7fff3d5b8f60, exec=0x7f067a36f240, jsobj=jsobj@entry=0x7f06eb486740, thisValue=..., argList=...) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/CallData.cpp:46
#16 0x00007f0783e90d50 in QTJSC::cti_op_call_NotJSFunction (args=0x7fff3d5b8fb0) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:1780
#17 0x00007f06edf2d976 in ?? ()
#18 0x0000000000000000 in ?? ()

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-12-30 03:57:26 UTC

*** This bug has been marked as a duplicate of bug 328271 ***