Bug 329364 - routingManager not exported in Python bindings
Summary: routingManager not exported in Python bindings
Status: REPORTED
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-29 14:17 UTC by Benjamin Kaiser
Modified: 2018-11-21 04:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Kaiser 2013-12-29 14:17:52 UTC
During the conversion the C++ routing tutorial #9[1] to Python I received the following error:

File "routing.py", line 23, in main
    manager = marble.model().routingManager()
AttributeError: 'MarbleModel' object has no attribute 'routingManager'

The code I was trying to run has been pasted here[2]
It appears as though the routingManager has not been exported as part of MarbleModel in the Python bindings.

[1] http://techbase.kde.org/Projects/Marble/Routing/BasicRouting
[2] http://pastebin.kde.org/pzsapghzx

Reproducible: Always
Comment 1 Benjamin Kaiser 2013-12-29 14:32:51 UTC
Also another error when porting #10[1] (would also occur in #11[2] and #12[3] ):

File "search.py", line 8, in main
    manager = Marble.MarbleRunnerManager(model.pluginManager())
AttributeError: 'MarbleModel' object has no attribute 'pluginManager'

The code is very similar to the code linked in the above code, except with the line from the above error being used `manager = Marble.MarbleRunnerManager(model.pluginManager())`
Once again it appears that pluginManager has not been exported (or sub-classed fully) in the Python bindings.

[1] http://techbase.kde.org/Projects/Marble/Runners/Search
[2] http://techbase.kde.org/Projects/Marble/Runners/ReverseGeocoding
[3] http://techbase.kde.org/Projects/Marble/Runners/Parse
Comment 2 Andrew Crouthamel 2018-11-11 04:32:37 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Andrew Crouthamel 2018-11-21 04:21:01 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? This bug will be moved back to REPORTED Status for manual review later, which may take a while. If you are able to, please lend us a hand.

Thank you for helping us make KDE software even better for everyone!