Bug 329176 - Allow changing visual properties for multiple classifier widgets at once
Summary: Allow changing visual properties for multiple classifier widgets at once
Status: RESOLVED FIXED
Alias: None
Product: umbrello
Classification: Unclassified
Component: general (show other bugs)
Version: Git
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Joris Steyn
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-23 23:14 UTC by Joris Steyn
Modified: 2013-12-24 09:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joris Steyn 2013-12-23 23:14:54 UTC
In current versions of Umbrello it is not possible to change the visual properties of multiple classifier widgets. Implementation is partly in place, but uses two-state checkboxes and toggles the values. This means if the widgets in the selection do not share the same values, it is not possible to get them all to the same state without manually selecting them.

Proposal:
* add new submenu to the new context menu (bug 329070) "Show"
* have the menu change the same properties as the regular menu, BUT:
* show individual show/hide menu items for each property

Reproducible: Always

Steps to Reproduce:
1. Add two class widgets to a diagram
2. Select them
3. Open context menu, change visual properties
Comment 1 Joris Steyn 2013-12-24 09:01:52 UTC
Git commit 5b0bf1ecf393c4c1d9cfb7fe7f058e4a54ee1177 by Joris Steyn.
Committed on 23/12/2013 at 16:50.
Pushed by jorissteyn into branch 'master'.

Undo stack and visual properties improvements

The multi-widget context menu allows setting visual properties ("Show") for a
selection. Unlike the previous "toggle" behaviour it is now possible to (for
example) hide all operations with one menu action.

Also fixed:
* applying the properties dialog without changes added a few undo commands to the stack
* the "Delete" shortcut is renamed to "Delete Diagram" because that is what it does
* mixed capitalization cmd/Cmd, is now always "Cmd"
* changes to the following widget options are now tracked in the undo stack:
** visual properties
** use fill color
** line width
** font
Related: bug 329175

M  +4    -1    umbrello/CMakeLists.txt
M  +4    -1    umbrello/cmds.h
M  +2    -2    umbrello/cmds/widget/cmd_changeFillColor.cpp
R  +9    -14   umbrello/cmds/widget/cmd_changeFont.cpp [from: umbrello/cmds/widget/cmd_changeFontSelection.cpp - 062% similarity]
C  +8    -10   umbrello/cmds/widget/cmd_changeFont.h [from: umbrello/cmds/widget/cmd_changeFontSelection.h - 073% similarity]
M  +4    -11   umbrello/cmds/widget/cmd_changeLineColor.cpp
M  +1    -0    umbrello/cmds/widget/cmd_changeLineColor.h
C  +11   -11   umbrello/cmds/widget/cmd_changeLineWidth.cpp [from: umbrello/cmds/widget/cmd_changeTextColor.cpp - 071% similarity]
C  +8    -9    umbrello/cmds/widget/cmd_changeLineWidth.h [from: umbrello/cmds/widget/cmd_changeLineColor.h - 073% similarity]
M  +4    -2    umbrello/cmds/widget/cmd_changeTextColor.cpp
M  +1    -0    umbrello/cmds/widget/cmd_changeTextColor.h
C  +14   -12   umbrello/cmds/widget/cmd_changeUseFillColor.cpp [from: umbrello/cmds/widget/cmd_changeTextColor.cpp - 066% similarity]
R  +12   -13   umbrello/cmds/widget/cmd_changeUseFillColor.h [from: umbrello/cmds/widget/cmd_changeFontSelection.h - 067% similarity]
C  +17   -13   umbrello/cmds/widget/cmd_changeVisualProperty.cpp [from: umbrello/cmds/widget/cmd_changeTextColor.cpp - 061% similarity]
C  +12   -10   umbrello/cmds/widget/cmd_changeVisualProperty.h [from: umbrello/cmds/widget/cmd_changeLineColor.h - 063% similarity]
M  +77   -25   umbrello/listpopupmenu.cpp
M  +31   -20   umbrello/listpopupmenu.h
M  +2    -1    umbrello/uml.cpp
M  +6    -2    umbrello/umlobject.cpp
M  +54   -52   umbrello/umlscene.cpp
M  +5    -1    umbrello/umlscene.h
M  +26   -18   umbrello/widgets/classifierwidget.cpp
M  +1    -0    umbrello/widgets/classifierwidget.h
M  +49   -9    umbrello/widgets/umlwidget.cpp
M  +7    -4    umbrello/widgets/umlwidget.h
M  +73   -13   umbrello/widgets/widgetbase.cpp
M  +1    -1    umbrello/widgets/widgetbase.h

http://commits.kde.org/umbrello/5b0bf1ecf393c4c1d9cfb7fe7f058e4a54ee1177