Bug 329022 - Akonadi adds blank emails to IMAP inbox
Summary: Akonadi adds blank emails to IMAP inbox
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 1.10.80
Platform: Kubuntu Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2013-12-20 04:02 UTC by Leon Maurer
Modified: 2018-10-27 04:20 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Akonadi in the process of adding blank emails to the inbox. (See the resource named gmail.) (97.48 KB, image/png)
2013-12-20 04:03 UTC, Leon Maurer
Details
The blank emails as seen in gmail. (366.65 KB, image/png)
2013-12-20 04:04 UTC, Leon Maurer
Details
most recent log file showing a 'BAD Command' error (server reply?) (25.25 KB, application/octet-stream)
2014-01-20 17:52 UTC, Hans Meine
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Maurer 2013-12-20 04:02:21 UTC
Whenever I start up Akonadi, it adds blank emails to my gmail account, which I access using IMAP. It added nearly a thousand blank emails before I stopped Akonadi and restarted my computer. When I started Akonadi, the same thing happened again.

I first saw this behaviour after updating to KDE 4.12 from kubuntu-ppa/backports.

Reproducible: Always
Comment 1 Leon Maurer 2013-12-20 04:03:57 UTC
Created attachment 84186 [details]
Akonadi in the process of adding blank emails to the inbox. (See the resource named gmail.)
Comment 2 Leon Maurer 2013-12-20 04:04:42 UTC
Created attachment 84187 [details]
The blank emails as seen in gmail.
Comment 3 Christian Mollekopf 2013-12-20 09:26:08 UTC
Thanks for the report.

Could you gather imap logs according to the process here? 
http://techbase.kde.org/Projects/PIM/Akonadi/Debug_IMAP

Thanks
Comment 4 Leon Maurer 2013-12-21 16:31:18 UTC
I'm now unable to reproduce the problem -- which is fine by me. Kubuntu did install more new KDE packages the day after I had these problems, so that may have solved it.

In any case, if I run into the problem again, I'll gather the IMAP logs.
Comment 5 Hans Meine 2014-01-20 10:33:19 UTC
I had the same problem, also due to updates from kubuntu-ppa/backports in December.

This is not with GMail, but with a corporate Exchange server, which previously had the problem that the IMAP resource would hang from time to time (I would use akonadiconsole to restart it).

Now I could not access my mails at all anymore, and with other (non-KDE) mail clients I would start to see hundreds of empty messages.

The problem seemed to be resolved when I returned after some weeks (holidays etc.), but this weekend I had the same problem again.

I am following your instructions for debugging now, but this should be at least some bits of additional information.
Comment 6 Hans Meine 2014-01-20 17:52:51 UTC
Created attachment 84751 [details]
most recent log file showing a 'BAD Command' error (server reply?)

Now, mail delivery stopped working again.  This is a new state of brokenness, however, one that I did not see in the last months AFAIR:

* I do not get to see new mails in my main inbox anymore (in KMail).
* I can see a "BAD Command" error flash for a brief moment at the end (?!) of fetching new mail if I toggle the detailed status in KMail's lower right corner.
* The same error appears in one of the /tmp/imap.log.*s (see attachment)
* However, I do *not* see any empty mails right now (so maybe this should eventually be put into a different/new bugreport).

The main akonadi[ctl] output seems to be less helpful, but here it is (I wonder if the SSL error is related; it's probably due to a domain root certificate missing on my machine):

akonadi_imap_resource_0(24724)/kdepimlibs (kimap) KIMAP::LoginJob::LoginJob: KIMAP::LoginJob(0x304bda0)
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) KIMAP::SessionThread::reconnect: connectToHost "owa.mevis.fraunhofer.de" 993
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) KIMAP::LoginJob::doStart: KIMAP::LoginJob(0x304bda0)
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) KIMAP::SessionThread::sslConnected: Initial SSL handshake failed. cipher.isNull() is false , cipher.usedBits() is 128 , the socket says: "Unbekannter Fehler" and the list of SSL errors contains 4 items.
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) KIMAP::LoginJob::handleResponse: "Fähigkeiten" "*"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) KIMAP::LoginJob::handleResponse: Capabilities updated:  ("IMAP4", "IMAP4rev1", "AUTH=NTLM", "AUTH=GSSAPI", "AUTH=PLAIN", "UIDPLUS", "CHILDREN", "IDLE", "NAMESPACE", "LITERAL+")
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) KIMAP::LoginJob::handleResponse: "Fähigkeiten" "A000001"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) KIMAP::LoginJob::handleResponse: "Anmeldung" "+"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) KIMAP::LoginJob::handleResponse: "Anmeldung" "A000002"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) KIMAP::LoginJob::~LoginJob: KIMAP::LoginJob(0x304bda0)
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveItemsTask::onFinalSelectDone: No messages present so we are done
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/Entwürfe"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/Gelöschte Elemente"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/Gesendete Elemente"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/Bewerbungen"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/Bugzilla"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/Buildreports"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/Forum"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/IEEE"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/Termine"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/Wiki"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/INBOX"
akonadi_imap_resource_0(24724)/kdepimlibs (kimap) RetrieveCollectionMetadataTask::doStart: "/Postausgang"
Comment 7 Andrew Crouthamel 2018-09-25 03:30:47 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Andrew Crouthamel 2018-10-27 04:20:13 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!