Bug 328781 - Tearing Prevention (VSync) "Automatic" setting does not work with NVIDIA driver
Summary: Tearing Prevention (VSync) "Automatic" setting does not work with NVIDIA driver
Status: RESOLVED DUPLICATE of bug 322060
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.11.4
Platform: Archlinux Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-14 02:25 UTC by Luke McCarthy
Modified: 2013-12-17 23:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke McCarthy 2013-12-14 02:25:26 UTC
When the "Tearing Prevention (VSync)" setting is set to "Automatic" when using the nvidia binary driver, I get screen tearing (on a GTX 760).

If I set it to "Full scene repaints" or "Re-use screen contents" the tearing goes away.

I would expect the "Automatic" setting to do the right thing, but in this case it does not. This seems to be a common source of frustration for many users who haven't figured out the correct setting.

Reproducible: Always
Comment 1 Thomas Lübking 2013-12-14 05:52:44 UTC
ensure you're not running into bug #322060
the auto-selection on the nvidia blob is "re-use screen content"
Comment 2 Luke McCarthy 2013-12-17 23:43:29 UTC
Ah sorry, I didn't see that bug report because I didn't notice any CPU load issues but setting KWIN_TRIPLE_BUFFER=1 does fix the tearing issue with the Automatic setting.

*** This bug has been marked as a duplicate of bug 322060 ***
Comment 3 Thomas Lübking 2013-12-17 23:57:59 UTC
If you've triple buffering enabled in the driver there'll be no additional CPU load.
See the last dupe comments and if you can provide the measured time on failure (notice that you've to unset KWIN_TRIPLE_BUFFER or the measure won't take place)