Bug 328776 - CSV importer may import certain investment transactions without assigning a brokerage or checking account
Summary: CSV importer may import certain investment transactions without assigning a b...
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: git (master)
Platform: Mint (Ubuntu based) Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-13 22:30 UTC by allan
Modified: 2014-01-06 20:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch file for this bug. Also includes improved wording of heading label of symboltabledlg.ui. (8.36 KB, patch)
2013-12-18 21:41 UTC, allan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description allan 2013-12-13 22:30:04 UTC
Because CSV files, and in particular investment files, have no well-defined format, it is quite possible for a transaction to have an action type that does not reflect the quantity, price and amount contents, or even to have an unrecognised action type.  The importer therefore has to evaluate these fields and request the user to assign an action type that matches the other fields.
Also, if the action type should involve a brokerage or checking account, the user should be requested to provide its name.  However, whether or not this is required is based on the initial action type.  If that initial action type does not require a brokerage or checking account, then the user will not get to input the account name.  If subsequently the user is asked to assign the correct action type, that assigning of the new type does not result in a re-evaluation of the possible need for the user  to input the account name.  The transaction will import, but be unbalanced because of the missing asset account.
A patch is required to deal with this issue.


Reproducible: Always

Steps to Reproduce:
1. Import a CSV investment file with a transaction containing say a quantity, price and amount, but with an action type of Stock Dividend.
2. When prompted that the action type does not match the other fields, appropriate types are offered to the user.
3. Select 'Buy' and continue the import process.
4. No asset account name will be requested and the transaction  will be imported as unbalanced.
Actual Results:  
As above.

Expected Results:  
The reassignment of action type should lead to re-evaluation of the need for an account name.
Comment 1 allan 2013-12-18 21:41:29 UTC
Created attachment 84168 [details]
Patch file for this bug. Also includes improved wording of heading label of symboltabledlg.ui.
Comment 2 allan 2013-12-27 23:26:29 UTC
Git commit 8c1f883fc302c639a5ee326ea226b2daf5a7a105 by Allan Anderson.
Committed on 18/12/2013 at 21:12.
Pushed by allananderson into branch 'master'.
Related: bug 328127
without assigning a brokerage or checking account.
Also, improve wording of heading label of symboltabledlg.ui.

M  +6    -5    kmymoney/converter/mymoneystatementreader.cpp
M  +9    -4    kmymoney/plugins/csvimport/investprocessing.cpp
M  +1    -0    kmymoney/plugins/csvimport/investprocessing.h
M  +5    -3    kmymoney/plugins/csvimport/symboltabledlg.ui

http://commits.kde.org/kmymoney/8c1f883fc302c639a5ee326ea226b2daf5a7a105
Comment 3 allan 2014-01-06 20:27:07 UTC
Git commit 72bfeac575a45ffcf944121c583fa763de8b2554 by Allan Anderson.
Committed on 06/01/2014 at 18:22.
Pushed by allananderson into branch 'master'.

M  +3    -0    kmymoney/converter/mymoneystatementreader.cpp

http://commits.kde.org/kmymoney/72bfeac575a45ffcf944121c583fa763de8b2554