Bug 328770 - I'm not able to encrypt a mail with a key which has a different email address.
Summary: I'm not able to encrypt a mail with a key which has a different email address.
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: crypto (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-13 19:23 UTC by Andreas Schneider
Modified: 2017-01-07 21:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2013-12-13 19:23:02 UTC
If I try to send a mail to

foobar@example.net

and want so sign it with the pgp key from wurst@example.net I'm not able to encrypt the mails. It results in a popup message: "It was not possible to create a message composer"

Let me know if I can provide more information.

Reproducible: Always

Steps to Reproduce:
1. Create a mail to foobar@example.net
2. Try to sign it with a valid pgp key of someone else
3. Click on Send
Actual Results:  
Popup message: "It was not possible to create a message composer"

Expected Results:  
Message should be successfully sent.
Comment 1 Hauke Laging 2014-01-04 08:10:42 UTC
You have to improve your bug report: The headline is not consistent with the text. The headline says you cannot encrypt, the text says you cannot sign. The reproduction steps do not even make sense:

"Try to sign it with a valid pgp key of someone else"

You cannot sign with someone else's key. (Yours are those keys for which you have the secret part.)

I have 4.10.5 and I can both encrypt to another key and sign with another key (which requires changing the identity configuration though). So either this was a bug which has already been fixed (or a regression which came up in a version newer than mine) or you are doing something wrong.
Comment 2 Andreas Schneider 2014-01-08 11:35:03 UTC
Oh sorry, s/sign/encrypt/

If I try to send a mail to foobar@example.net and want so encrypt it with the pgp key from wurst@example.net I'm not able to encrypt the mails. It results in a popup message: "It was not possible to create a message composer" Let me know if I can provide more information.

Reproducible: Always
Steps to Reproduce: 1. Create a mail to foobar@example.net
2. Try to encrypt it with a valid pgp key of someone else
3. Click on Send Actual Results: Popup message: "It was not possible to create a message composer"

Expected Results: Message should be successfully sent.
Comment 3 Hauke Laging 2014-01-08 11:49:35 UTC
(In reply to comment #2)

> Steps to Reproduce: 1. Create a mail to foobar@example.net
> 2. Try to encrypt it with a valid pgp key of someone else

What happens if you try this in a shell?

echo foo | gpg --armor --recipient wurst@example.net --encrypt
Comment 4 Andreas Schneider 2014-01-08 12:52:59 UTC
asn@magrathea:~/workspace/projects/libssh> echo foo | gpg --armor --recipient wurst@example.net --encrypt
gpg: wurst@example.net: skipped: No public key
gpg: [stdin]: encryption failed: No public key

Well for wurst@example.com I don't have a key, but here is one I have and it works just fine.

echo foo | gpg --armor --recipient asn@redhat.com --encrypt                                                                                  
-----BEGIN PGP MESSAGE-----
Version: GnuPG v2.0.22 (GNU/Linux)

hQEOA04r7zp8xFBtEAP+KriR4qOfaL1y/G1220wmNOtIui/X02jexvCz+wj1DXdz
DYwfsgEzOnbFRaAdyx35ILIrRxIhI7wmbCWuwutltXrmPswnDYfKYoNWeYzTNhBJ
HSI16WquxYtEB+AQQJpAZV+0qzMyqHGScwZ+L9PtQpTWFGTRnflWkwAUjWnyOK8D
/0MX78lbT5gG0ssc2tT8BlD5FY+55GmdRkJ0wg9wCEqgz9UV6dwL+34BULTZRL7H
TfposNspQCU8gcyCclcfxiyMYXDRxdTsI+lGmJLtBsXbbedGfBYjvY1gYLK93T5f
ZgjgwJBZ434ElWoXONmbj/+ACWc5uFwrP1bnFcLbJ8Ie0j8BkVSbag8SqdwU2B8C
zsvavIO4m/CxCo/Ee7e9ek0KL7U7YX373uCNG7B/ksaSW6aaozu90NXaoNdDIuqo
HH4=
=7KTT
-----END PGP MESSAGE-----

The problem is I have a key for asn@redhat.com but send a mail to anschnei@redhat.com. The person is the same and I want to encrypt the mail using the key for asn@redhat.com but kmail doesn't allow me to do that.
Comment 5 Hauke Laging 2014-01-08 14:10:12 UTC
(In reply to comment #4)

> The problem is I have a key for asn@redhat.com but send a mail to
> anschnei@redhat.com. The person is the same and I want to encrypt the mail
> using the key for asn@redhat.com but kmail doesn't allow me to do that.

Unfortunately you still haven't given the KMail version you are using. I just did a better test: I wrote an email to an address which doesn't have a certificate. There was a warning and I was given a dialog from which I could select a key and then everything was fine.

So your KMail version may have a bug but it seems that it has been fixed meanwhile so this bug report should be closed.
Comment 6 Andreas Schneider 2014-01-10 10:30:49 UTC
The version is 4.12. If it had been fixed, then hooray :)
Comment 7 Denis Kurz 2016-09-24 17:55:02 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 8 Denis Kurz 2017-01-07 21:58:32 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.