Bug 328734 - Events removed in the CalDAV server are not removed in Akonadi
Summary: Events removed in the CalDAV server are not removed in Akonadi
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: DAV Resource (show other bugs)
Version: 4.13
Platform: unspecified Linux
: NOR normal with 50 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-12 21:27 UTC by flyos
Modified: 2014-10-08 12:36 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.14.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description flyos 2013-12-12 21:27:58 UTC
I use CalDAV (Owncloud 5 and now 6) to synchronise between several computers and my phone. Whenever I remove events/to-dos through Korganizer from one computer, they are removed from the server (and the phone), but not from the other Akonadi/Korganizer instances.

All work as expected if I directly remove the events/to-dos from the server (using Owncloud interface).

This is especially annoying for the to-do list, since removing items is a very common thing...

Reproducible: Always

Steps to Reproduce:
1. Create a event or to-do on computer 1 and synchronize with the DAV server
2. Check that the event has been locally synchronised with computer 2 (usually works perfectly so far!)
3. Remove the event from, say, computer 1 and synchronize
 
Actual Results:  
The event is removed from server (and other non-KDE devices), but no from computer 2.

Expected Results:  
The event (or to-do item) should be remove from computer 2 after synchronization, since it is not any longer on the server.

Happens with KDE SC 4.11 and Owncloud 5 or brand new Owncloud 6 as DAV servers.
Comment 1 Sebastian Niemeyer 2014-05-03 10:12:02 UTC
I can confirm this problem.

openSUSE 13.1 with KDE 4.13
x86_64 machine.

The behaviour is exactly the same. If i remove a item from one device the akonadi device doesn't delete the item locally
Comment 2 Till Schäfer 2014-05-23 13:45:35 UTC
i can confirm this problem for 4.13.1 on gentoo. It is especially noticable for tasks which never disappear. 

Server side: DaviCal Server 1.1.1

clearing the akonadi cache fixes the problem, because it refeteches everything. 

=> Please update the affected Version to 4.13.1
=> This is not limited to OwnCloud
Comment 3 Till Schäfer 2014-06-05 12:22:03 UTC
This bug is causing also causing DAV Resource to fall into a Broken State: see Bug 335833
Comment 4 Rigo Wenning 2014-07-16 20:41:26 UTC
I can confirm for 4.13.2 from OpenSuse Current repos with a SoGo server. Removing the change.dat file puts the resource back online, but I haven't verified if it really syncs as it silently failed in the past.
Comment 5 yves 2014-08-06 10:14:21 UTC

Hi, 

I confirm this bug using KDE 4.13.3 and owncloud 6.0.4 (which uses a SabreDAV backend).
Comment 6 yves 2014-08-06 10:15:08 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Grégory Oestreicher 2014-09-01 09:57:42 UTC
This is working for me with what will be become 4.14.1 (speaking about the original issue). I'm not sure of the exact cause now, but it's likely to be fixed. Reopen if you still have the problem.
Comment 8 Rigo Wenning 2014-09-11 08:44:04 UTC
I still have this issue with KDE 14.0 Maybe someone fixed this going to 14.1. But 14.1 is not released yet for OpenSuse
Comment 9 Till Schäfer 2014-09-23 13:42:12 UTC
this is fixed for me as well in 4.14.1 as well.
Comment 10 flyos 2014-10-08 12:36:31 UTC
Still isn't fix for with Owncloud 6 and KDE 4.14.1 on Kubuntu 14.04 (Backports PPA activated). However, some parts of Akonadi seem to be out-of-sync in my system, notably:
- libakonadi-perl
- libakonadi-ruby
- ruby-akonadi
are still in 4.13 for some reason...