Bug 328655 - Exception on recurring event on CalDAV calendar makes whole event series disappear
Summary: Exception on recurring event on CalDAV calendar makes whole event series disa...
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: recurrence (show other bugs)
Version: 4.11.3
Platform: Ubuntu Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-11 12:06 UTC by Benedikt Bauer
Modified: 2022-04-16 11:43 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Raw payload of exception from akonadiconsole (867 bytes, text/plain)
2013-12-11 12:12 UTC, Benedikt Bauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benedikt Bauer 2013-12-11 12:06:55 UTC
I use a calendar that is synced via owncloud's CalDAV interface over several computers that are partly equipped with KOrganizer and partly with Thunderbird/Lightning. Whenever I change a recurring event in Lightning by shifting the start and/or end time, the whole recurring event disappears in KOrganizer's calendar view.

Reproducible: Always

Steps to Reproduce:
1. Create a recurring event on a CalDAV calendar
2. Use another application (e.g. Thunderbird Lightning) to add an exception (in my case different start and/or end times) to the event.
3. Wait until the CalDAV calendar has been synced back to KOrganizer
Actual Results:  
The exception makes the whole event series disappear in the KOrganizer calendar. The exception is present and labelled correctly as exception in akonadiconsole.

Expected Results:  
KOrganizer should display the recurring event and the changed exception correctly.
Comment 1 Benedikt Bauer 2013-12-11 12:12:31 UTC
Created attachment 84031 [details]
Raw payload of exception from akonadiconsole
Comment 2 Martin Kyral 2015-03-10 10:18:28 UTC
Confirming this issue. Zimbra, korganizer-4.14.4-6.fc21. Having exception in recurring event (weekly meeting) causes means the whole series is gone.
Comment 3 gjditchfield 2022-04-01 22:15:35 UTC
I wasn't able to reproduce this with KOrganizer 5.19.3, but my mix of 
software is different from the original report.  Can you still reproduce
the bug?

What I did:
- I used mailbox.org as the CalDAV provider.
- I used the web interface, to avoid any problem with Thunderbird.
- I created a recurring event, and waited for it to sync down to KOrganizer.
- I made one occurrence an exception, and waited for it to sync.

The change synced properly, and no events disappeared.
Comment 4 Bug Janitor Service 2022-04-16 04:34:47 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Benedikt Bauer 2022-04-16 11:43:31 UTC
I couldn't reproduce it either on 5.19.3. Looks like it has been fixed.