Bug 328349 - Unable to login after hibernate when input language is other than English
Summary: Unable to login after hibernate when input language is other than English
Status: RESOLVED DUPLICATE of bug 306932
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: 4.11.3
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 342898 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-03 04:08 UTC by Prime Jyothi
Modified: 2015-02-15 20:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Prime Jyothi 2013-12-03 04:08:24 UTC
When input language is set to something other than English, login fails when restoring the session from hibernate.

Reproducible: Always

Steps to Reproduce:
1. Login to the system, the password should consist of English characters.
2. Enable ibus input method and add a Language other than English. These tests done with Malayalam & Thai Languages.
3. Caution : Save/close any open applications as this session cannot be restored.
4. Switch the input language to something other than English and ensure that non English characters are appearing in input windows.
5. Hibernate to Disk.
6. Resume the System
7. Login to the system - Login fails.
Actual Results:  
Login fails.
When password is typed to the password window, corresponding text in the selected language is shown briefly in the password box.

To access the system again, the user has to do one of the following :
1. Login to a virtual terminal and terminate the active session (kill -9 -1).
2. Restart the system.

Expected Results:  
The user should be able to login to the system.

When password is being asked the system should either switch to English automatically or provide a mechanism to switch the input language.

To access the system again, the user has to do one of the following :
1. Login to a virtual terminal and terminate the active session (kill -9 -1).
2. Restart the system.
Comment 1 Prime Jyothi 2013-12-03 08:18:42 UTC
Two updates :
1. Just realized that there is a work around to login to the system. If the ibus-daemon process is killed from a virtual terminal, the input language will be English again and the user can login to the system.

2. If the input language is set a language other than English, the user will not be able to unlock the screen after locking.
Comment 2 Akhilan 2015-01-16 04:46:44 UTC
*** Bug 342898 has been marked as a duplicate of this bug. ***
Comment 3 Akhilan 2015-01-16 04:49:23 UTC
Any update? This is a severe bug. All the work carrying on lost after locking. and i have to restart the system to continue.
Comment 4 Rajeesh K V 2015-02-14 15:11:19 UTC
I remember Martin Gräßlin mentioning that this is recently fixed in Plasma 5.2.1 by disabling input methods in lock screen.
Comment 5 Martin Flöser 2015-02-15 20:15:02 UTC
There is no need to restart the system. It is possible to get out of the locked state from a tty.
For Plasma 4:
qdbus | grep kscreenlocker_greet | xargs -I {} qdbus {} /MainApplication quit

For Plasma 5:
as superuser: loginctl unlock-sessions

*** This bug has been marked as a duplicate of bug 306932 ***