Bug 328188 - akonadi_imap_resource has crashed, possibly due to unreliable Internet connection
Summary: akonadi_imap_resource has crashed, possibly due to unreliable Internet connec...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.13
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
: 324701 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-28 18:57 UTC by Thomas Dreibholz
Modified: 2017-01-07 21:49 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.63 KB, text/plain)
2014-05-24 06:19 UTC, Martin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Dreibholz 2013-11-28 18:57:14 UTC
Application: akonadi_imap_resource (4.11)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-13-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

akonadi_imap_resource has crashed, possibly due to unreliable Internet connection.

-- Backtrace:
Application: Yahoo av type IMAP E-post-tjener (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fce484437c0 (LWP 3474))]

Thread 2 (Thread 0x7fce2da4d700 (LWP 9855)):
#0  0x00007fff92cdea2f in clock_gettime ()
#1  0x00007fce43e4096d in clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fce4777a757 in do_gettime (frac=0x7fce2da4cb40, sec=0x7fce2da4cb38) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fce47853fe5 in updateCurrentTime (this=0x7fce24001330) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0x7fce24001330, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0x00007fce4785282c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fce2da4cbf4) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fce478528d5 in timerSourcePrepare (source=<optimized out>, timeout=timeout@entry=0x7fce2da4cbf4) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fce42b4cd4d in g_main_context_prepare (context=context@entry=0x7fce240009a0, priority=priority@entry=0x7fce2da4cc78) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3339
#9  0x00007fce42b4d5c3 in g_main_context_iterate (context=context@entry=0x7fce240009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3692
#10 0x00007fce42b4d7ac in g_main_context_iteration (context=0x7fce240009a0, may_block=1) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3773
#11 0x00007fce47852a76 in QEventDispatcherGlib::processEvents (this=0x7fce240008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007fce478245ef in QEventLoop::processEvents (this=this@entry=0x7fce2da4cdb0, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fce478248e5 in QEventLoop::exec (this=this@entry=0x7fce2da4cdb0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007fce4772388f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#15 0x00007fce47725f2f in QThreadPrivate::start (arg=0x1ac99b0) at thread/qthread_unix.cpp:338
#16 0x00007fce4346ff6e in start_thread (arg=0x7fce2da4d700) at pthread_create.c:311
#17 0x00007fce43e2b9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fce484437c0 (LWP 3474)):
[KCrash Handler]
#6  operator char const* (this=<optimized out>) at /usr/include/qt4/QtCore/qbytearray.h:425
#7  KIMAP::Session::selectedMailBox (this=0x18ce590) at ../../kimap/session.cpp:427
#8  0x000000000045513a in RetrieveItemsTask::startRetrievalTasks (this=this@entry=0x1a188b0) at ../../../resources/imap/retrieveitemstask.cpp:129
#9  0x00000000004566eb in RetrieveItemsTask::onFetchForBodyCheckDone (this=0x1a188b0, job=<optimized out>) at ../../../resources/imap/retrieveitemstask.cpp:119
#10 0x00007fce47839a58 in QMetaObject::activate (sender=sender@entry=0x1af2cc0, m=m@entry=0x7fce44ac5600 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff92c158f0) at kernel/qobject.cpp:3539
#11 0x00007fce44735102 in KJob::result (this=this@entry=0x1af2cc0, _t1=_t1@entry=0x1af2cc0) at ./kjob.moc:208
#12 0x00007fce44735140 in KJob::emitResult (this=0x1af2cc0) at ../../kdecore/jobs/kjob.cpp:318
#13 0x00007fce4783ddce in QObject::event (this=0x1af2cc0, e=<optimized out>) at kernel/qobject.cpp:1194
#14 0x00007fce46bc2dfc in QApplicationPrivate::notify_helper (this=this@entry=0x185bab0, receiver=receiver@entry=0x1af2cc0, e=e@entry=0x185bf50) at kernel/qapplication.cpp:4567
#15 0x00007fce46bc9470 in QApplication::notify (this=this@entry=0x7fff92c15fc0, receiver=receiver@entry=0x1af2cc0, e=e@entry=0x185bf50) at kernel/qapplication.cpp:4353
#16 0x00007fce44cf5a6a in KApplication::notify (this=0x7fff92c15fc0, receiver=0x1af2cc0, event=0x185bf50) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007fce478258bd in QCoreApplication::notifyInternal (this=0x7fff92c15fc0, receiver=receiver@entry=0x1af2cc0, event=event@entry=0x185bf50) at kernel/qcoreapplication.cpp:946
#18 0x00007fce47828e1f in sendEvent (event=0x185bf50, receiver=0x1af2cc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x182bf80) at kernel/qcoreapplication.cpp:1570
#20 0x00007fce478292c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#21 0x00007fce47853073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#22 postEventSourceDispatch (s=s@entry=0x185e080) at kernel/qeventdispatcher_glib.cpp:279
#23 0x00007fce42b4d3b6 in g_main_dispatch (context=0x185e7d0) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3065
#24 g_main_context_dispatch (context=context@entry=0x185e7d0) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3641
#25 0x00007fce42b4d708 in g_main_context_iterate (context=context@entry=0x185e7d0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3712
#26 0x00007fce42b4d7ac in g_main_context_iteration (context=0x185e7d0, may_block=1) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3773
#27 0x00007fce47852a55 in QEventDispatcherGlib::processEvents (this=0x182dc40, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0x00007fce46c649d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007fce478245ef in QEventLoop::processEvents (this=this@entry=0x7fff92c15f30, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007fce478248e5 in QEventLoop::exec (this=this@entry=0x7fff92c15f30, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007fce47829e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#32 0x00007fce46bc134c in QApplication::exec () at kernel/qapplication.cpp:3828
#33 0x00007fce47f59e03 in Akonadi::ResourceBase::init (r=r@entry=0x19db800) at ../../akonadi/resourcebase.cpp:548
#34 0x000000000041dce3 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:192
#35 0x00007fce43d52de5 in __libc_start_main (main=0x416400 <main(int, char**)>, argc=3, ubp_av=0x7fff92c160d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff92c160c8) at libc-start.c:260
#36 0x0000000000416584 in _start ()

Possible duplicates by query: bug 324701.

Reported using DrKonqi
Comment 1 Christian Mollekopf 2013-12-09 15:26:24 UTC
This is probably fixed in 4.12 by fdb5da0de4e2f2cbdbc1c226792b3748494394ef.
Comment 2 Christian Mollekopf 2013-12-09 15:26:49 UTC
*** Bug 324701 has been marked as a duplicate of this bug. ***
Comment 3 Martin 2014-05-24 06:19:56 UTC
Created attachment 86793 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.13) on KDE Platform 4.13.0 using Qt 4.8.6

- What I was doing when the application crashed:

I returned the system from suspend mode and was greeted with a certificate request. After accepting it the resource crashed.

-- Backtrace (Reduced):
#6  operator char const* (this=<optimized out>) at /usr/include/qt4/QtCore/qbytearray.h:425
#7  KIMAP::Session::selectedMailBox (this=0x257f250) at ../../kimap/session.cpp:449
#8  0x0000000000459cea in RetrieveItemsTask::startRetrievalTasks (this=0x282ab00) at ../../../resources/imap/retrieveitemstask.cpp:96
#9  0x00007f9fc0e72908 in QMetaMethod::invoke (this=this@entry=0x7fff13a31480, object=object@entry=0x282ab00, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
[...]
#11 0x000000000041f633 in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., member=<optimized out>, obj=<optimized out>) at /usr/include/qt4/QtCore/qobjectdefs.h:434
Comment 4 Denis Kurz 2016-09-24 20:33:31 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 5 Denis Kurz 2017-01-07 21:49:22 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.