Bug 327901 - Muting mutes master and speaker channel, unmuting unmutes only master channel => no sound after unmuting
Summary: Muting mutes master and speaker channel, unmuting unmutes only master channel...
Status: RESOLVED DUPLICATE of bug 318986
Alias: None
Product: kmix
Classification: Unclassified
Component: Backend: Pulseaudio (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-21 14:07 UTC by Max Michels
Modified: 2021-02-12 13:42 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
KMix after autostart (37.98 KB, image/png)
2013-12-16 16:13 UTC, Andrew Belitsky
Details
KMix after restart (36.31 KB, image/png)
2013-12-16 16:14 UTC, Andrew Belitsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Max Michels 2013-11-21 14:07:52 UTC
Archlinux kmix version 4.11.3-1
Lenovo T410 Laptop

I'm using snd_hda_intel driver for my Intel sound card. Various channels are available: Master, Headphone, Speaker, PCM.

When hitting the mute button on my laptop, kmix mutes the Master and Speaker channel. However, it unmutes only the Master channel which results in a muted state.

Maybe this is not a kmix problem but it seems like one for me.

Reproducible: Always

Steps to Reproduce:
0. Playback some sound to verify sound works
1. HIt the mute button on a T410 => muted sound
2. Hit the unmute button on a T410 => muted sound
Actual Results:  
Muted sound

Expected Results:  
Unmuted sound
Comment 1 Andrew Belitsky 2013-12-04 14:14:19 UTC
I have the same problem on my Packard Bell dot s with Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02) and KDE 4..11.3.
Comment 2 Christian Esken 2013-12-16 13:39:35 UTC
KMix always mutes only one channel, so something is either in the hardware or driver.
As a first diagnostics: Please quit KMix (Open main window and press CTRL-q), and try again. Does still something get muted now when you press the key? If yes, then it is probably wired to the hardware.
Comment 3 Andrew Belitsky 2013-12-16 15:53:22 UTC
On my netbook I found that autostarted KMix (after loading of KDE ) have controls that works with my sound card (master, headphones, speaker, mic, etc.). Muting works wrong with them.
But if I restart KMix then controls changes: controls for my soundcard are disappearing and PulseAudio's controls appears. Muting works correct here.
Comment 4 Andrew Belitsky 2013-12-16 16:13:54 UTC
Created attachment 84123 [details]
KMix after autostart
Comment 5 Andrew Belitsky 2013-12-16 16:14:38 UTC
Created attachment 84124 [details]
KMix after restart
Comment 6 Max Michels 2013-12-16 21:54:23 UTC
(In reply to comment #2)
> As a first diagnostics: Please quit KMix (Open main window and press
> CTRL-q), and try again. Does still something get muted now when you press
> the key? If yes, then it is probably wired to the hardware.

Fixes the problem for me.

(In reply to comment #3)
> But if I restart KMix then controls changes: controls for my soundcard are disappearing and PulseAudio's controls appears.

Not for me. All the channels come up like they always do.
Comment 7 Christian Esken 2013-12-17 12:44:12 UTC
@Max Michels: What exactly did you mean with "Fixes the problem for me."? Does the correct channel get muted (and umuted) after quitting KMix and pressing the key?
Comment 8 Max Michels 2013-12-17 14:06:09 UTC
(In reply to comment #7)
> @Max Michels: What exactly did you mean with "Fixes the problem for me."?
> Does the correct channel get muted (and umuted) after quitting KMix and
> pressing the key?

Yes, kmix works properly after I restarted it, i.e. the correct channel gets muted and unmuted. Thanks for the hint. Seems to have something to do with the audio setup during the startup of KDE.
Comment 9 Christian Esken 2014-01-02 08:03:28 UTC
The screenshots are very interesting: After Login/Autostart we have ALSA, and after restarting KMix we have Pulseaudio. Not sure why this would happen - I will reassign this to the PulseAudio component, as it looks be a PA detection/start problem.
Comment 10 Andrew Crouthamel 2018-11-11 04:35:58 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 11 Max Michels 2018-11-11 16:00:35 UTC
I don't have a KDE setup at the moment. Unless somebody else confirms this is still a bug, feel free to close. Thanks!
Comment 12 Andrew Crouthamel 2018-11-21 04:45:27 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? This bug will be moved back to REPORTED Status for manual review later, which may take a while. If you are able to, please lend us a hand.

Thank you for helping us make KDE software even better for everyone!
Comment 13 Jonathan Marten 2021-02-12 13:42:56 UTC
As shown by the screenshots and comment 9, this appears to be a "startup or reconnect to PulseAudio not working" problem.

*** This bug has been marked as a duplicate of bug 318986 ***