Bug 327777 - ownCloud calendars and contacts are not shown in Kontact
Summary: ownCloud calendars and contacts are not shown in Kontact
Status: RESOLVED DUPLICATE of bug 284783
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: DAV Resource (show other bugs)
Version: 4.11
Platform: Debian unstable Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-18 18:00 UTC by didi.debian
Modified: 2014-01-31 20:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
CalDAV resources (62.98 KB, image/png)
2013-11-18 18:00 UTC, didi.debian
Details
CardDAV resources (60.19 KB, image/png)
2013-11-18 18:01 UTC, didi.debian
Details
Akonadi Console's remote configuration (31.00 KB, image/png)
2013-12-04 18:24 UTC, didi.debian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description didi.debian 2013-11-18 18:00:41 UTC
Created attachment 83624 [details]
CalDAV resources

I've created a DAV groupware resource, specified my credentials, selected 'ownCoud' as my server type (I'm running 5.0.12), specified my host and installation path, tested the connection successfully and finished the wizard. But no addressbooks or contacts show up.
When editing the Akonadi resource, I fetched the discovered collections and they all show up, both for contacts and calendars (see attachments). But no matter what I do, I don't see my owncloud calendars or addressbooks.
It doesn't matter if I do it through System Settings -> Personal Information or in KAddressbook or KOrganizer.
My last try consisted of:
- Remove all akonadi resources, including all mail accounts and all related items from KWallet
- Uninstalled (purged) Kontact and all related applications (kmail, knotes, akregator, kaddressbook, korganizer)
- Rebooted in recovery mode and removed (rm -rf) the akonadi directory and the directories of kontact and it's related applications
- Rebooted again and logged into KDE
- Installed Kontact and related applications and configured my mail accounts (4 dIMAP, 1POP3)
- Added the DAV groupware resource like I described earlier ... to no avail

I'm running a fully up-to-date Debian Sid system, running KDE 4.11.3-1.
If you need any more info, let me know.

Cheers,
  Diederik
Comment 1 didi.debian 2013-11-18 18:01:27 UTC
Created attachment 83625 [details]
CardDAV resources
Comment 2 didi.debian 2013-11-18 18:49:25 UTC
Doing a synchonize all through akonadi console with 'tail -f .xsession-errors' produces the following output:
kded(3459)/KPasswdServer KPasswdServer::checkAuthInfoAsync: User = "" , WindowId = 0
kded(3459)/KPasswdServer KPasswdServer::checkAuthInfoAsync: User = "" , WindowId = 0
kded(3459)/KPasswdServer KPasswdServer::checkAuthInfoAsync: User = "" , WindowId = 0
kded(3459)/KPasswdServer KPasswdServer::checkAuthInfoAsync: User = "" , WindowId = 0
Error during executing query "INSERT INTO CollectionTable (remoteId, remoteRevision, name, parentId, resourceId, cachePolicyInherit, isVirtual) VALUES (:0, :1, :2, :3, :4, :5, :6)" :  "Duplicate entry '83-Work' for key 'CollectionTable_parentAndNameIndex' QMYSQL3: Unable to execute statement"

No idea if it's relevant, but maybe it is.
Comment 3 didi.debian 2013-12-04 18:24:36 UTC
Created attachment 83932 [details]
Akonadi Console's remote configuration

It looks like the remote configuration isn't stored properly.
The previous attachment show the native configuration and there all the settings are present, but I'm missing URLs (or sth like that) in the remote configuration dialog.
I don't know what info to put in which config setting though, since adding a DAV groupware resource from the akonadi console gives the same result as in this attachment.
Comment 4 didi.debian 2014-01-29 17:09:19 UTC
Freshly installed system from scratch, KDEPIM now at 4.11.5 and ownCloud 6.0.1, but still no go.
Any hints on how to debug this would be much appreciated.
Comment 5 Martin Koller 2014-01-31 20:34:53 UTC
as in comment #2:  "Duplicate entry '83-Work' for key 'CollectionTable_parentAndNameIndex' 

I had the same problem and found out that you can not give the same name to a calendar and an addressbook (in owncloud it works but akonadi has a problem with this).
Comment 6 didi.debian 2014-01-31 20:48:47 UTC
(In reply to comment #5)
> I had the same problem and found out that you can not give the same name to
> a calendar and an addressbook (in owncloud it works but akonadi has a
> problem with this).

That's it! Thank you very much :-)
I had an addressbook named 'Work' and a calendar named 'Work' and after removing the Work addressbook and doing a sync, all calendars and my other addressbook showed up. \o/

Definitely a bug in akonadi as far as I'm concerned.
Comment 7 Martin Koller 2014-01-31 20:52:00 UTC

*** This bug has been marked as a duplicate of bug 284783 ***