Bug 327728 - Automatic redirection to twitter
Summary: Automatic redirection to twitter
Status: RESOLVED UNMAINTAINED
Alias: None
Product: akregator
Classification: Applications
Component: internal browser (show other bugs)
Version: 4.13.1
Platform: Debian unstable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 331559 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-17 17:14 UTC by Damijan Bec
Modified: 2017-01-07 21:47 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Recorded session (767.97 KB, video/ogg)
2013-11-17 17:15 UTC, Damijan Bec
Details
akregator started from inside kontact (8.06 KB, text/plain)
2013-12-29 23:59 UTC, psalty
Details
akregator started standalone (4.09 KB, text/plain)
2013-12-30 00:00 UTC, psalty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Damijan Bec 2013-11-17 17:14:17 UTC
Problem is automatic redirection while visiting Linux.com Feeds to https://twitter.com/i/jot 
Once you click on Complete Story for article from Linux.com Akregator redirects you to 
https://twitter.com/i/jot. 
The only thing one can see is the following text 
GIF89a 
After one clicks on Complete story, desired story is displayed but only for a second or two then redirection happens. The attachment holds recorded issue

Reproducible: Always

Steps to Reproduce:
See the recorded session
Actual Results:  
Instead of desired web page one gets the following "text"

GIF89a
Comment 1 Damijan Bec 2013-11-17 17:15:12 UTC
Created attachment 83609 [details]
Recorded session
Comment 2 psalty 2013-12-29 23:58:20 UTC
same issue with site http://www.businessspectator.com.au/bs.nsf/RSS?readform&type=topstories&cat=all
If any of the articles is selected with Complete Story link then a new tab is created in akregator and the page loads, then a few seconds after loading the page is redirected to https://twitter.com/i/jot and GIF89a< is displayed.
If the page is navigated with the back button then the page reloads correctly and them immediatley redirects to the https://twitter.com/i/jot page.
If the page is opened in konqueror, chrome or iceweasle, then it renders ok.
Akregator running inside of kontact manager.
System Debian KDE Testing/jessie
akregator 4:4.11.3-1 amd64 RSS/Atom feed aggregator
kontact 4:4.11.3-1 amd64 integrated application for personal information management

Other Info:
If akregator is started by itself from the command line, then the bug doesn't happen.
Attached are 2 files showing the console printouts when kontact and akregator are started from the console.
Comment 3 psalty 2013-12-29 23:59:31 UTC
Created attachment 84331 [details]
akregator started from inside kontact
Comment 4 psalty 2013-12-30 00:00:31 UTC
Created attachment 84332 [details]
akregator started standalone
Comment 5 Maarten De Meyer 2014-01-16 13:30:55 UTC
I can reproduce the issue.
If you open links that contain some sort of twitter integration in a new tab they will be redirected.

https://twitter.com/i/jot is a one pixel image they use to track people.
Short term workaround might be to block it in your firewall.
Comment 6 Rolf Eike Beer 2014-06-01 20:47:26 UTC
*** Bug 331559 has been marked as a duplicate of this bug. ***
Comment 7 nicofrand 2015-02-10 08:23:39 UTC
Any news regarding this issue ?

I can still reproduce it with Akregator 4.13.3 when reading this feed : http://www.2ality.com/feeds/posts/default.
Comment 8 Denis Kurz 2016-09-24 19:42:52 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of akregator (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 9 Denis Kurz 2017-01-07 21:47:54 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.