Bug 327669 - Crash after moving a diagram pasted from listview
Summary: Crash after moving a diagram pasted from listview
Status: RESOLVED FIXED
Alias: None
Product: umbrello
Classification: Unclassified
Component: general (show other bugs)
Version: Git
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Joris Steyn
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-15 21:53 UTC by Joris Steyn
Modified: 2013-11-21 17:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.12.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joris Steyn 2013-11-15 21:53:22 UTC
When pasting a diagram to another instance of Umbrello, the list item and all objects that have widgets on the diagram are added to the other instance. Everything seems to works fine except: a crash occurs when moving the pasted diagram. Saving and reloading the file fixes the issue.

Reproducible: Always

Steps to Reproduce:
1. Add widgets to a diagram
2. Copy the diagram
3. Paste the diagram to another Umbrello instance
4. Move the pasted diagram
Actual Results:  
SIGSEGV

Expected Results:  
No SIGSEGV.
Comment 1 Ralf Habacker 2013-11-21 08:59:03 UTC

*** This bug has been marked as a duplicate of bug 327834 ***
Comment 2 Joris Steyn 2013-11-21 11:47:23 UTC
This issue is distinct from bug 327834, it happens when pasting a diagram listview item. The new  item points to the wrong (old) diagram resulting in problems on first interaction with the item.
Comment 3 Ralf Habacker 2013-11-21 11:53:12 UTC
Do you have a testcase ? I tried to reproduce with the huge test case from bug 327834, but the crash did not happens, which guided me to the resolved conclusion
Comment 4 Joris Steyn 2013-11-21 16:28:30 UTC
Git commit bbb9b085a734eefb0ad5ca4265d25fb0e32e6d9e by Joris Steyn.
Committed on 19/11/2013 at 21:31.
Pushed by jorissteyn into branch 'master'.

Fix crash when moving diagram after paste

This also makes the behaviour of the (still partly broken) diagram duplication
a bit more acceptable/usable untill bug 327670 has been resolved.

M  +10   -2    umbrello/umldoc.cpp

http://commits.kde.org/umbrello/bbb9b085a734eefb0ad5ca4265d25fb0e32e6d9e
Comment 5 Joris Steyn 2013-11-21 17:01:44 UTC
OK see above commit. This is the issue I intended to fix in this issue, reproducible in 4.12 with these steps:
1. Start Umbrello
2. Add one or more widgets to the class diagram
3. Select the list view item of the class diagram in the tree view
4. CTRL+C
5. File -> New / New Umbrello instance
6. Select "Logical View" in the tree
7. CTRL+V (so far so good)
8. Try to move the new diagram item to another location in the tree

Step 8. resulted in a crash. That should be fixed now in master. But, there's definately more work here so I created bug 327910.