Bug 327411 - Akonadi hangs on boot
Summary: Akonadi hangs on boot
Status: RESOLVED DUPLICATE of bug 326480
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.11
Platform: Ubuntu Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-10 13:57 UTC by Lastique
Modified: 2014-01-29 16:17 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Akonadi server self-test report and backtraces (5.15 KB, application/gzip)
2013-11-10 13:57 UTC, Lastique
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lastique 2013-11-10 13:57:32 UTC
Created attachment 83474 [details]
Akonadi server self-test report and backtraces

Sometimes, when the system boots, Akonadi services don't start. I only see akonadiserver, akonadi_control and mysqld processes at startup, no other Akonadi processes. I have two IMAP mail accounts set up, and Akonadi resources for them don't start. Kmail shows that Akonadi service is not started. Akonadi resources configuration in System settings says the same and offers to start Akonadi, but it does nothing. The only way to revive Akonadi is to forcefully kill all Akonadi and MySQL processes and attempt to start the service again from system settings.

I'm on Kubuntu 13.10, x86_64. I have Nepomuk disabled. I attached Akonadi Server self-test report (from the system settings page) and backtraces from the hanging Akonadi processes.
Comment 1 Ondrej Konecny 2013-11-29 12:28:04 UTC
I have the same problem.
KDE 4.11.3
Comment 2 Christux 2014-01-27 23:39:58 UTC
Same here! I read some where that probably the nvidia driver is causing this.

KDE 4.12.1
Comment 3 Daniel Vrátil 2014-01-28 07:38:12 UTC
If you use nvidia binary drivers, please see discussion in bug 326480.
Comment 4 Jekyll Wu 2014-01-28 08:28:16 UTC

*** This bug has been marked as a duplicate of bug 326480 ***
Comment 5 Ondrej Konecny 2014-01-28 11:49:39 UTC
Yes, I was using the nvidia driver. I have switched to nouveau recently and the akonadi bug is gone. I just wonder how can a graphics card driver affect akonadi ...
Comment 6 Christux 2014-01-28 16:31:46 UTC
I just installed the nvidia driver 331.38 from rpmfusion-nonfree-update-testing repository (fedora).
So far it seems to work!
Comment 7 Daniel Vrátil 2014-01-29 16:17:31 UTC
(In reply to comment #5)
> I just wonder how can a graphics card driver affect akonadi ...

It somehow breaks signal processing in kernel, which then affects DBus and breaks Akonadi start up. The latest drivers fix this, so I didn't bother which much investigation :)