Bug 327337 - kmahjongg crashes when use custom layout
Summary: kmahjongg crashes when use custom layout
Status: RESOLVED DUPLICATE of bug 188413
Alias: None
Product: kmahjongg
Classification: Applications
Component: general (show other bugs)
Version: 0.8
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-11-08 23:01 UTC by Oleg Kukharchuk
Modified: 2013-11-17 23:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
layout file (2.61 KB, application/octet-stream)
2013-11-08 23:07 UTC, Oleg Kukharchuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Kukharchuk 2013-11-08 23:01:15 UTC
Application: kmahjongg (0.8)
KDE Platform Version: 4.11.3 (Compiled from sources)
Qt Version: 4.8.5
Operating System: Linux 3.11.0-gentoo x86_64
Distribution: "NAME=Gentoo"

-- Information about the crash:
- What I was doing when the application crashed:
I created a new layout for the kmahjongg. Application crashes during loading this layout.
- Custom settings of the application:

The crash can be reproduced every time.

-- Backtrace:
Application: KMahjongg (kmahjongg), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007fe4c1fcb1f5 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007fe4c1fcc66b in __GI_abort () at abort.c:90
#8  0x00007fe4c200cfce in __libc_message (do_abort=2, fmt=0x7fe4c2102950 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:196
#9  0x00007fe4c2012d36 in malloc_printerr (action=3, str=0x7fe4c2102a80 "free(): invalid next size (normal)", ptr=<optimized out>) at malloc.c:4902
#10 0x00007fe4c2013b20 in _int_free (av=0x7fe4c2339640 <main_arena>, p=0x2e7bc80, have_lock=0) at malloc.c:3758
#11 0x000000000041c5d9 in free (alignment=8, x=<optimized out>) at /usr/include/qt4/QtCore/qvector.h:99
#12 free (x=<optimized out>, this=<optimized out>) at /usr/include/qt4/QtCore/qvector.h:468
#13 ~QVector (this=0x7fff0a127200, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qvector.h:124
#14 GameData::onlyFreeInLine (this=this@entry=0x2e6eaf0, position=position@entry=64) at /mnt/shared/portage/portage/kde-base/kmahjongg-4.11.3/work/kmahjongg-4.11.3/GameData.cpp:400
#15 0x000000000041ce47 in GameData::generateSolvableGame (this=this@entry=0x2e6eaf0) at /mnt/shared/portage/portage/kde-base/kmahjongg-4.11.3/work/kmahjongg-4.11.3/GameData.cpp:272
#16 0x000000000041d192 in GameData::generateStartPosition2 (this=0x2e6eaf0) at /mnt/shared/portage/portage/kde-base/kmahjongg-4.11.3/work/kmahjongg-4.11.3/GameData.cpp:573
#17 0x0000000000416033 in BoardWidget::calculateNewGame (this=0x2e6c400, gNumber=gNumber@entry=-1) at /mnt/shared/portage/portage/kde-base/kmahjongg-4.11.3/work/kmahjongg-4.11.3/boardwidget.cpp:756
#18 0x000000000041dced in KMahjonggLayoutSelector::layoutChanged (this=0x2e2eb80) at /mnt/shared/portage/portage/kde-base/kmahjongg-4.11.3/work/kmahjongg-4.11.3/kmahjongglayoutselector.cpp:110
#19 0x00007fe4c27d9cb4 in QMetaObject::activate (sender=sender@entry=0x2e31070, m=m@entry=0x7fe4c3c5c800 <QListWidget::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7fff0a127520) at kernel/qobject.cpp:3547
#20 0x00007fe4c371c6af in QListWidget::currentItemChanged (this=this@entry=0x2e31070, _t1=_t1@entry=0x304e760, _t2=0x2e914d0) at .moc/release-shared/moc_qlistwidget.cpp:246
#21 0x00007fe4c371c7de in QListWidgetPrivate::_q_emitCurrentItemChanged (this=0x2e310a0, current=..., previous=...) at itemviews/qlistwidget.cpp:1112
#22 0x00007fe4c27d9cb4 in QMetaObject::activate (sender=sender@entry=0x2e629c0, m=m@entry=0x7fe4c3c5c0c0 <QItemSelectionModel::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff0a127710) at kernel/qobject.cpp:3547
#23 0x00007fe4c370b35a in QItemSelectionModel::currentChanged (this=this@entry=0x2e629c0, _t1=..., _t2=...) at .moc/release-shared/moc_qitemselectionmodel.cpp:172
#24 0x00007fe4c370b449 in QItemSelectionModel::setCurrentIndex (this=0x2e629c0, index=..., command=...) at itemviews/qitemselectionmodel.cpp:1175
#25 0x00007fe4c36bb208 in QAbstractItemView::mousePressEvent (this=0x2e31070, event=<optimized out>) at itemviews/qabstractitemview.cpp:1682
#26 0x00007fe4c32212a8 in QWidget::event (this=this@entry=0x2e31070, event=event@entry=0x7fff0a128500) at kernel/qwidget.cpp:8372
#27 0x00007fe4c35ae8f6 in QFrame::event (this=0x2e31070, e=0x7fff0a128500) at widgets/qframe.cpp:557
#28 0x00007fe4c36c1ceb in QAbstractItemView::viewportEvent (this=0x2e31070, event=0x7fff0a128500) at itemviews/qabstractitemview.cpp:1644
#29 0x00007fe4c27c5b44 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=this@entry=0x25e1860, receiver=receiver@entry=0x2e315b0, event=event@entry=0x7fff0a128500) at kernel/qcoreapplication.cpp:1059
#30 0x00007fe4c31d3dfc in QApplicationPrivate::notify_helper (this=this@entry=0x25e1860, receiver=receiver@entry=0x2e315b0, e=e@entry=0x7fff0a128500) at kernel/qapplication.cpp:4558
#31 0x00007fe4c31d7039 in QApplication::notify (this=this@entry=0x7fff0a129130, receiver=receiver@entry=0x2e315b0, e=e@entry=0x7fff0a128500) at kernel/qapplication.cpp:4105
#32 0x00007fe4c3ed08d6 in KApplication::notify (this=0x7fff0a129130, receiver=0x2e315b0, event=0x7fff0a128500) at /mnt/shared/portage/portage/kde-base/kdelibs-4.11.3/work/kdelibs-4.11.3/kdeui/kernel/kapplication.cpp:311
#33 0x00007fe4c27c59de in QCoreApplication::notifyInternal (this=0x7fff0a129130, receiver=receiver@entry=0x2e315b0, event=event@entry=0x7fff0a128500) at kernel/qcoreapplication.cpp:949
#34 0x00007fe4c31d9f1b in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#35 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x2e315b0, event=event@entry=0x7fff0a128500, alienWidget=alienWidget@entry=0x2e315b0, nativeWidget=nativeWidget@entry=0x2d98890, buttonDown=buttonDown@entry=0x7fe4c3c7a208 <qt_button_down>, lastMouseReceiver=..., spontaneous=spontaneous@entry=true) at kernel/qapplication.cpp:3173
#36 0x00007fe4c324d0d4 in QETWidget::translateMouseEvent (this=this@entry=0x2d98890, event=event@entry=0x7fff0a128c50) at kernel/qapplication_x11.cpp:4517
#37 0x00007fe4c324b9d1 in QApplication::x11ProcessEvent (this=0x7fff0a129130, event=event@entry=0x7fff0a128c50) at kernel/qapplication_x11.cpp:3640
#38 0x00007fe4c32745ea in x11EventSourceDispatch (s=s@entry=0x25e4800, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#39 0x00007fe4bddc6055 in g_main_dispatch (context=0x25de8d0) at /var/tmp/portage/dev-libs/glib-2.36.4-r1/work/glib-2.36.4/glib/gmain.c:3054
#40 g_main_context_dispatch (context=context@entry=0x25de8d0) at /var/tmp/portage/dev-libs/glib-2.36.4-r1/work/glib-2.36.4/glib/gmain.c:3630
#41 0x00007fe4bddc6398 in g_main_context_iterate (context=context@entry=0x25de8d0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /var/tmp/portage/dev-libs/glib-2.36.4-r1/work/glib-2.36.4/glib/gmain.c:3701
#42 0x00007fe4bddc6454 in g_main_context_iteration (context=0x25de8d0, may_block=1) at /var/tmp/portage/dev-libs/glib-2.36.4-r1/work/glib-2.36.4/glib/gmain.c:3762
#43 0x00007fe4c27f3d36 in QEventDispatcherGlib::processEvents (this=0x25b3ba0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#44 0x00007fe4c32746be in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007fe4c27c468f in QEventLoop::processEvents (this=this@entry=0x7fff0a129010, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007fe4c27c4918 in QEventLoop::exec (this=this@entry=0x7fff0a129010, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007fe4c27c9b78 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#48 0x00007fe4c31d277c in QApplication::exec () at kernel/qapplication.cpp:3823
#49 0x000000000040fe51 in main (argc=1, argv=0x7fff0a129268) at /mnt/shared/portage/portage/kde-base/kmahjongg-4.11.3/work/kmahjongg-4.11.3/main.cpp:64

Possible duplicates by query: bug 322518, bug 321465, bug 320526, bug 320128, bug 314055.

Reported using DrKonqi
Comment 1 Oleg Kukharchuk 2013-11-08 23:07:56 UTC
Created attachment 83435 [details]
layout file
Comment 2 Jekyll Wu 2013-11-08 23:18:25 UTC

*** This bug has been marked as a duplicate of bug 322518 ***
Comment 3 Jekyll Wu 2013-11-08 23:19:11 UTC

*** This bug has been marked as a duplicate of bug 188413 ***
Comment 4 Mark Purcell 2013-11-10 06:33:39 UTC
Control: forward -1 https://bugs.kde.org/show_bug.cgi?id=327377
Control: severity -1 important

On Sat, 9 Nov 2013 15:53:04 Rainer Dorsch wrote:
> Upgrade: digikam-private-libs:i386 (3.4.0-1, 3.5.0-2), digikam:i386
> (3.4.0-1, 3.5.0-2),  digikam-data:i386 (3.4.0-1, 3.5.0-2)

Rainer,

I see you have also filed a report with upstream, so have noted the Debian bug 
as forwarded.

There has been very little change between your upgraded versions (3.4 -> 3.5), 
as this was a maintenance release, I believe 5 bugs were fixed:
https://bugs.kde.org/buglist.cgi?f1=cf_versionfixedin&o1=equals&query_format=advanced&bug_status=RESOLVED&bug_status=NEEDSINFO&bug_status=VERIFIED&bug_status=CLOSED&v1=3.5.0&product=digikam&product=digikamimageplugins&product=kipiplugins&product=showfoto

There have also been no other reports of albums disappearing, although 3.5 has 
been available since 10 October, so I have set the severity of your report to 
important.

I would imagine it has to do with the location of your digikam4.db file, is 
that located in your Pictures directory and have you changed this?  I would 
recommend you check the quality of these databases, especially your backup 
before you used digikam/3.5:
http://userbase.kde.org/Digikam/Check_Database

Your tags can also be located in digikam4.db, unless you choose to store them 
in each picture file.

I'll let the digikam team provide you some further assistance via 327337.

Mark
Comment 5 Christoph Feck 2013-11-17 23:52:01 UTC
Mark, comment #4 was added to the wrong bug report. Can you check the forwarding?