Bug 327241 - Attachment not recognized by KMail2 (not shown as icon and not filtered correctly)
Summary: Attachment not recognized by KMail2 (not shown as icon and not filtered corre...
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: message list (show other bugs)
Version: 4.13
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-06 19:11 UTC by Till Schäfer
Modified: 2015-01-31 14:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.14.6


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Till Schäfer 2013-11-06 19:11:48 UTC
I am using an akonadi imap recourse with offline imap enabled. Many mails with an attachment are not recognized as mail with attachment. This causes the message list to not display the attachment icon and the status filter (drop down box at the top right corner right of the quick filter) to not work correctly. 

This bug is not the same as bug 80995, because all messages are downloaded completely (imap offline mode). Also clicking on and displaying the message does not help. 

This bug is only present for the majority of the mails with an attachment. Some mails attachments are recognized correctly. 

Reproducible: Sometimes

Steps to Reproduce:
1. receive a mail with attachment
2. message list does not display the attachment, nor filter correctly for attachments




akonadi server is at version 1.10.3
Comment 1 Till Schäfer 2014-01-14 17:02:58 UTC
still present for akonadi server 1.11 and kmail 4.12

maybe related to Bug 329964
Comment 2 Martin Koller 2015-01-31 14:50:45 UTC
Git commit 0cb0e2f5efc7d76033f9b9ccc83aeebe9845f338 by Martin Koller.
Committed on 31/01/2015 at 14:44.
Pushed by mkoller into branch 'KDE/4.14'.

Fix missing mail flags; avoid code duplication

This patch uses the new method Akonadi::MessageFlags::copyMessageFlags()
to copy the mail message flags into Akonadi objects, avoiding
code duplication.
Some places did not do this previously leading to mail flags never
appearing (or getting lost) in Akonadi
Related: bug 286692, bug 313401, bug 342756
FIXED-IN: 4.14.6
REVIEW: 122224

M  +1    -1    CMakeLists.txt
M  +1    -13   resources/imap/messagehelper.cpp
M  +3    -0    resources/maildir/maildirresource.cpp
M  +2    -0    resources/maildir/retrieveitemsjob.cpp
M  +6    -0    resources/mbox/mboxresource.cpp
M  +3    -0    resources/mixedmaildir/mixedmaildirstore.cpp
M  +2    -9    resources/pop3/pop3resource.cpp

http://commits.kde.org/kdepim-runtime/0cb0e2f5efc7d76033f9b9ccc83aeebe9845f338