Bug 327197 - When add one face tag in mainview/albums/one pictures view digikam and/or opencv fullfill the memory
Summary: When add one face tag in mainview/albums/one pictures view digikam and/or ope...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Faces-Detection (show other bugs)
Version: 4.0.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-06 00:56 UTC by e.longuemare
Modified: 2019-12-23 07:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description e.longuemare 2013-11-06 00:56:18 UTC
When add one face tag in mainview/albums/one pictures view digikam and/or opencv fullfill the memory

Reproducible: Always

Steps to Reproduce:
1.Go to album view, switch to one picture view by clicking on thumb
2.Activate face tag to show face tag
3.Add a tag (draw it) and add a know face tag (know in recognition.db)
4. doing nothing else and wait
Actual Results:  
Digikam process use more and more memory, then opencv give and insufficient memory error message.

Expected Results:  
Face tag is added to picture without fullfill the memory and make the system unusable (have to wait for  task is finished) or all system crash.

LOGS from GDB (not a complete system crash) :
##START OF LOG ###
digikam(26113)/digikam (core) Digikam::FaceUtils::identityForTag: Found kface identity 8 for tag 38
[New Thread 0x9d1c2b40 (LWP 26192)]
digikam(26113)/KFACE KFaceIface::trainIdentityBatch: Training 1 images for identity 8
############[Thread 0x9d1c2b40 (LWP 26192) exited]
[Thread 0x94592b40 (LWP 26187) exited]
#######TAG ONE ######### 3 lignes aboveOpenCV Error: Insufficient memory (Failed to allocate 262144 bytes) in OutOfMemoryError, file /home/eric/opencv-2-4-5-SH/OpenCV/opencv-2.4.5/modules/core/src/alloc.cpp, line 52
digikam(26113)/KFACE: cv::Exception training LBPH: /home/eric/opencv-2-4-5-SH/OpenCV/opencv-2.4.5/modules/core/src/alloc.cpp:52: error: (-4) Failed to allocate 262144 bytes in function OutOfMemoryError
 
digikam(26113)/digikam (core) Digikam::FacePipeline::Private::checkFinished: Check for finish:  0 packages, 0 infos to filter, hasFinished() true
[Thread 0x95594b40 (LWP 26188) exited]
[Thread 0x93d91b40 (LWP 26189) exited]
[New Thread 0x93d91b40 (LWP 26252)]
[Thread 0x93d91b40 (LWP 26252) exited]
### End of log ###
Comment 1 caulier.gilles 2013-11-06 06:40:02 UTC
Problem already reported...

Gilles Caulier

*** This bug has been marked as a duplicate of bug 323888 ***
Comment 2 caulier.gilles 2019-12-23 07:58:20 UTC
Problem is fixed with new 7.0.0-beta1 through this long story from this bug

https://bugs.kde.org/show_bug.cgi?id=399923

You can test digiKam 7.0.0-beta1 with bundle available here:

https://download.kde.org/unstable/digikam/

Don't hesitate to give us a fresh feedback about his entry.

Thanks in advance

Gilles Caulier