Bug 326998 - General KTp settings cannot be reached from the presence applet
Summary: General KTp settings cannot be reached from the presence applet
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: presence-applet (show other bugs)
Version: 0.7.0
Platform: unspecified Linux
: NOR wishlist
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-01 13:53 UTC by Thomas Pfeiffer
Modified: 2014-04-06 19:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Pfeiffer 2013-11-01 13:53:41 UTC
We are now at a point where you can do almost anything with KTp without opening the main contact list window. However, one of the few things you can only reach via that window are the settings. This is a problem because when users find pretty much everything else right in the context menu of the presence applet, they'd not expect having to open the contact list to get to the settings.
I'd recommend replacing the "Accounts Manager" menu entry with "KDE Telepathy Settings" which would then include the Accounts settings.

Reproducible: Always
Comment 1 Siddhartha 2014-04-06 19:15:17 UTC
Git commit 1ec052e1d9b121659e16745aadcee19c55ba5da1 by Siddhartha Sahu.
Committed on 30/03/2014 at 07:47.
Pushed by siddharthasahu into branch 'master'.

Use SettingsKcmDialog from K-C-I

REVIEW: 117181

M  +9    -5    presence/src/presence-applet.cpp
M  +1    -1    presence/src/presence-applet.h

http://commits.kde.org/telepathy-contact-applet/1ec052e1d9b121659e16745aadcee19c55ba5da1