Bug 326892 - kded-obexftpdaemon crashes on adapter removal
Summary: kded-obexftpdaemon crashes on adapter removal
Status: RESOLVED DUPLICATE of bug 308324
Alias: None
Product: solid
Classification: Unclassified
Component: bluetooth-daemon (show other bugs)
Version: 4.11.60
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-10-30 16:34 UTC by Michi
Modified: 2014-01-19 20:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michi 2013-10-30 16:34:15 UTC
Application: kded4 (4.11.60)
KDE Platform Version: 4.11.60
Qt Version: 4.8.5
Operating System: Linux 3.12.0-rc5-mic x86_64
Distribution (Platform): openSUSE RPMs

-- Information about the crash:
- What I was doing when the application crashed:

unplugging the BT dongle

I think I should add that I have bluez5 installed. KDE is a very recent 4.12 snapshot from OBS.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Dæmon (kded4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb000421780 (LWP 2244))]

Thread 4 (Thread 0x7fafdf16e700 (LWP 2258)):
#0  0x00007faffda49a01 in poll () from /lib64/libc.so.6
#1  0x00007faffa9545c4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007faffa9546cc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fafff0acd76 in QEventDispatcherGlib::processEvents (this=0x1d4f0d0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x00007fafff07ed0f in QEventLoop::processEvents (this=this@entry=0x7fafdf16de20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fafff07f005 in QEventLoop::exec (this=this@entry=0x7fafdf16de20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007faffef7dfef in QThread::exec (this=this@entry=0x1d23ed0) at thread/qthread.cpp:536
#7  0x00007fafff060513 in QInotifyFileSystemWatcherEngine::run (this=0x1d23ed0) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007faffef8068f in QThreadPrivate::start (arg=0x1d23ed0) at thread/qthread_unix.cpp:338
#9  0x00007faffece90db in start_thread () from /lib64/libpthread.so.0
#10 0x00007faffda527cd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fafde766700 (LWP 2266)):
#0  0x00007faffeceb440 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007faffa994251 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007faffa953e5b in g_main_context_query () from /usr/lib64/libglib-2.0.so.0
#3  0x00007faffa954532 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007faffa9546cc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fafff0acd76 in QEventDispatcherGlib::processEvents (this=0x1f150f0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00007fafff07ed0f in QEventLoop::processEvents (this=this@entry=0x7fafde765e20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fafff07f005 in QEventLoop::exec (this=this@entry=0x7fafde765e20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007faffef7dfef in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#9  0x00007fafe32604a7 in KCupsConnection::run() () from /usr/lib64/libkcupslib.so
#10 0x00007faffef8068f in QThreadPrivate::start (arg=0x1de3750) at thread/qthread_unix.cpp:338
#11 0x00007faffece90db in start_thread () from /lib64/libpthread.so.0
#12 0x00007faffda527cd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fafddf65700 (LWP 2267)):
#0  0x00007fff7503d827 in clock_gettime ()
#1  0x00007faffda5f8cd in clock_gettime () from /lib64/libc.so.6
#2  0x00007faffefd4e47 in do_gettime (frac=0x7fafddf64bf0, sec=0x7fafddf64be8) at tools/qelapsedtimer_unix.cpp:127
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:144
#4  0x00007fafff0ae405 in updateCurrentTime (this=0x1f162e0) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0x1f162e0, tm=...) at kernel/qeventdispatcher_unix.cpp:460
#6  0x00007fafff0acbac in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fafddf64ca4) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fafff0acc55 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007faffa953c6d in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007faffa9544e3 in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007faffa9546cc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007fafff0acd76 in QEventDispatcherGlib::processEvents (this=0x1df3750, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#12 0x00007fafff07ed0f in QEventLoop::processEvents (this=this@entry=0x7fafddf64e60, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fafff07f005 in QEventLoop::exec (this=this@entry=0x7fafddf64e60, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007faffef7dfef in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#15 0x00007faffef8068f in QThreadPrivate::start (arg=0x1cb89d0) at thread/qthread_unix.cpp:338
#16 0x00007faffece90db in start_thread () from /lib64/libpthread.so.0
#17 0x00007faffda527cd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fb000421780 (LWP 2244)):
[KCrash Handler]
#5  QHashData::nextNode (node=0x21bda60) at tools/qhash.cpp:294
#6  0x00007fafd4f815ee in ObexFtpDaemon::offlineMode() () from /usr/lib64/kde4/kded_obexftpdaemon.so
#7  0x00007fafd4f8043c in ObexFtpDaemon::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) [clone .part.2] () from /usr/lib64/kde4/kded_obexftpdaemon.so
#8  0x00007fafff093d68 in QMetaObject::activate (sender=0x2192d30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff750169b0) at kernel/qobject.cpp:3556
#9  0x00007fafd5199fe2 in BlueDevil::Manager::usableAdapterChanged(BlueDevil::Adapter*) () from /usr/lib64/libbluedevil.so.2
#10 0x00007fafd519b797 in BlueDevil::Manager::Private::_k_interfacesRemoved(QDBusObjectPath const&, QStringList const&) () from /usr/lib64/libbluedevil.so.2
#11 0x00007fafff093d68 in QMetaObject::activate (sender=0x218fd10, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff75016c80) at kernel/qobject.cpp:3556
#12 0x00007fafd51a9a41 in ?? () from /usr/lib64/libbluedevil.so.2
#13 0x00007fafd51a9df3 in ?? () from /usr/lib64/libbluedevil.so.2
#14 0x00007faffbdc2ead in ?? () from /usr/lib64/libQtDBus.so.4
#15 0x00007fafff09811e in QObject::event (this=0x218fd10, e=<optimized out>) at kernel/qobject.cpp:1203
#16 0x00007faffe1ff8ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#17 0x00007faffe205e70 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#18 0x00007fafffe2651a in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#19 0x00007fafff0800ad in QCoreApplication::notifyInternal (this=0x7fff75017650, receiver=receiver@entry=0x218fd10, event=event@entry=0x243c4c0) at kernel/qcoreapplication.cpp:949
#20 0x00007fafff0830ff in sendEvent (event=0x243c4c0, receiver=0x218fd10) at kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x19df480) at kernel/qcoreapplication.cpp:1573
#22 0x00007fafff0835a3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1466
#23 0x00007fafff0ad493 in sendPostedEvents () at kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=0x1a8dd50) at kernel/qeventdispatcher_glib.cpp:280
#25 0x00007faffa9542d6 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#26 0x00007faffa954628 in ?? () from /usr/lib64/libglib-2.0.so.0
#27 0x00007faffa9546cc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#28 0x00007fafff0acd55 in QEventDispatcherGlib::processEvents (this=0x19e5fe0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#29 0x00007faffe29c936 in ?? () from /usr/lib64/libQtGui.so.4
#30 0x00007fafff07ed0f in QEventLoop::processEvents (this=this@entry=0x7fff75017520, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007fafff07f005 in QEventLoop::exec (this=this@entry=0x7fff75017520, flags=...) at kernel/qeventloop.cpp:204
#32 0x00007fafff08413b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#33 0x00007fafea117fbb in kdemain () from /usr/lib64/libkdeinit4_kded4.so
#34 0x000000000040879e in _start ()

Reported using DrKonqi
Comment 1 Alex Fiestas 2014-01-19 20:51:57 UTC

*** This bug has been marked as a duplicate of bug 308324 ***