Bug 326789 - kslideshow.kss doesn't terminate when screen is unlocked
Summary: kslideshow.kss doesn't terminate when screen is unlocked
Status: RESOLVED DUPLICATE of bug 224200
Alias: None
Product: kscreensaver
Classification: Unclassified
Component: general (show other bugs)
Version: 4.11.2
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-28 16:01 UTC by Micha
Modified: 2013-10-29 03:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Micha 2013-10-28 16:01:15 UTC
Ever since the upgrade to the new Kubuntu version (Saucy) kslideshow.kss doesn't terminate when I unlock the screen, and it not only continues running but consumes 5-10% CPU.  If I don't kill it manually, after several lock-unlock cycles I see multiple kslideshow.kss processes, all consuming CPU.  I thought initially that this might have happened because my slideshow is set to display images from an NTFS partition but I set it to display from a native partition and the issue persists.  I should also note that with the previous Kubuntu versions I received from time to time a notification that the slideshow has crashed but I never saw multiple kslideshow.kss processes running and never seen it consuming CPU when the system was unlocked.

Reproducible: Always

Steps to Reproduce:
1. Wait until the system starts the slideshow.
2. Unlock the system and use "top" to display active processes.
3.
Actual Results:  
kslideshow.kss running in the background and consuming CPU.

Expected Results:  
No kslideshow.kss running with system unlocked.
Comment 1 Jekyll Wu 2013-10-29 03:38:05 UTC

*** This bug has been marked as a duplicate of bug 224200 ***