Bug 326701 - Screensaver consumes lots of CPU even after done
Summary: Screensaver consumes lots of CPU even after done
Status: RESOLVED DUPLICATE of bug 224200
Alias: None
Product: kscreensaver
Classification: Unclassified
Component: screensavers (show other bugs)
Version: 4.11.2
Platform: Kubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-26 19:07 UTC by msmigiel
Modified: 2014-04-17 06:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description msmigiel 2013-10-26 19:07:10 UTC
Whenever one of the KDE screensavers runs (in my case, KDE Asciiquarium), after the screensaver is done running (in my case with no password), the process 'kdeasciiquarium' stays running and consumes about 30% of the CPU. It won't die unless I kill it manually.

I have been using Kubuntu since version 12.04 and have not seen this problem until I upgraded to version 13.10.

Reproducible: Always

Steps to Reproduce:
1. Have screensaver KDE Asciiquarium set to run (in my case after 10 minutes). I have no password required.
2. Wait time required for screensaver to turn on.
3. After a minute or two, hit a key to turn off the screensaver. Note the process still running consuming a lot of CPU.
Actual Results:  
The screen saver process stays running, consuming 30% of my CPU.

Expected Results:  
The screensaver process should be killed and not hoggingthe CPU.

I have only seen this going on Kubuntu 13.10. This is a 5-ish year old Toshiba Satellite laptop with only Kubuntu on it.
Comment 1 msmigiel 2013-10-26 19:27:01 UTC
Note, I have seen this defect below and while I think it's related, I am not sure it's the same issue as the "blank" screen saver works for me and this bug has no mention of lots of CPU consumption.

https://bugs.kde.org/show_bug.cgi?id=224200
Comment 2 Wolfgang Bauer 2014-04-17 06:48:00 UTC
(In reply to comment #1)
> Note, I have seen this defect below and while I think it's related, I am not
> sure it's the same issue as the "blank" screen saver works for me and this
> bug has no mention of lots of CPU consumption.
> 
> https://bugs.kde.org/show_bug.cgi?id=224200
I think this is actually the same bug, yes.

The screensaver processes that keep running do of course consume the CPU, how much depends on the particular screen saver obviously.

As to why it doesn't happen with _all_ screen savers (it even seems to happen with different ones on different systems), I am not sure really.
But I do have a patch ready that fixes the issue for me. (I haven't seen any left-over screen saver processes in 2 weeks now... ;-) )

*** This bug has been marked as a duplicate of bug 224200 ***