Bug 326443 - Amarok crashes on startup
Summary: Amarok crashes on startup
Status: RESOLVED DUPLICATE of bug 323635
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.8.0
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: 2.9
Assignee: Amarok Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-10-22 14:08 UTC by mr.soup12
Modified: 2013-10-22 15:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mr.soup12 2013-10-22 14:08:49 UTC
Application: amarok (2.8.0)
KDE Platform Version: 4.11.2
Qt Version: 4.8.5
Operating System: Linux 3.11.3-201.fc19.i686 i686
Distribution: "Fedora release 19 (Schrödinger’s Cat)"

-- Information about the crash:
Attempt to start amarok, experience crash when opening from tray.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb77a57c0 (LWP 2236))]

Thread 11 (Thread 0xb0b70b40 (LWP 2239)):
#0  0xb77ec424 in __kernel_vsyscall ()
#1  0x4f3345db in poll () from /lib/libc.so.6
#2  0x43cb092e in poll_func () from /lib/libpulse.so.0
#3  0x43c9f1ff in pa_mainloop_poll () from /lib/libpulse.so.0
#4  0x43c9fa3e in pa_mainloop_iterate () from /lib/libpulse.so.0
#5  0x43c9fb14 in pa_mainloop_run () from /lib/libpulse.so.0
#6  0x43cb08cd in thread () from /lib/libpulse.so.0
#7  0x43c56ffe in internal_thread_func () from /usr/lib/pulseaudio/libpulsecommon-3.0.so
#8  0x4f4179da in start_thread () from /lib/libpthread.so.0
#9  0x4f340c0e in clone () from /lib/libc.so.6

Thread 10 (Thread 0xaaa82b40 (LWP 2241)):
#0  0xb77ec424 in __kernel_vsyscall ()
#1  0x4f41b724 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x4f34e5e4 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xab302b76 in my_service_thread_sleep () from /usr/lib/mysql/libmysqld.so.18
#4  0xaafb2afd in ma_checkpoint_background () from /usr/lib/mysql/libmysqld.so.18
#5  0x4f4179da in start_thread () from /lib/libpthread.so.0
#6  0x4f340c0e in clone () from /lib/libc.so.6

Thread 9 (Thread 0xa0f0ab40 (LWP 2242)):
#0  0xb77ec424 in __kernel_vsyscall ()
#1  0x4f41b724 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x4f34e5e4 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x410f99a3 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib/libQtCore.so.4
#4  0x464d9c92 in AbstractDirectoryWatcher::run() () from /lib/libamaroklib.so.1
#5  0x422f490a in ThreadWeaver::JobRunHelper::runTheJob(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /lib/libthreadweaver.so.4
#6  0x422f4b06 in ThreadWeaver::Job::execute(ThreadWeaver::Thread*) () from /lib/libthreadweaver.so.4
#7  0x422f421c in ThreadWeaver::Thread::run() () from /lib/libthreadweaver.so.4
#8  0x410f9450 in QThreadPrivate::start(void*) () from /lib/libQtCore.so.4
#9  0x4f4179da in start_thread () from /lib/libpthread.so.0
#10 0x4f340c0e in clone () from /lib/libc.so.6

Thread 8 (Thread 0xa05ffb40 (LWP 2243)):
#0  0x4f55a0f3 in __x86.get_pc_thunk.bx () from /lib/libglib-2.0.so.0
#1  0x4f5cef7b in g_mutex_get_impl () from /lib/libglib-2.0.so.0
#2  0x4f5cf2b9 in g_mutex_lock () from /lib/libglib-2.0.so.0
#3  0x4f58a40e in g_main_context_acquire () from /lib/libglib-2.0.so.0
#4  0x4f58b2c9 in g_main_context_iterate.isra.21 () from /lib/libglib-2.0.so.0
#5  0x4f58b569 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#6  0x4123cb7f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#7  0x4120b444 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#8  0x4120b781 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#9  0x410f6a9d in QThread::exec() () from /lib/libQtCore.so.4
#10 0x411eb1d5 in QInotifyFileSystemWatcherEngine::run() () from /lib/libQtCore.so.4
#11 0x410f9450 in QThreadPrivate::start(void*) () from /lib/libQtCore.so.4
#12 0x4f4179da in start_thread () from /lib/libpthread.so.0
#13 0x4f340c0e in clone () from /lib/libc.so.6

Thread 7 (Thread 0x9fc72b40 (LWP 2244)):
#0  0xb77ec424 in __kernel_vsyscall ()
#1  0x4f41b33c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x4f34e58c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x410f99c5 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib/libQtCore.so.4
#4  0x422f2704 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned(ThreadWeaver::Thread*) () from /lib/libthreadweaver.so.4
#5  0x422f57ec in ThreadWeaver::WorkingHardState::waitForAvailableJob(ThreadWeaver::Thread*) () from /lib/libthreadweaver.so.4
#6  0x422f265b in ThreadWeaver::WeaverImpl::waitForAvailableJob(ThreadWeaver::Thread*) () from /lib/libthreadweaver.so.4
#7  0x422f58d2 in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /lib/libthreadweaver.so.4
#8  0x422f1543 in ThreadWeaver::WeaverImpl::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /lib/libthreadweaver.so.4
#9  0x422f4183 in ThreadWeaver::Thread::run() () from /lib/libthreadweaver.so.4
#10 0x410f9450 in QThreadPrivate::start(void*) () from /lib/libQtCore.so.4
#11 0x4f4179da in start_thread () from /lib/libpthread.so.0
#12 0x4f340c0e in clone () from /lib/libc.so.6

Thread 6 (Thread 0x9f471b40 (LWP 2245)):
#0  0xb77ec424 in __kernel_vsyscall ()
#1  0x4f41b33c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x4f34e58c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x410f99c5 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib/libQtCore.so.4
#4  0x422f2704 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned(ThreadWeaver::Thread*) () from /lib/libthreadweaver.so.4
#5  0x422f57ec in ThreadWeaver::WorkingHardState::waitForAvailableJob(ThreadWeaver::Thread*) () from /lib/libthreadweaver.so.4
#6  0x422f265b in ThreadWeaver::WeaverImpl::waitForAvailableJob(ThreadWeaver::Thread*) () from /lib/libthreadweaver.so.4
#7  0x422f58d2 in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /lib/libthreadweaver.so.4
#8  0x422f1543 in ThreadWeaver::WeaverImpl::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /lib/libthreadweaver.so.4
#9  0x422f4183 in ThreadWeaver::Thread::run() () from /lib/libthreadweaver.so.4
#10 0x410f9450 in QThreadPrivate::start(void*) () from /lib/libQtCore.so.4
#11 0x4f4179da in start_thread () from /lib/libpthread.so.0
#12 0x4f340c0e in clone () from /lib/libc.so.6

Thread 5 (Thread 0x9ec70b40 (LWP 2246)):
#0  0xb77ec424 in __kernel_vsyscall ()
#1  0x4f41b33c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x4f34e58c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x410f99c5 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib/libQtCore.so.4
#4  0x422f2704 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned(ThreadWeaver::Thread*) () from /lib/libthreadweaver.so.4
#5  0x422f57ec in ThreadWeaver::WorkingHardState::waitForAvailableJob(ThreadWeaver::Thread*) () from /lib/libthreadweaver.so.4
#6  0x422f265b in ThreadWeaver::WeaverImpl::waitForAvailableJob(ThreadWeaver::Thread*) () from /lib/libthreadweaver.so.4
#7  0x422f58d2 in ThreadWeaver::WorkingHardState::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /lib/libthreadweaver.so.4
#8  0x422f1543 in ThreadWeaver::WeaverImpl::applyForWork(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /lib/libthreadweaver.so.4
#9  0x422f4183 in ThreadWeaver::Thread::run() () from /lib/libthreadweaver.so.4
#10 0x410f9450 in QThreadPrivate::start(void*) () from /lib/libQtCore.so.4
#11 0x4f4179da in start_thread () from /lib/libpthread.so.0
#12 0x4f340c0e in clone () from /lib/libc.so.6

Thread 4 (Thread 0x9cbe4b40 (LWP 2247)):
#0  0xb77ec424 in __kernel_vsyscall ()
#1  0x4f41b33c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x4929d8b4 in WTF::TCMalloc_PageHeap::scavengerThread() () from /lib/libQtWebKit.so.4
#3  0x4929d900 in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /lib/libQtWebKit.so.4
#4  0x4f4179da in start_thread () from /lib/libpthread.so.0
#5  0x4f340c0e in clone () from /lib/libc.so.6

Thread 3 (Thread 0x9ba9bb40 (LWP 2251)):
#0  0xb77ec424 in __kernel_vsyscall ()
#1  0x4f3345db in poll () from /lib/libc.so.6
#2  0x4f59aacc in g_poll () from /lib/libglib-2.0.so.0
#3  0x4f58b428 in g_main_context_iterate.isra.21 () from /lib/libglib-2.0.so.0
#4  0x4f58b569 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x4123cb7f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#6  0x4120b444 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#7  0x4120b781 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#8  0x410f6a9d in QThread::exec() () from /lib/libQtCore.so.4
#9  0x410f6bfc in QThread::run() () from /lib/libQtCore.so.4
#10 0x410f9450 in QThreadPrivate::start(void*) () from /lib/libQtCore.so.4
#11 0x4f4179da in start_thread () from /lib/libpthread.so.0
#12 0x4f340c0e in clone () from /lib/libc.so.6

Thread 2 (Thread 0x9b1f3b40 (LWP 2252)):
#0  0xb77ec424 in __kernel_vsyscall ()
#1  0x4f41b33c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x4f34e58c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x431c9752 in QTWTF::TCMalloc_PageHeap::scavengerThread() () from /lib/libQtScript.so.4
#4  0x431c97a0 in QTWTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /lib/libQtScript.so.4
#5  0x4f4179da in start_thread () from /lib/libpthread.so.0
#6  0x4f340c0e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77a57c0 (LWP 2236)):
[KCrash Handler]
#6  0x9e1a24b6 in intel_miptree_map () from /usr/lib/dri/i915_dri.so
#7  0x9e1d0794 in intel_map_renderbuffer () from /usr/lib/dri/i915_dri.so
#8  0x9df0bf4d in map_attachment () from /lib/libdricore9.2.0.so.1
#9  0x9df0c7d9 in _swrast_map_renderbuffers () from /lib/libdricore9.2.0.so.1
#10 0x9df00565 in _swrast_span_render_start () from /lib/libdricore9.2.0.so.1
#11 0x9df017ea in _swrast_render_start () from /lib/libdricore9.2.0.so.1
#12 0x9df4d0ff in _swsetup_RenderStart () from /lib/libdricore9.2.0.so.1
#13 0x9dedd233 in run_render () from /lib/libdricore9.2.0.so.1
#14 0x9ded7de4 in _tnl_run_pipeline () from /lib/libdricore9.2.0.so.1
#15 0x9e1cf683 in intelRunPipeline () from /usr/lib/dri/i915_dri.so
#16 0x9ded876a in _tnl_draw_prims () from /lib/libdricore9.2.0.so.1
#17 0x9ded8e84 in _tnl_vbo_draw_prims () from /lib/libdricore9.2.0.so.1
#18 0x9dec3859 in vbo_draw_arrays () from /lib/libdricore9.2.0.so.1
#19 0x9dec3a62 in vbo_exec_DrawArrays () from /lib/libdricore9.2.0.so.1
#20 0x434bdaf6 in glDrawArrays () from /lib/libGL.so.1
#21 0x42ea34f1 in QGL2PaintEngineExPrivate::drawTexture(QGLRect const&, QGLRect const&, QSize const&, bool, bool) () from /lib/libQtOpenGL.so.4
#22 0x42ea3807 in QGL2PaintEngineEx::drawPixmap(QRectF const&, QPixmap const&, QRectF const&) () from /lib/libQtOpenGL.so.4
#23 0x4564d23b in QPaintEngineEx::drawPixmap(QPointF const&, QPixmap const&) () from /lib/libQtGui.so.4
#24 0x45665ee3 in QPainter::drawPixmap(QPointF const&, QPixmap const&) () from /lib/libQtGui.so.4
#25 0x9e1f4216 in BlockAnalyzer::paintEvent(QPaintEvent*) () from /usr/lib/kde4/amarok_context_applet_analyzer.so
#26 0x4554bbed in QWidget::event(QEvent*) () from /lib/libQtGui.so.4
#27 0x42e4a95e in QGLWidget::event(QEvent*) () from /lib/libQtOpenGL.so.4
#28 0x454f1174 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/libQtGui.so.4
#29 0x454f7c89 in QApplication::notify(QObject*, QEvent*) () from /lib/libQtGui.so.4
#30 0x41d50f35 in KApplication::notify(QObject*, QEvent*) () from /lib/libkdeui.so.5
#31 0x4120ca3a in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib/libQtCore.so.4
#32 0x45545831 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /lib/libQtGui.so.4
#33 0x45731624 in QWidgetPrivate::repaint_sys(QRegion const&) () from /lib/libQtGui.so.4
#34 0x455396b8 in QWidgetPrivate::syncBackingStore() () from /lib/libQtGui.so.4
#35 0x4554b62c in QWidget::event(QEvent*) () from /lib/libQtGui.so.4
#36 0x42e4a95e in QGLWidget::event(QEvent*) () from /lib/libQtOpenGL.so.4
#37 0x454f1174 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/libQtGui.so.4
#38 0x454f7c89 in QApplication::notify(QObject*, QEvent*) () from /lib/libQtGui.so.4
#39 0x41d50f35 in KApplication::notify(QObject*, QEvent*) () from /lib/libkdeui.so.5
#40 0x4120ca3a in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib/libQtCore.so.4
#41 0x4120fd55 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/libQtCore.so.4
#42 0x4121027d in QCoreApplication::sendPostedEvents(QObject*, int) () from /lib/libQtCore.so.4
#43 0x4123d38f in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib/libQtCore.so.4
#44 0x4f58b0f6 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#45 0x4f58b4a8 in g_main_context_iterate.isra.21 () from /lib/libglib-2.0.so.0
#46 0x4f58b569 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#47 0x4123cb60 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#48 0x455a227f in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtGui.so.4
#49 0x4120b444 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#50 0x4120b781 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#51 0x4121121f in QCoreApplication::exec() () from /lib/libQtCore.so.4
#52 0x454ef5c5 in QApplication::exec() () from /lib/libQtGui.so.4
#53 0x0804f8b5 in main ()

The reporter indicates this bug may be a duplicate of or related to bug 323635.

Possible duplicates by query: bug 325894, bug 323824.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2013-10-22 15:34:18 UTC
The problem is upstream with OpenGL, not much we can do about. As a workaround, please see https://bugs.kde.org/show_bug.cgi?id=323635#c14

*** This bug has been marked as a duplicate of bug 323635 ***