Bug 326194 - Movie player controls only show up at the first playing of the movie
Summary: Movie player controls only show up at the first playing of the movie
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: PDF backend (show other bugs)
Version: 0.17.60
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-18 10:33 UTC by Oliver Sander
Modified: 2013-10-29 14:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.3


Attachments
Example pdf file (22.19 KB, application/x-download)
2013-10-18 10:34 UTC, Oliver Sander
Details
The movie played by the pdf (325.64 KB, video/ogg)
2013-10-18 10:34 UTC, Oliver Sander
Details
The corresponding tex sources (688 bytes, text/x-tex)
2013-10-18 10:35 UTC, Oliver Sander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Sander 2013-10-18 10:33:30 UTC
I use the LaTeX 'multimedia' package to show movie files within my pdf presentations.  The package has an option 'showcontrols', which should show & enable the movie player controls while playing the movie.  This does work, but only during the first time the movie is played.  Clicking on the movie again to play it a second time plays the movie, but the controls are not there.

I can make the controls reappear by either reloading the file, or by switching to presentation mode (or back).

Reproducible: Always
Comment 1 Oliver Sander 2013-10-18 10:34:22 UTC
Created attachment 82914 [details]
Example pdf file
Comment 2 Oliver Sander 2013-10-18 10:34:51 UTC
Created attachment 82915 [details]
The movie played by the pdf
Comment 3 Oliver Sander 2013-10-18 10:35:15 UTC
Created attachment 82916 [details]
The corresponding tex sources
Comment 4 Albert Astals Cid 2013-10-19 17:06:30 UTC
Git commit 5955d97af740709afa50f2a74ba63faa513ccb15 by Albert Astals Cid.
Committed on 19/10/2013 at 17:05.
Pushed by aacid into branch 'KDE/4.11'.

Fix Movie player controls sometimes only show up at the first playing of the movie
FIXED-IN: 4.11.3

M  +1    -0    ui/videowidget.cpp

http://commits.kde.org/okular/5955d97af740709afa50f2a74ba63faa513ccb15
Comment 5 Oliver Sander 2013-10-19 21:12:47 UTC
Thanks, Albert.  Maybe it's too late in the day, but I don't actually see any difference with the patch.  The bug is still there.  Is that possible?
Comment 6 Albert Astals Cid 2013-10-20 16:09:42 UTC
It's probably too late in the day.
Comment 7 Oliver Sander 2013-10-28 20:50:01 UTC
I have recently updated my entire system to Debian testing, and recompiled poppler and okular (from git master) from scratch.  That was earlier in the day :-) still I keep having the same problem as described originally.  Albert, can you recommend something that I could do to help and debug this?
Comment 8 Albert Astals Cid 2013-10-28 23:00:20 UTC
Only reason i can find is that you're not compiling or running it correctly. Add some code that crashes in VideoWidget::play, compile and run, and if it does not crash, it's because you're doing something wrong.

Some code that crashes:
int *a = 0; *a = 33;
Comment 9 Oliver Sander 2013-10-29 13:16:34 UTC
I purged the system okular + libraries from my computer, just to be sure I am not secretly starting that one.

I cannot make okular crash by placing that line into VideoWidget::play, and not by putting it into the VideoWidget constructor, either.  I can make it crash, however, when putting it into main(), or into Shell::fileOpen().  Does it make sense to try more places?  Since I don't know KDE/QT programming I would need some help on what places to try.
Comment 10 Albert Astals Cid 2013-10-29 14:00:38 UTC
Read the last bit of http://okular.kde.org/download.php
Comment 11 Oliver Sander 2013-10-29 14:11:34 UTC
Oh stupid me.
I know what it says on that page, and I had followed those instructions.  But on rechecking I remembered that I had a second old instance of okular compiled and forgotten a while ago in a temporary directory.  And of course the relevant paths pointed to that one first...
Anyway, apologies, and many thanks for your time.
Comment 12 Albert Astals Cid 2013-10-29 14:22:28 UTC
Just to confirm, the fix is working, right?
Comment 13 Oliver Sander 2013-10-29 14:35:23 UTC
Yes, thank you.