Bug 326054 - Focus not given to chat window
Summary: Focus not given to chat window
Status: RESOLVED DUPLICATE of bug 310442
Alias: None
Product: telepathy
Classification: Unclassified
Component: chat-plasmoid (show other bugs)
Version: 0.6.3
Platform: Archlinux Packages Linux
: NOR minor
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-15 15:25 UTC by Ovidiu-Florin BOGDAN
Modified: 2013-11-13 10:04 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ovidiu-Florin BOGDAN 2013-10-15 15:25:10 UTC
By Focus, I mean the chat window selected and the text field in focus, so I can type new messages.
The following happens when using tabbed view for chat window.
Focus is not given to chat window sometimes when I close a tab (chat with another person) or open a new tab (usually from krunner).
I have to click on the chat window in order to restore focus, so I can type a new message.

Reproducible: Sometimes

Steps to Reproduce:
1. start a chat with another person
OR
1. Close a current chat (tab)
Actual Results:  
Focus, sometimes is not given to the typing area, thus, you cannot type a new message.

Expected Results:  
Focus always to be given to the typing area.

I have not tested this without the tabbed view, but I will if necessary.
Comment 1 Siddhartha 2013-10-17 20:05:18 UTC
Confirming this.

Using packages from git master
Using tabbed view

Opening a new window from contact list gives focus to window but not to the text area. If no interaction is done with text-ui, opening successive tabs also does not give focus to the text area. However, once the focus is set in any of tab, subsequent new tabs gives the focus to the text field properly.
Comment 2 David Edmundson 2013-11-13 10:04:33 UTC

*** This bug has been marked as a duplicate of bug 310442 ***