Bug 326018 - freezes when I attempt to use the sharpen/refocus tool
Summary: freezes when I attempt to use the sharpen/refocus tool
Status: RESOLVED DOWNSTREAM
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Editor-Sharpen (show other bugs)
Version: 3.2.0
Platform: Microsoft Windows Microsoft Windows
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-14 18:05 UTC by tmwb723
Modified: 2020-08-12 12:54 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tmwb723 2013-10-14 18:05:53 UTC
I am attempting to sharpen an image using refocus, but no matter what number I use the program acts like it's working but doesn't sharpen the image.  It just seems to freeze.  I can't cancel or anything, but have to close down the program in order to continue editing images.  

Reproducible: Always

Steps to Reproduce:
1.Import Image
2.Select Sharpen tool
3.Click on "ok"
Actual Results:  
I got the wait icon for my mouse and wasn't able to cancel or finish sharpening the image, even after 10 minutes of waiting.

Expected Results:  
I expected the image to take some time, but evetutally show me an "after" image different than the "before" image.
Comment 1 caulier.gilles 2013-10-15 04:54:35 UTC
This problem have been fixed in more recent release. Please try 3.4.0 or 3.5.0 version as well.

Gilles Caulier
Comment 2 caulier.gilles 2014-01-28 17:46:11 UTC
what's news here using digiKAm 3.4.0 for windows ?

Gilles Caulier
Comment 3 Metko 2014-01-29 12:26:29 UTC
Don't know for windows, but on OpenSUSE 12.3 (64 bit, KDE 4.12.1) the error still persists. I compiled digikam (downloaded source tarball version 3.5.0 from the digikam website) with a newer version of eigen3, which was held responsible previously for this bug. Can't identify the package that provides libclapack, which might be another candidate. Let me know what other information you guys would like to see, or what output I should post.

The last version of digikam with a working refocus tool for me was 3.1.0.
Comment 4 Metko 2014-02-06 15:55:29 UTC
Trying to track down the error myself it turned out that I had compiled digikam successfully, but that the version from the repositories was run instead. When I run the compiled version, the error is gone indeed, i.e. refocus works alright. The sources have an #ifdef HAVE_EIGEN3; therefore, I figure the problem is in the OpeSUSE build system.
Comment 5 caulier.gilles 2014-02-06 16:59:25 UTC
Ok thanks for the feedback...

Gilles Caulier
Comment 6 Metko 2014-02-07 08:54:06 UTC
Although the bug is a conditional one, it is still a bug I would say. People running a binary that was built with the proper eigen3 library will not experience any problems with the sharpen tool, true. But if eigen3 was not present when building the sharpen tool, then the user still encounters this problem, i.e. an unresponsive refocus function. Clean solutions would either disable the refocus method in the sharpen tool when eigen3 was not present or not build the sharpen tool altogether under this circumstance.
Comment 7 caulier.gilles 2014-02-07 09:28:42 UTC
>But if eigen3 was not present when building the sharpen tool, then the user still encounters this >problem, i.e. an unresponsive refocus function.

==> Impossible: if eigen is present digiKam will be compiled with it. If it not present, it do not compile and Refocus feature is disabled...

Giles Caulier
Comment 8 Metko 2014-02-07 14:06:53 UTC
You're right, digikam can't be built without eigen3. Now it's even more puzzling how the buggy version in the OpenSUSE repos is fabricated. I know, that's not your concern, but here is a suggestion: Could the check for eigen3 in the bootstrap.linux be made more specific in the sense that not only the presence is tested, but also if it has at least a specific version? Just an idea...
Comment 9 caulier.gilles 2014-02-07 14:51:23 UTC
Eigen3 dependency is just detected as well.

Eigen3 share headers and which are used to build digiKam.

It's possible that Eigen3 need dependencies too. This is what i search in this case. Perhaps these extra stuff are missing (this must break digiKam as well normally) or uncomplete/corrupted.

In all case report this problem to OpenSuse team. It's clear that it's a packaging problem...

Gilles Caulier
Comment 10 Raymond Wooninck 2014-02-08 10:38:00 UTC
To confirm the setup, I have checked the digikam package based on the indications that Metko is running openSUSE 12.3 with KDE 4.12.1.  openSUSE 12.3 itself does not provide the eigen3 library and therefore the digikam package is build without it. Validating the buildlog for this particular setup indicates the following

[  279s] --  libpgf library found..................... YES (optional)
[  279s] --  Eigen3 library found..................... NO  (optional)
[  279s] --
[  279s] --  digiKam will be compiled without Refocus tool support.
[  279s] --

So as Gilles indicated, the Digikam for an openSUSE 12.3 system lacks (correctly) the Refocus tool. 

Raymond
openSUSE KDE Community team
Comment 11 Metko 2014-02-10 12:44:10 UTC
Yes, I see this also in my local build, but when I look down further it says

--  digiKam can be compiled.................. YES
-- ----------------------------------------------------------------------------------
--
-- Adjusting compilation flags for GCC version ( 4.7.2 )
-- Configuring incomplete, errors occurred!

and no Makefile is generated. If I understand Gilles correctly, this is the intended behavior. How about in your build, Raymond? The question then is, what Makefile is used for building?

I have now installed digikam version 3.2.0 from the openSUSE 12.3 system repos. What Raymond calls "lack of the Refocus tool" is exactly the behavior that gave rise to the discussion here: It is possible to select the Refocus tool very well to start and to stop it. It is just doing nothing and running for ever. I wouldn't call this "lacking".
Comment 12 Metko 2014-02-20 18:19:33 UTC
Hi Raymond,

i wonder if you saw my message. In my local build the Makefile is not
generated if Eigen3 is missing, even if there is a line stating that
digikam will be compiled without refocus tool. If this is the case in
your build system too, then probably an old Makefile is used for
building digikam.

Best,

               ALEX.


2014-02-08 11:38 GMT+01:00 Raymond Wooninck <tittiatcoke@gmail.com>:
> https://bugs.kde.org/show_bug.cgi?id=326018
>
> Raymond Wooninck <tittiatcoke@gmail.com> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |tittiatcoke@gmail.com
>
> --- Comment #10 from Raymond Wooninck <tittiatcoke@gmail.com> ---
> To confirm the setup, I have checked the digikam package based on the
> indications that Metko is running openSUSE 12.3 with KDE 4.12.1.  openSUSE 12.3
> itself does not provide the eigen3 library and therefore the digikam package is
> build without it. Validating the buildlog for this particular setup indicates
> the following
>
> [  279s] --  libpgf library found..................... YES (optional)
> [  279s] --  Eigen3 library found..................... NO  (optional)
> [  279s] --
> [  279s] --  digiKam will be compiled without Refocus tool support.
> [  279s] --
>
> So as Gilles indicated, the Digikam for an openSUSE 12.3 system lacks
> (correctly) the Refocus tool.
>
> Raymond
> openSUSE KDE Community team
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 13 Raymond Wooninck 2014-02-20 18:36:05 UTC
(In reply to comment #11)
> Yes, I see this also in my local build, but when I look down further it says
> 
> --  digiKam can be compiled.................. YES

This statement is correct as that Eigen3 was declared as an optional requirement. 

> and no Makefile is generated. If I understand Gilles correctly, this is the
> intended behavior. How about in your build, Raymond? The question then is,
> what Makefile is used for building?

With our build a makefile is correctly generated.  We have the following output:
[  235s] --  Doxygen found............................ YES (optional)
[  235s] --  digiKam can be compiled.................. YES
[  235s] -- ----------------------------------------------------------------------------------
[  235s] -- 
[  235s] -- Adjusting compilation flags for GCC version ( 4.7.2 )
[  235s] -- Looking for dgettext
[  236s] -- Looking for dgettext - found
[  236s] -- Found Gettext: built in libc
[  236s] -- Configuring done
[  240s] -- Generating done
[  240s] -- Build files have been written to: /home/abuild/rpmbuild/BUILD/digikam-3.5.0/build

> I have now installed digikam version 3.2.0 from the openSUSE 12.3 system
> repos. What Raymond calls "lack of the Refocus tool" is exactly the behavior
> that gave rise to the discussion here: It is possible to select the Refocus
> tool very well to start and to stop it. It is just doing nothing and running
> for ever. I wouldn't call this "lacking".

That is something that I don't control. As indicated eigen3 is an optional package and digikam should be able to be build without it. If the Refocus tool can still be started, is a different discussion. But before you installed the package from the openSUSE system, did you removed the locally build package ?  However be aware that digikam version 3.5.0 is available from the openSUSE Build Service.