Bug 325945 - kdeplasma-applets-plasma-nm loses 'active connections
Summary: kdeplasma-applets-plasma-nm loses 'active connections
Status: RESOLVED INTENTIONAL
Alias: None
Product: plasma-nm
Classification: Unclassified
Component: applet (show other bugs)
Version: 0.9.3.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jan Grulich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-13 03:57 UTC by gene c
Modified: 2014-04-23 06:56 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
xsession log (363.22 KB, text/plain)
2013-10-15 00:54 UTC, gene c
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gene c 2013-10-13 03:57:15 UTC
I used it to connect to local wifi - worked fine. Left my laptop
and returned a couple hours later. I am still connected - and the hover
pop up shows the connection and correct SSID. However clicking the
applet no longer shows an active connection section. No way to disconnect.

   There is a previous connection (also no 'unknown connections'
section) but it had nothing useful (just a connection out of my list not
used for years).

   After a few minutes the SSID I was connected to showed up in the
'previous connections' section - with a button to 'connect'. Clicking
that, the connection was killed and re-establihsed and the 'active
connections' section re-appeaed with the connected SSID now visible. The
unkown connection  section also re-appeared. 

Version: kdeplasma-applets-plasma-nm 0.9.3.0-2

On Arch linux Fully up to date testing repo: kernel 3.12 rc4
KDE : 4.11.3
Comment 1 Jan Grulich 2013-10-13 09:32:03 UTC
Is your problem reproducible always? Can you please enable plasma-nm (monitor and model) in kdebugdialog and when you run into this problem again, can you please send here some info from .xseesion-errors file? It should look like this output:

plasma-desktop(1520)/Plasma-nm (monitor) Monitor::wirelessNetworkAppeared: Wireless network  "Epsilon105"  appeared
plasma-desktop(1520)/Plasma-nm (model) Model::insertItem: Connection  "Epsilon105"  has been added
plasma-desktop(1520)/Plasma-nm (monitor) Monitor::wirelessNetworkDisappeared: Wireless network  "wifina"  disappeared
plasma-desktop(1520)/Plasma-nm (model) Model::removeWirelessNetwork: Wireless network  "wifina"  has been completely removed
plasma-desktop(1520)/Plasma-nm (monitor) Monitor::wirelessNetworkDisappeared: Wireless network  ".dom."  disappeared
plasma-desktop(1520)/Plasma-nm (model) Model::removeWirelessNetwork: Wireless network  ".dom."  has been completely removed
Comment 2 Lamarque V. Souza 2013-10-13 11:23:17 UTC
Just for the record: sometimes I face this problem too. In may case I think it may be related to suspend to ram. It is not always reproducible.
Comment 3 gene c 2013-10-13 13:05:02 UTC
I left this running overnight and no problems at all. When it did happen i did not suspend the laptop - so in my case that was not the issue.

I've enabled the kdedebug and will keep you apprised.

PS. This site looks bad for me using chrome dev.
Comment 4 gene c 2013-10-15 00:54:22 UTC
Created attachment 82854 [details]
xsession log

Fresh boot today - connected to network SpecialVisitor.
Put laptop to sleep - awoke and it auto connected to HumptyDumpty-gc-N5.

The app now only shows 'Unkown Connections' - the active and previous lists are gone..

logfile attached.
Comment 5 gene c 2013-10-15 01:08:25 UTC
After a few minutes it recovered and all 3 items are now back to normal - active and prev are now visible. I did not do anything (like force a reconnect). It just 'fixed' itself.

I do also note that there are many apparent dups of same SSID in the unknown list  (hpsetup for example appears over 30 times in the list. Similar for other SSIDs.
Comment 6 Jan Grulich 2013-10-15 20:44:44 UTC
Git commit 8f4c0fc26118481ecec1d7ce024a16d3461f1852 by Jan Grulich.
Committed on 15/10/2013 at 20:43.
Pushed by grulich into branch 'master'.

Display wireless icon with full signal for shared connections

M  +11   -0    declarative-plugins/model/modelitem.cpp

http://commits.kde.org/plasma-nm/8f4c0fc26118481ecec1d7ce024a16d3461f1852
Comment 7 Jan Grulich 2013-10-15 20:44:45 UTC
Git commit dce686c21cc73669082bd54b1bec177b8d385377 by Jan Grulich.
Committed on 15/10/2013 at 20:44.
Pushed by grulich into branch 'master'.

Do not remove shared connection when it is disconnected

M  +2    -4    declarative-plugins/model/model.cpp

http://commits.kde.org/plasma-nm/dce686c21cc73669082bd54b1bec177b8d385377
Comment 8 Jan Grulich 2013-10-15 20:49:00 UTC
Do not pay attention to the commits above, I mistook bugs.
Comment 9 gene c 2013-10-20 04:47:18 UTC
Any progress on fixing this issue?
Comment 10 Jan Grulich 2013-10-20 09:13:06 UTC
Not yet, because I don't know where could be a problem, because the log looks okay and when everything were recoverd after some time, it looks like NetworkManager notify about changes with a delay. So far I don't see any problem from plasma-nm side.
Comment 11 gene c 2013-10-20 18:02:38 UTC
Well its still happening all the time - i don't know how to take a screen shot of it because the popup pops down when i move to screenshot.

However as of now it shows top entry as previous connections, next entry as unknown and other than the green ball below next to connected there is nothing else - so the 'active' connections item is gone. Disconnecting and reconnecting restores it but only temporarily.

I have slept / resumed as well but the first time this happened that was not the case.
Comment 12 gene c 2013-10-24 03:35:15 UTC
Today the popup is completely useless - only thing was a huge number of unknown connections (none of which are within 50 miles of me).

The only way to get it to do anything was to turn of wireless and restart.

2 pieces of information - 

(1) this is a multi router setup (all on same SSID). This may be required to trigger this bug.

(2) I saw this in log today - perhaps it's of use:

plasma-desktop(1836)/Plasma-nm (model) Model::insertItem: Connection  "DIRECT-roku-321"  has been added
kded(1571)/networkstatus NetworkStatusModule::solidNetworkingStatusChanged: SolidNetwork changed status:  3
kded(1571)/networkstatus NetworkStatusModule::setNetworkStatus: "SolidNetwork" ,  3
void NetworkManager::NetworkManagerPrivate::propertiesChanged(const QVariantMap&) Unhandled property "ActivatingConnection" 
plasma-desktop(1836)/Plasma-nm (monitor) Monitor::availableConnectionAppeared: New available connection  "ShowMeYourPants" 
 for  "/sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/net/wlan0"


I have no idea what 'SolidNetwork' is - there is certainly no such SSID around here. There is a roku box however tho it has never been connected to.

When the popup is a mess it would be real nice if there was some more elegant way to make it clean itself up.

I
Comment 13 gene c 2013-10-24 11:01:52 UTC
More info - when I click on the active connection - the info is partly masked - this is in my view totally the wrong design. 

Here's a suggestion - enhance the 'edit connection's window to manage active connections - make it so you can connect and open a new window with full connection details from there - that would be a great app. Using the menu popup thing should only be for casual brief viewing.

Please consider this request - this could be an awesome and useful tool.

Leave the popup thing for quick casual info but for the heavy lifting please make a real application out of the edit connections window.

Thanks.
Comment 14 Jan Grulich 2014-04-22 13:25:13 UTC
Is this problem still reproducible with the latest version of plasma-nm?
Comment 15 gene c 2014-04-22 16:39:01 UTC
I have not experienced this lately (now running kde 4.13).
You can close this one - any thoughts on making a connection application windows?