Bug 325918 - Password field loses focus on language (keyboard layout) change
Summary: Password field loses focus on language (keyboard layout) change
Status: RESOLVED DUPLICATE of bug 319935
Alias: None
Product: kscreensaver
Classification: Unclassified
Component: locker-qml (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-12 11:24 UTC by athlion
Modified: 2013-10-12 15:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description athlion 2013-10-12 11:24:12 UTC
When my screen is locked (I'm using KDE 4.11.2 but I can remember this happening all the way down to KDE 4.9) the password field is focused and I can type my password right away. 

If, on the other hand, the keyboard layout currently active is not my desired one and I want to switch it (by pressing left Alt+left Shift), the layout changes but the password field loses focus. I can no longer type my password unless I click on the password field or hit Alt+p, which is annoying! 

Reproducible: Always

Steps to Reproduce:
1. Have more than one keyboard layouts active (change them by left Alt+left shift).
2. Lock the screen.
3. Change the layout using the key combination (left Alt+left shift).
4. Password field is no longer in focus.
Actual Results:  
The password field was no longer in focus and I could not type in my password unless I re-focused it myself.

Expected Results:  
The password field should have retained its focus.
Comment 1 Christoph Feck 2013-10-12 15:14:02 UTC

*** This bug has been marked as a duplicate of bug 319935 ***