Bug 325917 - Window "Select tag" (Filter tag is missing) appears after closing filter settings window with valid settings
Summary: Window "Select tag" (Filter tag is missing) appears after closing filter sett...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.11.2
Platform: OpenSUSE Linux
: NOR normal with 80 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 326068 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-12 11:14 UTC by Roman Inflianskas
Modified: 2021-01-21 08:06 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
1. Just marked message with new tag (137.00 KB, image/png)
2013-10-15 15:31 UTC, Roman Inflianskas
Details
2. Added filter (24.55 KB, image/png)
2013-10-15 15:36 UTC, Roman Inflianskas
Details
3. Pressed Apply button in Filter Rules dialog (64.51 KB, image/png)
2013-10-15 15:39 UTC, Roman Inflianskas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Inflianskas 2013-10-12 11:14:19 UTC
I use gmail via IMAP. I want to mark messages automatically, so I created tag, than I created filter with action "Add tag". On closing window "Select tag" (Filter tag is missing) appears. I also use groupware (owncloud), so my tag list also contains tags from owncloud calendar.

Reproducible: Always
Comment 1 Laurent Montel 2013-10-15 14:37:00 UTC
could you paste screenshot about your problem ?
I didn't understand what do you do to show bug.
You want to create filter so you will create tag where ?
Comment 2 Roman Inflianskas 2013-10-15 15:31:15 UTC
Created attachment 82860 [details]
1. Just marked message with new tag

I just created new tag via message context menu -> Mark message -> Add new tag. Here comes another bug (should I create separate report?) — tons of duplicated tag "pyqt list".
Comment 3 Roman Inflianskas 2013-10-15 15:36:28 UTC
Created attachment 82861 [details]
2. Added filter

I created new filter with 1 action. As you can see I have no choices: all other tags (pc, health, ... from to-do lists created in Owncloud Groupware calender) disappeared.
Comment 4 Roman Inflianskas 2013-10-15 15:39:11 UTC
Created attachment 82862 [details]
3. Pressed Apply button in Filter Rules dialog

I pressed Apply button in Filter Rules dialog and got this window. As you can see "pyqt list" remained in Filter Actions.
Comment 5 Feth Arezki 2013-12-17 20:43:14 UTC
Same here with 4.11.3 on debian unstable.
The label specified in the action part of the filter is forgotten: when I edit the filter again, an action "tag" is still selected, but the selected tag is "task list" (first of the drop down).
Comment 6 Feth Arezki 2014-01-28 06:59:43 UTC
Also, I tried exporting the filters, this is what they look like: 

[Filter #0] 
Applicability=0
AutomaticName=true
ConfigureShortcut=false
ConfigureToolbar=false
Enabled=false
Icon=system-run
StopProcessingHere=true
ToolbarName=<List-Id>: <<mangled list name>>
action-args-0=
action-name-0=add tag 
actions=1
apply-on=check-mail,before-send-mail,send-mail,manual-filtering
contentsA=<<mangled list name>>
fieldA=List-Id
funcA=contains
identifier=c4JqXgP1PJDAWS7T
name=<List-Id>: <<mangled list name>>
operator=and
rules=1

We can see that arg0 is empty here.
When I reimport this filter with the arg0 filled in, kmail2 asks me for the correct label because it can't match it and forgets it nonetheless when I click "apply".
Comment 7 der_fenix 2014-02-17 21:47:49 UTC
Confirm this bug. KMail 4.12.2
Comment 8 Lassi Väätämöinen 2014-02-25 08:33:32 UTC
Happens also with Ubuntu 12.04, with Kmail2 from PPA.

KMail
Version 4.12.2
Comment 9 Luis Silva 2014-04-07 17:42:34 UTC
*** Bug 326068 has been marked as a duplicate of this bug. ***
Comment 10 Todd Kennedy 2014-07-22 15:00:03 UTC
Confirmed in Opensuse 13.1 KMail 4.11.5. I would love to help find this if I knew where to look.
Comment 11 Denis Kurz 2016-09-24 18:11:43 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 12 Denis Kurz 2017-01-07 21:55:58 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.
Comment 13 Lassi Väätämöinen 2021-01-21 08:06:51 UTC
*** This bug has been confirmed by popular vote. ***