Bug 325887 - DAV connector halts if resources names are duplicated
Summary: DAV connector halts if resources names are duplicated
Status: RESOLVED DUPLICATE of bug 284783
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: DAV Resource (show other bugs)
Version: 4.11
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-11 12:10 UTC by nmset
Modified: 2014-01-31 21:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nmset 2013-10-11 12:10:14 UTC
With Owncloud 5.x
A contact resource named FOO
A calendar resource named FOO
=> The KDE akonadi DAV resource connector stops to work completely.
Rename one of the resources => works perfectly.
On Android, the connectors CalDav-Sync and CardDav-Sync do not report errors with resources of similar name.
Using mysql backend. Could be a unique index problem in the akonadi database.

Could not find a similar report. Sorry if duplicate.

Regards.


Reproducible: Always

Steps to Reproduce:
1.Create calendar and contact resources of similar name in OwnCloud
2.Connect with akonadi
3.
Actual Results:  
No resource is displayed

Expected Results:  
All resources should be usable
Comment 1 Alvaro Soliverez 2014-01-03 00:11:49 UTC
Probably a duplicate of bug 327363. This one is older but the other one is better documented
Comment 2 Martin Koller 2014-01-31 21:49:13 UTC

*** This bug has been marked as a duplicate of bug 284783 ***