Bug 325868 - 'System default' setting for font sub-pixel-hinting does not change the setting at all, just keeps the old setting
Summary: 'System default' setting for font sub-pixel-hinting does not change the setti...
Status: RESOLVED DUPLICATE of bug 244857
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_fonts (show other bugs)
Version: 4.11.2
Platform: Gentoo Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-10 23:48 UTC by Michael
Modified: 2014-07-15 14:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2013-10-10 23:48:05 UTC
When configuring the font options the default setting is 'System default'. I do not know where KDE takes this 'default' from. But in my case, it does not change the setting at all.

For example setting RGB sub-pixel-hinting and applying the settings, then switching to 'system default' leaves KDE with RGB sub-pixel-hinting. Setting it to 'active' with BGR sub-pixel order, applying, and then resetting it to 'System default' leaves KDE with BGR sub-pixel-hinting.

nvidia-binary driver 325.15 on 3.11 kernel, xorg-server 1.14.3

Reproducible: Always
Comment 1 Michael 2013-10-11 12:06:15 UTC
Expected results: The setting 'System default' should set it to some configuration not depending on KDE.

An additional tooltip that hints at what lib/subsystem/component is responsible would be also useful.
Comment 2 Andrea Iacovitti 2014-07-15 14:27:01 UTC

*** This bug has been marked as a duplicate of bug 244857 ***